VirtualBox

Ticket #4599 (closed defect: wontfix)

Opened 5 years ago

Last modified 5 years ago

Guest additions mouse movements only one way

Reported by: jdshewey Owned by:
Priority: minor Component: guest additions
Version: VirtualBox 3.0.2 Keywords: Cursor, Mouse, Pointer
Cc: Guest type: Windows
Host type: Linux

Description

I am trying to use a program like autoit (download is free) to move the mouse cursor to a location on the screen. (Eg.: MouseMove(150, 150, 0)) If you enable "Show location of pointer when I press the CTRL key" under Mouse Properties (Under the Pointer Options tab) and press control after executing a script using the command in the guest, it will show that the mouse has moved to the specified location in the guest. This is different from the actual location of the host cursor. If you make any movements to the host cursor, it will warp the guest cursor to the location of the host cursor. In other words, mouse movements are only one-way. If the mouse is moved within the guest, the host does not move the mouse accordingly.

I am using a Windows XP Guest with an Ubuntu 9.04 host and VirtualBox 3.0.2

Change History

comment:1 Changed 5 years ago by frank

This is not a bug but a feature. The guest is untrusted by definition and therefore not allowed to move the host mouse pointer. If you require this functionality you could disable the mouse integration -- then you should see that the guest mouse pointer (which is now different from the host pointer) can be moved.

comment:2 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to wontfix
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use