VirtualBox

Ticket #4567 (closed defect: fixed)

Opened 5 years ago

Last modified 3 years ago

Internal network stops working after suspend

Reported by: greenrd Owned by:
Priority: major Component: network/hostif
Version: VirtualBox 3.0.2 Keywords:
Cc: Guest type: Linux
Host type: Mac OS X

Description

This is with OSE 3.0.2 with two Linux guests on an internal network. After suspending the host, the guests also suspend as expected, and automatically resume, and when I try to use the internal network, it doesn't work. Cannot connect to the other machine and pings fail. Bringing down and up the interface on both machines does not change anything.

Each guest has 2 network cards; all 4 are the same type. On one of the guests, the internal networking is attached to the first network card; on the other, it's attached to the second. The other network cards are NAT. The NAT network cards are both configured to do DNS masquerading.

Attachments

VBox.log Download (44.8 KB) - added by greenrd 5 years ago.
Log file for first machine
VBox.2.log Download (38.2 KB) - added by greenrd 5 years ago.
Log file for second machine

Change History

Changed 5 years ago by greenrd

Log file for first machine

Changed 5 years ago by greenrd

Log file for second machine

comment:1 Changed 5 years ago by greenrd

It turns out it doesn't require a suspend - it seems to be caused by the network being left almost idle for a period of time (although there may be some operating system packets transmitted, so I don't know if it's completely idle).

comment:2 Changed 5 years ago by greenrd

This still happens on VirtualBox 3.0.6.

comment:3 Changed 4 years ago by eskild

I see the same problem with suspend/resume on 3.0.6. Host: WinXP; guest: Fedora Core 10 with e1000 NIC.

comment:4 Changed 4 years ago by greenrd

I am no longer experiencing this bug - I think due to upgrading my guests.

comment:5 Changed 4 years ago by frank

eskild, I'm quite sure that this bug was fixed in 3.0.8, please verify.

comment:6 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if this problem persists, 3.0.10 is about to be released.

comment:7 Changed 4 years ago by castorinop

  • Status changed from closed to reopened
  • Resolution fixed deleted

i using 3.2.8 OSE and fail again

comment:8 Changed 3 years ago by frank

  • Component changed from network to network/hostif

comment:9 Changed 3 years ago by aleksey

Can anybody confirm that the problem is present in 4.0.4 and provide VBox.log?

comment:10 Changed 3 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

No response, closing.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use