VirtualBox

Ticket #4530 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

Copy/Paste not working in Windows host-> fixed in 3.0.6

Reported by: shreks Owned by:
Priority: major Component: guest additions
Version: VirtualBox 3.0.6 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

This bug is very similar to bug 4380. Instead it is on Windows host this time. I am running VirtualBox 3.0.2 on my Windows XP and the guest OS is Ubuntu Linux 9.04. What I have found is that, after enabling the bidirectional shared clipboard for Ubuntu guest and entering Ubuntu desktop, the copy/paste functions of windows file manager in Windows XP are disabled, an exact symptom happening on Windows XP guest OS for VirtualBox 3.0.0 running on Fedora 11 host.

Attachments

VBox.log Download (56.0 KB) - added by shreks 5 years ago.
GordonDev2-2009-09-14-10-51-04.log Download (47.0 KB) - added by gordonlukch 5 years ago.
Linux 32bit guests could not shared clipboard to Host and other guests

Change History

Changed 5 years ago by shreks

comment:1 Changed 5 years ago by michael

Did you update the Guest Additions on the Ubuntu guest to version 3.0.2?

comment:2 Changed 5 years ago by shreks

Oh, thanks for your reminding. I did forget to upgrade the guest additions tool to 3.0.2. Now everything works as expected. Thank you!

comment:3 Changed 5 years ago by shreks

And please close this bug, thanks!

comment:4 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Version changed from VirtualBox 3.0.2 to VirtualBox 3.0.0
  • Resolution set to fixed
  • Summary changed from Copy/Paste not working in Windows host to Copy/Paste not working in Windows host-> fixed in 3.0.2

comment:5 Changed 5 years ago by gordonlukch

  • Status changed from closed to reopened
  • Resolution fixed deleted

Exactly Same Problem!!!

VB version : 3.02 r49928 Host OS: Linux Ubuntu 9.04 (64 Bits) Guest OS: Windows XP Professional SP2 with GA (version same as VB)

It work fine on Ubuntu 9.04 guest (32 Bits). But XP guest not stable, just work for a moment.

comment:6 Changed 5 years ago by michael

gordonlukch: if you are interested in helping to solve this, you might want to try running a test build of VirtualBox (disclaimer  here) to help track down the problem. A temporary link to the test build is:

 http://www.virtualbox.org/download/testcase/VirtualBox-2009-07-30-22-14-17-lin64-3.0-3.0.3-r50558.run

If you remove your current version of VirtualBox, install the test build and run it with the following environment variable set:

VBOX_RELEASE_LOG=+clipboard.e.l.l2.l3.f

it will provide additional information in the log file which may help to track down the problem.

comment:7 Changed 5 years ago by Mark_Simmons

Also seeing issues with clipboard copying from Ubuntu 9.04(Host) to Windows XP SP3(Guest).

This is using VirtualBox version 3.0.2 r49928 installed via repository.

Here's the behaviour:

1) Copying from XP(G) to Ubuntu(H) using 'Guest to Host' clipboard sharing works perfectly.

2) Copying from Ubuntu(H) to XP(G) using 'Host to Guest' clipboard sharing fails to transfer data from Ubuntu(H) to XP(G) and then leaves the XP(G) clipboard cleared and in an unusable state (subsequent copying of data in XP(G) then fails to appear in the Windows clipboard - fixed by restarting Guest or killing VBoxTray.exe)

3) Copying from XP(G) to Ubuntu(H) using 'Bidirectional' clipboard sharing works perfectly when clipboard transfer is from XP(G) to Ubuntu(H), but *only* if I have not previously copied anything in Ubuntu(H) to the clipboard. If I do, I end up in the same situation as in point 2.

So, basically, it's the transfer of clipboard data from Ubuntu to XP that looks very broken in some way.

comment:8 Changed 5 years ago by michael

Mark_Simmons: does killing the X11 application holding the clipboard make the XP guest clipboard work again?

comment:9 Changed 5 years ago by Mark_Simmons

No, I'm afraid not. Once it happens, it can only be fix as I mentioned.

However, I've also just noticed that, if I also run a Windows clipboard manager (in this case Ditto) under the XP Guest machine that Ditto's clipboard list flickers (as if it is continually seeing a change in clipboard state) when 'Host to Guest' or 'Bidirectional' is enabled and something it copied to the Ubuntu clipboard.

This odd 'flickering/update' behaviour does not occur when 'Guest to Host' clipboard copying is enabled, *or* from what I can see, in 'Bidirectional'before the first Ubuntu copy.

This tends to give me the impression that, once something is copied to the Ubuntu clipboard, VirtualBox under Ubuntu is repeatedly chucking clipboard data at the Guest, rather than just transfering data once when the clipboard is updated. It would certainly seem to explain the behaviour I described above where the Guest's clipboard is fine, until Ubuntu copies something to its own clipboard, and then the Guest's clipboard starts getting hammered to the point that it cannot respond properly.

Does this sound the slightest bit feasible?

As another point of interest is that, if running, Ditto actually captures the clipboard transfer data coming from Ubuntu(H) to XP(G), but the XP(G) native clipboard stays blank.

comment:10 Changed 5 years ago by Marji

I have the same problem. Virtual Box 3.0.2 r49928 host: windows XP Professional Ver 2002 Service Pack 3 guest: Ubuntu 9.04 i386

When I start the Ubuntu VM, everything works fine. After a few copy and paste operations between the host (Windows XP) and guest (Ubuntu), it becomes nonfunctional. Sometimes only one direction is broken. Restarting the VM usually helps.

I do have the latest VBox additions installed.

I have had this problem for the last 8 months - with all the latest versions of VirtualBox (I started with the version valid in 12/2009, and kept upgrading).

I'm happy to debug, provide more details or install a debug / development version ov VB to provide more details.

Please help me to contribute to solution of this problem.

Marji

comment:11 Changed 5 years ago by michael

Update: I am currently working on this. It is a bit tricky as I can't reproduce it myself, but I have a definite suspicion as to what is wrong (confirmed by the behaviour that Mark_Simmons sees in the clipboard manager).

comment:12 Changed 5 years ago by Mark_Simmons

Michael,

Just a couple of additions that I forgot to mention before:

1) Although, as mentioned before, Ditto (when running) on XP(G) captures the incoming clipboard data, it cannot write data back to the clipboard, which it normally can with no problems.

2) Although the paste option is available in XP(G), either on the right-click context menu, or normal app menu, which indicates the system clipboard has data, nothing can be pasted from the clipboard.

Again, once the problem occurs, it almost appears as if both the normal Windows cut/copy commands and Ditto are being completely locked out of the system clipboard by VirtualBox (Additions) in some way.

I've also now replicated this same behaviour on another separate Ubuntu 9.04 Host PC with a fresh install of VirtualBox v3.0.4 r50677 and a clean Guest VM install of Windows XP SP3. Both Host and Guest are fully patched and up-to-date.

comment:13 Changed 5 years ago by frank

What is the current status with 3.0.6?

comment:14 Changed 5 years ago by gordonlukch

Still problem, not ok on linux guest now.

VB version : 3.06 r52128 Host OS: Linux Ubuntu 9.04 (64 Bits) Guest OS: Windows XP Professional SP2 with GA (version same as VB) Guest OS: Linux Ubuntu 9.04 32 Bits (version same as VB)

OK : Linux Host <--> Windows XP guest Failed : Linux Host <--> Linux Guest

comment:15 Changed 5 years ago by michael

  • Version changed from VirtualBox 3.0.0 to VirtualBox 3.0.6

gordonlukch: does copy and paste fail altogether with that Linux guest? Can you check whether the process "VBoxClient --clipboard" is running on the guest (under your user ID)? If not, can you see if there is a file called .vboxclient-clipboard.pid in your home directory in the Linux guest, and if so delete it? And of course, can you check whether the shared clipboard is enabled for that guest? Failing all that, can you attach a log file from the guest?

Is anyone else subscribed to this ticket still experiencing problems? I will take no answer as a "no"...

comment:16 Changed 5 years ago by gordonlukch

I found "VBoxClient --clipboard" on 32 bit linux guest, i also found the ".vboxclient-clipboard.pid" in my home directory. I tried deleted it, but nothing changed. And i checked my VM shared clipboard setting, it is shared bidirectional.

Changed 5 years ago by gordonlukch

Linux 32bit guests could not shared clipboard to Host and other guests

comment:17 Changed 5 years ago by michael

Could you describe what fails more precisely please? Is it simply that copying and pasting inside guest and host work independently without affecting each other? We are of course talking about copy and paste using the menu item or Ctrl-C, Ctrl-V here. And could you try starting VirtualBox from the command line as follows:

$ VBOX_RELEASE_LOG=+shared_clipboard.e.l.f VirtualBox --startvm [name of your VM]

(replacing [name of your VM] with the actual VM name of course), then trying a few copy and paste operations and sending the log of that session? Thanks!

comment:18 Changed 5 years ago by Mark_Simmons

Michael,

Just to confirm with you on the previous issue I had with clipboard syncing from Ubuntu Jaunty host to a XP SP3 guest; this is now working fine in Virtualbox 3.0.6 r52128 with VBox Additions of the same version.

Bidirectional now works cleanly and immediately and exactly as advertised on two separate installations on Ubuntu Jaunty using an XP SP3 guest VM and Ditto registers the clipboard update from Ubuntu to XP with no issues.

Many thanks for your hard work on this. Very much appreciated!

comment:19 Changed 5 years ago by gordonlukch

At last, i found its all are work (copy & paste) from all guests (32bits) to host (64 bits) or host to guests. Thanks.

comment:20 Changed 5 years ago by michael

  • Status changed from reopened to closed
  • Resolution set to fixed
  • Summary changed from Copy/Paste not working in Windows host-> fixed in 3.0.2 to Copy/Paste not working in Windows host-> fixed in 3.0.6

Thanks for the feedback. I will close this ticket again then.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use