VirtualBox

Ticket #4492 (closed defect: duplicate)

Opened 5 years ago

Last modified 5 years ago

Unable to create raw vmdk on Mac OSX

Reported by: mongrol Owned by:
Priority: major Component: other
Version: VirtualBox 3.0.2 Keywords: vboxmanage raw boot camp
Cc: Guest type: Windows
Host type: Mac OS X

Description

vboxmanage is unable to create a rawdisk vmdk file of a full disk or of selected partitions.

e.g. sudo vboxmanage internalcommands createrawvmdk -rawdisk /dev/disk0 -filename win7raw.vmdk irtualBox Command Line Management Interface Version 3.0.2 (C) 2005-2009 Sun Microsystems, Inc. All rights reserved.

Error while creating the raw disk VMDK: VERR_DEV_IO_ERROR The raw disk vmdk file was not created

listing partitions works ok.

sudo vboxmanage internalcommands listpartitions -rawdisk /dev/disk0 VirtualBox Command Line Management Interface Version 3.0.2 (C) 2005-2009 Sun Microsystems, Inc. All rights reserved.

Number Type StartCHS EndCHS Size (MiB) Start (Sect) 1 0xee 1023/254/63 1023/254/63 200 1 2 0xaf 1023/254/63 1023/254/63 130944 409640 3 0x07 1023/254/63 1023/254/63 21354 268847104

as does selecting the boot camp partition device itself. This does not allow VBox to boot as the bootloader info is on partition 1.

sudo vboxmanage internalcommands createrawvmdk -rawdisk /dev/disk0s3 -filename win7raw.vmdk

VirtualBox Command Line Management Interface Version 3.0.2 (C) 2005-2009 Sun Microsystems, Inc. All rights reserved.

RAW host disk access VMDK file win7raw.vmdk created successfully.

Bug has been present since at least v2.2.4. No idea if it's worked before this as other users have worked around it using VMWare.

Change History

comment:1 Changed 5 years ago by mongrol

Sorry. Report above with better formatting.

vboxmanage is unable to create a rawdisk vmdk file of a full disk or of selected partitions.

sudo vboxmanage internalcommands createrawvmdk -rawdisk /dev/disk0 -filename win7raw.vmdk

VirtualBox Command Line Management Interface Version 3.0.2 (C) 2005-2009 Sun Microsystems, Inc. All rights reserved.

Error while creating the raw disk VMDK: VERR_DEV_IO_ERROR The raw disk vmdk file was not created

listing partitions works ok.

sudo vboxmanage internalcommands listpartitions -rawdisk /dev/disk0 VirtualBox Command Line Management Interface Version 3.0.2 (C) 2005-2009 Sun Microsystems, Inc. All rights reserved.

Number Type StartCHS EndCHS Size (MiB) Start (Sect)
1 0xee 1023/254/63 1023/254/63 200 1
2 0xaf 1023/254/63 1023/254/63 130944 409640
3 0x07 1023/254/63 1023/254/63 21354 268847104

as does selecting the boot camp partition device itself. This does not allow VBox to boot as the bootloader info is on partition 1.

udo vboxmanage internalcommands createrawvmdk -rawdisk /dev/disk0s3 -filename win7raw.vmdk

VirtualBox Command Line Management Interface Version 3.0.2 (C) 2005-2009 Sun Microsystems, Inc. All rights reserved.

RAW host disk access VMDK file win7raw.vmdk created successfully.

Bug has been present since at least v2.2.4. No idea if it's worked before this as other users have worked around it using VMWare.

comment:2 Changed 5 years ago by klaus

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #1461

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use