VirtualBox

Ticket #4413 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

VirtualBox 3.0 reboots system with RHEL 5.3 x64 host OS

Reported by: mbay2002 Owned by:
Priority: major Component: VMM
Version: VirtualBox 3.0.0 Keywords:
Cc: Guest type: other
Host type: Linux

Description

I just upgraded to VirtualBox 3.0 on a RHEL 5.3 machine 64-bit, and when I try to start it up, it brings the whole machine down (hard re-boot). I'm going to revert to 2.2.4 for now... the only thing I can find are a few lines in /var/log/messages:

Jul 6 12:19:20 lx57 kernel: VBoxDrv: dbg - g_abExecMemory=ffffffff88e6db00
Jul 6 12:19:20 lx57 kernel: vboxdrv: fAsync=0 offMin=0x73f offMax=0x1593
Jul 6 12:19:20 lx57 kernel: vboxdrv: TSC mode is 'synchronous', kernel timer mode is 'normal'.
Jul 6 12:19:20 lx57 kernel: VBoxNetFlt: dbg - g_abExecMemory=ffffffff890a9ae0

I can't get a core dump because it crashes hard, I don't even get a VBox.log file. This is kernel 2.6.18-128.1.16.el5

Change History

comment:1 Changed 5 years ago by frank

The messages are harmless. Any chance to test VBox 3.0.2?

comment:2 Changed 5 years ago by mbay2002

Thanks for responding Frank.... I just tried 3.02 and I still get the hard re-boot when I fire it up... going back to 2.2.4...

comment:3 follow-up: ↓ 4 Changed 5 years ago by frank

I did not try with RHEL 5.3 but tried CentOS 5.3 and didn't saw such host reboots. Could you attach the output of dmesg to this defect? And did you use the standard configuration for your VM or did you alter some settings? I want to find out what is different with your configuration...

comment:4 in reply to: ↑ 3 Changed 5 years ago by mbay2002

Replying to frank:

I did not try with RHEL 5.3 but tried CentOS 5.3 and didn't saw such host reboots. Could you attach the output of dmesg to this defect? And did you use the standard configuration for your VM or did you alter some settings? I want to find out what is different with your configuration...

I had the following in /var/log/messages Jul 6 12:19:20 lx57 kernel: VBoxDrv: dbg - g_abExecMemory=ffffffff88e6db00 Jul 6 12:19:20 lx57 kernel: vboxdrv: fAsync=0 offMin=0x73f offMax=0x1593 Jul 6 12:19:20 lx57 kernel: vboxdrv: TSC mode is 'synchronous', kernel timer mode is 'normal'. Jul 6 12:19:20 lx57 kernel: VBoxNetFlt: dbg - g_abExecMemory=ffffffff890a9ae0

But one of the developers said these lines are okay. I've uninstalled 3.01 and 3.02 and gone back to 2.2.4... I'm getting a new machine in a few weeks and I'm just going to wait until I get that. My current machine is a Dell Precision 670 which is probably 3 or 4 years old. I'm just going to hope all works well on my new machine (I'm getting a Sun Ultra 24 which I think I'm going to install Ubuntu instead of Solaris, but then run Solaris as a guest on VirtualBox).

comment:5 Changed 5 years ago by frank

Please could you attach the whole output of dmesg please (use the attach button)?

comment:6 Changed 5 years ago by mbay2002

Hi Frank - I can send you the dmesg with VB 2.2.4, but I don't think that will help. I'm not planning on re-installing 3.0.x because I'm getting a new computer any day now. If the dmesg output from VB 2.2.4 will help, let me know.

comment:7 Changed 5 years ago by frank

Yes, please attach the whole dmesg file from VBox 2.2.4 here.

comment:8 Changed 5 years ago by frank

  • Component changed from other to VMM

comment:9 Changed 4 years ago by ace

I can confirm hard reset on 64-bit CentOS 5.3. It happens right after loading VirtualBox kernel module. I see kernel panic on console and all I have to catch before reset is something concerning modprobe and VirtualBoxLinuxInit function.

There is only one line in dmesg: Unable to handle kernel paging request at ffffffffff5fd030 RIP:

Tried versions 3.0.2 and 3.0.10. But this happens only with xen-enabled kernel. When booting orinary kernel, all works fine.

comment:10 Changed 4 years ago by frank

ace, it is not possible to run VirtualBox on a Xen-enabled kernel. Though I agree that the host should not reboot when the kernel module is loaded.

comment:11 Changed 4 years ago by frank

I will try to reproduce this issue with CentOS 5.4.

comment:12 Changed 4 years ago by frank

Which of the kernels is Xen-enabled? You don't try to run VBox from a Xen Dom0 or Xen DomU, do you?

comment:13 Changed 4 years ago by ace

I try 2.6.18-128.el5xen in Dom0 and it crashes. 2.6.18-128.el5 works fine. So I think it would be better to change subject of this issue to something like "VirtualBox makes host to reboot when it should give error message".

comment:14 Changed 4 years ago by frank

  • Summary changed from VirtualBox 3.0 crashes hard on RHEL 5.3 64-bit to VirtualBox 3.0 reboots host if started from Xen/Dom0

comment:15 Changed 4 years ago by Technologov

This looks like a duplicate of bug #2383

-Technologov

comment:16 Changed 4 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to duplicate

comment:17 Changed 4 years ago by mbay2002

  • Status changed from closed to reopened
  • Resolution duplicate deleted

I initially opened this ticket. I did not have Xen enabled in my kernel, and in fact WAS able to run VirtualBox 2.2.4 on RHEL as noted in my original posting. This should NOT have been renamed. The name needs to go back to "VirtualBox 3.0 crashes hard on RHEL 5.3 64-bit". Has nothing to do with Xen.

comment:18 Changed 4 years ago by sandervl73

  • Summary changed from VirtualBox 3.0 reboots host if started from Xen/Dom0 to VirtualBox 3.0 reboots system with RHEL 5.3 x64 host OS

Please attach the dmesg of 2.2.4 here as requested before.

comment:19 Changed 4 years ago by mbay2002

I no longer have the machine, so I can't test. If you want to close this ticket on that basis, fine, but the title really needs to be ""VirtualBox 3.0 crashes hard on RHEL 5.3 64-bit".

If you look at my original posting, the symptoms were that VB 2.2.4 worked fine on RHEL 5.3 64-bit, but upgrading to VB 3.0 caused the system to crash hard. I reverted back to VB 2.2.4, and the problem went away. I then purchased a new system and have Ubuntu 9.04 64-bit installed, and VB 3.08 is working fine on it. I now have no way to test the RHEL system.

MY ORIGINAL submission had NOTHING to do with XEN.

comment:20 Changed 4 years ago by Technologov

OK, I will test in on RHEL 5.3/x64.

-Technologov

comment:21 Changed 4 years ago by Technologov

OK, but this system has *damn* slow download from virtualbox.org (at 2 KB/s). Downloading from nvidia.com is at 150 KB/s. So testing older version of VBox 3.0.2. (which I already have)

Everything is fine. Only one reminder: you must do:

# rmmod kvm-intel

Host: RHEL 5.3, x64, Core 2 P8600, VBox 3.0.2. VT-x = on.

Guest: Windows XP

-Technologov

comment:22 Changed 4 years ago by Technologov

Please close.

comment:23 Changed 4 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

Thanks for this test.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use