VirtualBox

Ticket #2383 (closed defect: obsolete)

Opened 14 years ago

Last modified 3 years ago

Installer: refuse to install in a Xen dom0

Reported by: hramrach Owned by:
Component: installer Version: VirtualBox 2.0.2
Keywords: Cc:
Guest type: Linux Host type: other

Description (last modified by aeichner) (diff)

The package installs but the vboxdrv module is stuck loading.

Attachments

vboxdrv.log Download (2.9 KB) - added by hramrach 14 years ago.
the part of the log that seems relevant

Change History

Changed 14 years ago by hramrach

the part of the log that seems relevant

comment:1 follow-up: ↓ 3 Changed 14 years ago by sandervl73

  • priority changed from major to minor

You can't use VirtualBox together with Xen. Never has been and never will be possible.

Unless there's some easy way to detect this during installation, there's not much we can do here.

comment:2 Changed 14 years ago by Technologov

My recommendation is to CLOSE this bug as WONTFIX.

-Technologov

comment:3 in reply to: ↑ 1 Changed 14 years ago by hramrach

Replying to sandervl73:

You can't use VirtualBox together with Xen. Never has been and never will be possible.

What's preventing it besides VirtualBox being incredibly buggy?

comment:4 Changed 14 years ago by sandervl73

Why do you think dom0 OSes need massive adjustments to be able to work with the Xen hypervisor? We are not going to do the same for VirtualBox.

Your baseless insulting claim says a lot about you and your total lack of knowledge about the subject.

comment:5 Changed 14 years ago by hramrach

The Linux kernel is already modified to work with the hypervisor.

comment:6 Changed 14 years ago by sandervl73

  • Component changed from host support to installer
  • Summary changed from does not work in xen dom0 to Installer: refuse to install in a Xen dom0

That fact is completely irrelevant. VirtualBox is like a small operating system by itself and would need extensive modifications; just like the Linux kernel. And it's rather pointless to run VirtualBox inside Xen. Use one or the other, but not both at the same time.

comment:7 Changed 13 years ago by Technologov

This looks like a duplicate of bug #4413

-Technologov

comment:8 Changed 13 years ago by Technologov

Another duplicate found: bug #4306

-Technologov

comment:9 Changed 3 years ago by aeichner

  • Status changed from new to closed
  • Resolution set to obsolete
  • Description modified (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use