VirtualBox

Ticket #4378 (closed defect: duplicate)

Opened 5 years ago

Last modified 5 years ago

Shared Folder Files are marked as read-only on Linux host once they are saved from Windows guest

Reported by: vdaron Owned by:
Priority: major Component: shared folders
Version: VirtualBox 3.0.0 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

I'm using Ubuntu Jaunty as Host, Windows XP SP3 as Guest.

Once a file is saved in the guest, the file is marked read-only in the host. Witch avoid any further modifications

I tried using old guest addition, but the problem remains (2.0.4 and 2.1.4)

Change History

comment:1 Changed 5 years ago by vdaron

Forgot to mention : 64bit Host System

comment:2 Changed 5 years ago by klirik

Confirmed here. Host: Ubuntu Jaunty x86_64 on AMD Phenom QuadCore 9600, 9Gb RAM. Guest: Windows XP SP3, 32bit, 1536MB RAM, 4 processors, VT-x/AMD-V: on, Nested Paging: on, Videomemory:64mb, 3D accel. on, HDD: IDE primary master 19GB, no FDD, audio ICH AC97/empty driver, Ethernet PCnet-FAST III (bridge, 'eth0'), no COM, no USB, 1 shared folder.

I have a working project on shared folder. (connected to the guest as network drive). Since VB 2.4 working of TortoiseHG on the guest (the repository is on the shared folder) was broken, and also it is impossible to save changes from VisualStudio more then once. However, the changing from notepad has no such effect.

Examples:

On the host:

alexey@ubuntu64:/media/bigstore/work$ touch test.txt alexey@ubuntu64:/media/bigstore/work$ ls -l test.txt -rw-r--r-- 1 alexey alexey 0 2009-07-07 20:36 test.txt

On the guest - open X:/work/test.txt in VisualStudio, add couple of symbols and save.

After this the attributes will be:

alexey@ubuntu64:/media/bigstore/work$ ls -l test.txt -r-------- 1 alexey alexey 7 2009-07-07 20:38 test.txt

i.e., the file became read-only! And it is impossible neither reset ro attribute from windows, neither, of course, save the file again with the same name.

Change the things back:

alexey@ubuntu64:/media/bigstore/work$ chmod a+rw test.txt alexey@ubuntu64:/media/bigstore/work$ ls -l test.txt -rw-rw-rw- 1 alexey alexey 7 2009-07-07 20:38 test.txt

Then open the same file with notepad, add couple more lines and save.

In this case nothing changed (except the date of last writting):

alexey@ubuntu64:/media/bigstore/work$ ls -l test.txt -rw-rw-rw- 1 alexey alexey 28 2009-07-07 20:40 test.txt

It is surely regression with this thing comparing to 2.2. The problem persist with previous and current version of VB extensions on the guest, i.e., it seems to be NOT related to extensions, but to the core of Vbox.

comment:3 Changed 5 years ago by klirik

is dupe of #4381

comment:4 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Thanks klirik.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use