VirtualBox

Ticket #4348 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

unable to start Windows 2000 installation with IO-APIC enabled -> fixed in SVN/3.0.2

Reported by: fuUser Owned by:
Priority: critical Component: other
Version: VirtualBox 3.0.0 Keywords: I/O-APIC
Cc: Guest type: Windows
Host type: other

Description

I tried to install Windows 2k and it fails after loading all drivers and before you can select the drive/partition. It shows something like "starting Windows 2000" and dies with 100% CPU-load on one emulated core. The problem can be tracked back to IO-APIC support, which is needed for SMP support. Setting it to 1 CPU and deactivating V-tx but leaving IO-APIC on doesn't solve the problem.

Host: Windows Vista x64 SP2, Intel Xeon X3220 (Quad-Core), 8GB RAM Guest: Windows 2k (Installer) with integrated SP4

Attachments

w2k-2009-07-01-22-53-16.log Download (43.2 KB) - added by fuUser 5 years ago.
logfile
VBox.log Download (49.5 KB) - added by sven.koehler 5 years ago.
logfile IO-APIC enabled, VT-x enabled
VBox.2.log Download (46.7 KB) - added by sven.koehler 5 years ago.
logfile IO-APIC enabled, VT-x disabled

Change History

Changed 5 years ago by fuUser

logfile

comment:1 Changed 5 years ago by sven.koehler

Same problem on Linux x86_64 host.

Changed 5 years ago by sven.koehler

logfile IO-APIC enabled, VT-x enabled

Changed 5 years ago by sven.koehler

logfile IO-APIC enabled, VT-x disabled

comment:2 follow-up: ↓ 3 Changed 5 years ago by Nephom

If you open IO APIC function in installed Windows system, you start a network transmitted, and the system will hung. When I change computer type from ACPI MultiProcessor PC to ACPI Uniprocessor PC, the system will run stable. BTW, if you used multi CPUs in installed Windows system, you cannot change it to one core beacuse it will hung on booting system.

comment:3 in reply to: ↑ 2 Changed 5 years ago by sven.koehler

Replying to Nephom:

If you open IO APIC function in installed Windows system, you start a network transmitted, and the system will hung. When I change computer type from ACPI MultiProcessor PC to ACPI Uniprocessor PC, the system will run stable. BTW, if you used multi CPUs in installed Windows system, you cannot change it to one core beacuse it will hung on booting system.

We're talking about the Win2k installation CD. It should always detect the right HAL and boot, but instead it hangs, no matter whether 1 CPU or 2. No matter with VT-x or without. Only disabling IO-APIC helps which also disables SMP support.

comment:4 Changed 5 years ago by sandervl73

Confirmed. Looks like an old problem, which is now relevant because of SMP. I'll look into it.

comment:5 Changed 5 years ago by sandervl73

  • Summary changed from unable to start Windows 2000 installation with IO-APIC enabled to unable to start Windows 2000 installation with IO-APIC enabled -> fixed in SVN/3.0.2

comment:6 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use