VirtualBox

Ticket #4325 (closed defect: worksforme)

Opened 5 years ago

Last modified 4 years ago

DIrect3D7 & Direct3D8 tests failed in DXDiag

Reported by: HeaveN Owned by:
Priority: major Component: 3D support
Version: VirtualBox 3.0.0 Keywords:
Cc: Guest type: Windows
Host type: other

Description

WinXPSP3 Guest on Ubuntu 9.04 Host. DirectX9 installed on guest. Started DXDiag.exe and run Direct3D Tests. Direct3D9 Test passed, but Direct3D7 & 8 tests failed with reasons: Direct3D 7 test results: Failure at step 8 (Creating 3D Device): HRESULT = 0x8007000e (Out of memory) Direct3D 8 test results: Failure at step 4 (EnumAdapterModes): HRESULT = 0x8876086c (error code)

Complete DXDiag log file attached.

Attachments

DxDiag.txt Download (32.2 KB) - added by HeaveN 5 years ago.
DxDiag.2.txt Download (30.6 KB) - added by eapache 5 years ago.
eapache's dxdiag

Change History

Changed 5 years ago by HeaveN

comment:1 Changed 5 years ago by kyvlle

Similar problem here. This time on Mac OS X 10.5.7 host, on a MacBook 2.2, Intel X3100 integrated graphics. Guest Windows XP SP2, DirectX9c.

Running dxdiag, I get the same error as above for DX7 tests. DirectDraw fullscreen will crash VirtualBox.

Also, I cannot change the display resolution. It is stuck at 800x600 in the Display Properties. I wonder if they are related.

comment:2 Changed 5 years ago by danielkza

I can reproduce the issue, Windows XP SP3 32-bit guest @ Windows 7 x64 host. My GPU is an ATI HD4830, Catalyst 9.7 driver (although I doubt it's relevant since people with diff. devices see the same issue).

But unlike kyvlle, I can change the display res. without problems, and the DirectDraw tests run successfully.

comment:3 Changed 5 years ago by eapache

I am only seeing the Dx7 test fail. Everything else works with 3.0.4.

Changed 5 years ago by eapache

eapache's dxdiag

comment:4 Changed 5 years ago by vbboi

Same here, only DX7 fails. Host: Vista 64, nvidia 8800GT Guest: XP 32

comment:5 Changed 5 years ago by trinkl

I have the same issue.

Direct3D 8 test results: Failure at step 4 (EnumAdapterModes): HRESULT = 0x8876086c (error code)

I can't play in DirectX 8 games at all.
For example Postal2 says:
"If you don't have DirectX 8.1b or later installed then please install it now. Otherwise, check the Postal 2 Tech Support site for more information."

Postal2 Eternal Damnation says:
"History: UD3DRenderDevice::UnSetRes <- DetermineFormats <- SetupPresentParms <- UD3DRenderDevice::SetRes <- UWindowsViewport::TryRenderDevice <- UWindowsViewport::OpenWindow <- UGameEngine::Init <- InitEngine"

Host - Debian Lenny 2.6.30-1-amd64
Guest - Windows XP Professional SP3 (32bit)
VirtualBox-OSE 3.0.6
Guest Additions 3.0.6
Video Card - ATI Radeon HD 4350
Video Driver - ATI Catalyst 9.8 (fglrx 9.8)

comment:6 Changed 4 years ago by verdy_p

a Windows guest hosted on a Windows VBOX should be capable of supporting the same level of the DirectX API, by installing and using the VirtualBox Display driver (from the addon virtual CD) in the guest OS: this driver should just forward the DirectX 9 API to the VBOX host that will reposition it on the virtual screen, but that should still support all DirectX9 API.

Because VBOX just supports the virtualisation of DirectX 8, there is still a low display performance (and the WinSAT tool in the guest reports it with a basic 1.0 performance level).

Are there works in progress to forward and virtualize the full DirectX 9 API (and possibly be able to support Aero in a guest Windows Vista or Windows Seven, or play games, or safely test any graphival intensive application in a virtualized Windows) instead of just DirectX 8 within the VBOX display driver for Windows?

comment:7 Changed 4 years ago by verdy_p

Note that I am not asking that the VBOX display driver (installed on a guest windows), will work without problems if the host is not Windows Vista or Seven : it may be difficult to emulate this API under Linux or MacOSX... But the VBOX display driver for Windows guests should be able to communicate with the host to query its capabilities and report the supported maximum version of DirectX.

comment:8 Changed 4 years ago by leonid

  • Status changed from new to closed
  • Resolution set to worksforme

DX7 isn't supported so no wonder that test fails. DX8 test used to fail randomly but it should be fixed in 3.1.

Rest of comments related to particular games and aero doesn't really belong to this ticket.

comment:9 Changed 4 years ago by verdy_p

But VirtualBox currently says hat it supports DX9, this is clearly not the case. Anyway DX8 effectively works but with limited performance. so yes VBOX is quite good when hosting Windows XP, but cannot work as a qualified platform for Seven or even Vista.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use