VirtualBox

Ticket #4324 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

VirtualBox 3.0 CentOS - High CPU Load - Poor Performance -> fixed in SVN/3.0.2

Reported by: szchlacta Owned by:
Priority: major Component: other
Version: VirtualBox 3.0.0 Keywords:
Cc: Guest type: other
Host type: other

Description

After upgrading to VirtualBox 3.0 (and installing new guest additions) the virtual machine is VERY sluggish. CPU load on Host system (64-bit VISTA )is nearly 100%. Virtual guest is 64-bit CENTOS. Performance was much better ( and was not running 100% CPU? on HOST) under previous version of VirtualBox (2.4.4.)

Change History

comment:1 Changed 5 years ago by tompecina

The same problem with Windows XP running on Fedora 11 (64 bit).

comment:2 Changed 5 years ago by ferly

Same problem running CentOS 4 (32-bit) on WinXP. Runs fine in VirtualBox v2.2.4.

Linux version 2.6.9-78.0.22.ELvm (centos@…) (gcc version 3.4.6 20060404 (Red Hat 3.4.6-10)) #1 Tue May 5 18:35:55 EDT 2009

comment:3 Changed 5 years ago by kelus

Same problem with Centos 5.3 (32bit) on Windows XP SP2

comment:4 Changed 5 years ago by mjlucas

Same problem here with CentOS 5u2 32-bit guest running on Redhat 5u2 64-bit host. Kernel of guest is started with options "divider=10 elevator=noop" which sets kernel to 100Hz.

XP SP2 guest running on same host works correctly as expected.

Nothing is logged in VBox.log, all Guest Additions up to date.

comment:5 Changed 5 years ago by user123456

Same problem here:

Vista x64 Host (Dual Core) RHEL Guest (32 bit)

Slightly different symptoms though:

Guest set to 1 processor, host OS reports 50% CPU utilization (one core) even though the guest OS is sitting idle.

comment:6 Changed 5 years ago by wbic16

Confirmed for me as well. I downgraded to VirtualBox 2.2.4 r47978 to resolve the performance issue. My CentOS guest became excessively sluggish under 3.0. I left guest additions installed after having upgraded them with 3.0, so the issue definitely seems to be in the VMM.

Host: Windows XP SP3 x86 32-bit Pentium 4 3.0GHz (w/ hyper threading) 1.5 GB PC2-3200 RAM 300 GB HDD ATI X300 128MB video card

Guest: CentOS 5.3 x86 32-bit 20 GB IDE primary master 256 MB RAM 16MB video RAM

comment:7 Changed 5 years ago by kwanlowe

I am seeing a similar issue with a Windows 64-bit host running VirtualBox 3.0.0 and a CentOS 5.3 VM. The host platform is a Dell XPS 1530. Initially the CPU utilization is fine, but after a few minutes the host TaskManager shows it pegging one core (constant 50% utilization). Running "top" in the VM doesn't show anything using any resources.

comment:8 Changed 5 years ago by sandervl73

  • Summary changed from VirtualBox 3.0 CentOS - High CPU Load - Poor Performance to VirtualBox 3.0 CentOS - High CPU Load - Poor Performance -> fixed in SVN/3.0.2

Should be fixed in 3.0.2.

comment:9 Changed 5 years ago by tompecina

No change in 3.0.2 - host: Fedora 11 64bit, guest: Win XP.

comment:10 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

tompecina: this ticket is about CentOS guests.

I assume this is fixed. If not reopen and provide more details.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use