VirtualBox

Ticket #4299 (closed defect: obsolete)

Opened 10 years ago

Last modified 3 years ago

Subdirectory creation fails for shared folder using ant => Fixed in SVN / 3.0.10

Reported by: bikehead Owned by:
Component: shared folders Version: VirtualBox 3.0.8
Keywords: Cc:
Guest type: Windows Host type: Linux

Description (last modified by aeichner) (diff)

I have downloaded apache ant 1.7.1 and installed it on my windows xpsp3 32bit guest under virtualbox on a fedora x64 system. I've included a very simple ant build.xml file that just tries to create a directory and untar a simple archive.

If I run this build with the archive file in a directory on my virtual c: drive or in an attached samba directory it creates a series of nested directories using an ant mkdir command and then unzips a simple archive.

However, if I run this in a shared folder then ant run will fail trying to execute the mkdir command. It will fail on the unzip too if the mkdir had succeeded.

Attachments

build.xml Download (397 bytes) - added by bikehead 10 years ago.
ant build.xml file (to be used with the attached a.zip file)
a.zip Download (1.1 KB) - added by bikehead 10 years ago.
simple zip archive file to be used by the attached build.xml

Change History

Changed 10 years ago by bikehead

ant build.xml file (to be used with the attached a.zip file)

Changed 10 years ago by bikehead

simple zip archive file to be used by the attached build.xml

comment:1 Changed 10 years ago by igorgatis

This is the same issue as 1870 ( http://www.virtualbox.org/ticket/187)

comment:3 Changed 10 years ago by frank

I need some simple instructions how to use this example.

comment:4 Changed 10 years ago by bikehead

Instructions for attachements. On a Linux host (Fedora) and a windows XP guest with java 1.5 (1.6 might work, but I haven't tried it) and ant installed, put build.xml and a.zip into the same directory and do run ant. Under the current VirtualBox it will fail in two ways: first it will fail trying to unzip the "a.zip" file. If you take that step out (uncomment it) then it will fail when it tries to create a subdirectory.

comment:5 Changed 10 years ago by rcatherman

I experience this on 3.0.6 with linux host ( ubuntu 9.04 amd64 ) and windows XP guest.

(1.6 might work, but I haven't tried it)

My java 1.6 fails using ant 1.7.1.

comment:6 Changed 10 years ago by frank

Well, the information I was looking for was ant unzip.

comment:7 Changed 10 years ago by cemerick

The usage of ant is irrelevant -- any usage of the Java mkdirs() method < http://java.sun.com/j2se/1.5.0/docs/api/java/io/File.html#mkdirs()>, which is what ant uses to implement its mkdir task, fails in the same way.

(this is mentioned in  http://www.virtualbox.org/ticket/1870, with simple code provided @ 2008-09-11 17:54:26 -- not sure why that issue got closed as a dupe of this, since this issue is related to a proximate factor, i.e. ant...but I digress.)

comment:8 Changed 10 years ago by bikehead

I just want to respond to cemerick's comment. The problem with 1870 is the sample code provide does work correctly as of VB 3.0.0 so it isn't just any use of mkdirs(). I opened this bug because 1870 appears to be fixed, but ant and unzip are doing something different that still causes failures. I don't know what that difference is, but there is still a problem and the sample code in 1870 does not show it.

comment:9 Changed 10 years ago by cemerick

A similar piece of code in an application of ours that used File.mkdirs() failed for me on v3.0.2 (I think?). So, perhaps there some interaction between mkdirs and particular environment, JDK version, etc. etc.? That's just speculation though, and I'm unfortunately not in a position to re-test at the moment.

comment:10 Changed 10 years ago by sunlover

Please test new additions:  http://www.virtualbox.org/download/testcase/VBoxGuestAdditions-r53888.iso The new build contains a fix which may help.

comment:11 Changed 10 years ago by frank

  • Summary changed from Subdirectory creation fails for shared folder using ant. to Subdirectory creation fails for shared folder using ant => Fixed in SVN / 3.0.10

comment:12 Changed 10 years ago by rcatherman

I'm not the originator of the bug, but I just tried the .iso you just posted and it removed the problem in my environment.

comment:13 Changed 10 years ago by frank

Thanks for the feedback!

comment:14 Changed 10 years ago by frank

  • Version changed from VirtualBox 2.2.4 to VirtualBox 3.0.8

comment:15 Changed 10 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

comment:16 Changed 10 years ago by cemerick

Hey, this works now, that's great :-)

Now if we can just get a bump in shared folder performance #1728 ...

comment:17 Changed 9 years ago by DieterFauth

  • Status changed from closed to reopened
  • Resolution fixed deleted

Seems to have reappeared in 3.1.8 (and latest 3.3.4). In 3.1.6 it worked. Seen on Windows and Ubuntu guests. Only the very first directory does not allow to mkdir (and rmdir). In Subdirs mkdir works.

comment:18 Changed 3 years ago by aeichner

  • Status changed from reopened to closed
  • Resolution set to obsolete
  • Description modified (diff)

Please reopen if still relevant with a recent VirtualBox release.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use