Ticket #417 (closed defect: obsolete)

Opened 11 years ago

Last modified 4 years ago

Shared clipboard does not work and also affect other programs

Reported by: xrfang Owned by:
Priority: minor Component: clipboard
Version: VirtualBox 3.0.10 Keywords: clipboard
Cc: Guest type: other
Host type: Windows

Description (last modified by frank) (diff)

I am running VirtualBox 1.4 on Ubuntu 6.10 Host. Guest system is Windows XP Pro.

There are several weird problems:

1) Clipboard sharing only partly works (works sometime, but not always). Also, while it works, it does not paste correctly for Chinese text. Somebody on Ubuntu-CN forum said it was incorrect UTF8 processing for Chinese text (did UTF8 conversion twice) I didn't verify though.

2) It affect other programs! Quite funny... while vbox is running, I try to copy text from Claws-Mail to Firefox, for example, both on the HOST system, it paste something strange. Clipboard return normal while I shut down VBox.


vbox_logs.tar.gz Download (87.1 KB) - added by AaronAnderson 11 years ago.
Logs from vbox.

Change History

comment:1 Changed 11 years ago by michael

This should be fixed in the current SVN version.

comment:2 Changed 11 years ago by kenken

I have this problem as well (Feisty host).

It looks like the host clipboard always contains the last copy from within the VM. For this reason, I cannot paste anything the other way.

comment:3 Changed 11 years ago by michael

Could you try the following test build of VirtualBox?

You should uninstall your current build before installing it. This will not affect your virtual machines.

comment:4 Changed 11 years ago by kenken

It worked in my small test (~10 min).

comment:5 Changed 11 years ago by AaronAnderson

I'm having problems with the 1.4.1 version posted above. I have the same problem as listed in the ticket. Thanks Michael.

comment:6 Changed 11 years ago by michael

AaronAnderson: try the following snapshot of VirtualBox 1.4.1:

General note: this is a beta version, not a release.

Changed 11 years ago by AaronAnderson

Logs from vbox.

comment:7 Changed 11 years ago by michael

AaronAnderson: are you using the latest version of the guest additions with your VM? Better to take the version from the non-debugging build I send you.

comment:8 Changed 11 years ago by AaronAnderson

Michael: I was NOT updating the VM addins when upgrading vbox. I updated them Friday afternoon. I'll try and do some stress testing this weekend or Monday morning.

comment:9 Changed 10 years ago by frank

  • Component changed from other to clipboard

comment:10 Changed 9 years ago by hydril

VirtualBox version 2.0.0
Host: Ubuntu 7.04 Guest: Win XP
I host the Windows box. Clipboard is shared. My colleague is on Debian. He logs into the Win with RDP.
Sometimes I paste fragments from his Debian clipboard and sometimes my copy/paste (even with middle mouse button) doesn't work. I guess that pasting is the problem because cutting text makes it disappear.

comment:11 Changed 9 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if this problem is still relevant with the latest release (2.1.2).

comment:12 Changed 8 years ago by kirte

  • Status changed from closed to reopened
  • Resolution fixed deleted

Hi, I'm having the same issue on Virtual box 3.0.10. My host OS is Windows 7 x64, starting guest os Windows 2008 R2 with the virtualbox additions breaks copy/paste in the host system. I'm unable to paste anything at all.

comment:13 Changed 8 years ago by frank

  • Host type changed from other to Windows
  • Version changed from VirtualBox 1.4.0 to VirtualBox 3.0.10

comment:14 Changed 7 years ago by matthew72

I still have clipboard sharing issues with vbox 4.0.4r70112 on ubuntu 10.04 host. all vms are windows xp guests.
it usually works as expected, but:

  • to copy/paste between two running vms i (only sometimes) have to paste in the host and copy the text again
  • today the clipboard stopped working within one of the vms: whatever i copied in the vm was ignored, when i (immediately) pasted in the same vm i still got the text i copied in the guest some time before. it didn't work until i tried copy/pasting in another vm (there are other two open at the same time): it worked there and somehow resolved the issue in the third vm too.

comment:15 Changed 4 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to obsolete
  • Description modified (diff)
Note: See TracTickets for help on using tickets.
ContactPrivacy policyTerms of Use