VirtualBox

Ticket #416 (closed defect: duplicate)

Opened 7 years ago

Last modified 7 years ago

vboxvfs kernel module does not compile cause of missing files

Reported by: GlaDiaC Owned by:
Priority: major Component: other
Version: VirtualBox 1.4.0 Keywords:
Cc: Guest type: other
Host type: other

Description

vboxvfs kernel module does not compile cause of missing files. The attached patch fixed all relevant files.

Attachments

vbox-kmp-vboxvfs.diff Download (3.2 KB) - added by GlaDiaC 7 years ago.

Change History

Changed 7 years ago by GlaDiaC

comment:1 Changed 7 years ago by GlaDiaC

kBuild calls the Makefile.kmk in src/VBox/Additions/linux/sharedfolders/ and uses a file named src/VBox/Additions/linux/sharedfolders/files_vboxvfs to copy the needed sources and headers which are needed to compile vboxvfs. The files get copied to out/linux.amd64/release/bin/additions/src/vboxvfs/. It copies a the src/VBox/Additions/linux/sharedfolders/Makefile.module to this directory too.

The problem is that in src/VBox/Additions/linux/sharedfolders/files_vboxvfs serveral headers and sources are missing. And they are missing in src/VBox/Additions/linux/sharedfoldes/Makefile.module too. So if you want to compile vboxadd in out/linux.amd64/release/bin/additions/src/vboxvfs/ you are not able to compile it cause there are missing headers and source files. The attached patch adds the missing files. Then vboxvfs will compile.

comment:2 Changed 7 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

We handle this report in #415 as well.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use