VirtualBox

Ticket #3989 (closed defect: invalid)

Opened 5 years ago

Last modified 5 years ago

Importing the Sun Storage Appliance fails with "Cannot find hard disk controller"

Reported by: LenzGr Owned by:
Priority: major Component: VM control
Version: VirtualBox 2.2.2 Keywords:
Cc: Guest type: Solaris
Host type: Linux

Description

I downloaded the Sun Storage Virtualbox Appliance from  http://www.sun.com/storage/disk_systems/unified_storage/resources.jsp and extracted the ZIP file. Trying to import the appliance fails with the following error message:

Sun Storage VBox> VBoxManage import Sun\ Storage\ VirtualBox.ovf VirtualBox Command Line Management Interface Version 2.2.2_OSE (C) 2005-2009 Sun Microsystems, Inc. All rights reserved.

Interpreting Sun Storage VirtualBox.ovf... ERROR: Cannot find hard disk controller with OVF instance ID 4 to which disk "ss7000_b00.vmdk" should be attached Details: code NS_ERROR_FAILURE (0x80004005), component Appliance, interface IAppliance, callee IAppliance Context: "Interpret" at line 259 of file VBoxManageImport.cpp

I'm attaching the .ovf file for your convenience. It should be easy to reproduce this problem by downloading the appliance from the Sun website...

Attachments

Sun Storage VirtualBox.ovf Download (13.7 KB) - added by LenzGr 5 years ago.
Sun Storage .ovf file

Change History

Changed 5 years ago by LenzGr

Sun Storage .ovf file

comment:1 Changed 5 years ago by poetzsch

  • Status changed from new to closed
  • Resolution set to invalid

Thanks for the report. The problem is that the OSE version doesn't support SATA controllers & the OVF make use of them. So to import this OVF you have to use the PUEL version of VirtualBox from  http://www.virtualbox.org. The error message is indeed very misleading & I will improve the error text to describe the situation more clearly in the next version of VirtualBox.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use