VirtualBox

Ticket #3933 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

Linux guest with 3 NICs (Bridged networking) dies (not crashes) after some hours of usage

Reported by: Lucia_Rotger Owned by:
Priority: critical Component: network/hostif
Version: VirtualBox 2.2.0 Keywords: multiple nics unexpected
Cc: Guest type: Linux
Host type: Linux

Description

Host is Debian Lenny, stock kernel 2.6.28.7, processor is Intel Core 2 Quad, 4 GB RAM. VirtualBox is v2.2.0. All guests are started through VBoxHeadless. There are 5 guests running, all Linux, stock kernel 2.4.xx; networking is Host Interface Networking (now Bridged Networking) for all. Of the 5 guests, 4 have only one NIC (Am79C973) and have been stable for two months of heavy use. The fifth has three NICs and there is no way it can stay up for more than 48 hours. First I set all three NICs to Am79C973 and the guest died silently after a few hours (2-3). This kernel has been running flawlessy in a physical computer for eight years (NICs were a different brand). After some months of testing and seeing the other guests work ok I decided to virtualize this one, but it keeps dying. The intersection of the drivers available in this kernel and the NICs in VBox is two: Intel PRO/1000 and AMD PCNet 32. I set eth0, eth1 to be Intel 82543GC, and the third to be Am79C973. It stays up longer, maybe 30 hours but it dies unexpectedly, it responds to nothing, the RDP server dies, and issuing VBoxManage poweroff does not work, the command does not return and I have to kill (Ctrl+C) it and kill the process itself. After that it can be started again and it works for some more time. The VBox logs show nothing of significance; host's /var/log/syslog and /var/log/messages show nothing either, and the guest's logs also show nothing. I'm at a loss here as to what to look for. I have no idea what causes it, and I'm really considering other virtualization solutions because I'm aware that this ticket provides very little information. Of course the drivers for the virtual NICs in the guest kernel could be buggy but I very much doubt it, specially for the Intel PRO/1000 one; when I tried to set all three NICs to Intel 82543GC it also died shortly. Besides, the RDP server in VBox dying points to a VBox bug and not a guest bug. If the guest crashes no matter how, I should still see the console right?

If there's anything I can do to test other setups or there is a secret beta NIC that's not in the manual or whatever, I'm open to ideas and I can test several things but it shouldn't take too long, otherwise I'll have to setup a VMWare host with three more nics and run this one there.

Change History

comment:1 Changed 5 years ago by sandervl73

Try again with 2.2.2.

comment:2 Changed 5 years ago by Lucia_Rotger

No, I don't think I'll try 2.2.2; the chances of it working magically are low. I don't see anything related in the 2.2.2 changelog and looking at the networking bugs I see you keep screwing it at each other new version. Besides, trying 2.2.2 means stopping four production servers. Versions > 1.0 of software made by Sun shouldn't have bugs this big. I'm switching to VMWare for the time being. Thanks for your efforts but it's not working. Version 2.anything should be smooth as silk.

comment:3 Changed 5 years ago by frank

You are correct, the changelog doesn't mention a fix regarding your specific problems but I can tell you that VirtualBox 2.2.2 indeed contains a fix for the PCnet device emulation. That changelog entry is just missing but we have other users with positive feedback, I will add it at least to the website.

The PCnet emulation of VirtualBox 2.2.0 has a bug which can lead to a deadlock of the VM under certain circumstances. A deadlock which makes the whole VM unresponsive, in fact the same symptoms you described. The bug was fixed in 2.2.2. In fact we did not change anything in the PCnet emulation with 2.2.0 but the bug was caused by some deeper memory changes of the VMM which required some more adaptions of the PCnet code (which was only partly done with 2.2.0).

Note that the E1000 emulation does not have this bug, so if you have a VM with E1000 network devices only and this VM dies as well, then there is probably another problem. But if we are talking about VMs with at least one PCnet device, the chances are really high that the problem is fixed with VirtualBox 2.2.2.

comment:4 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

Since you are unwilling to test I'll just close it. As Frank said there's a pcnet fix in 2.2.2. Complaints like the one above serve no purpose.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use