VirtualBox

Ticket #3900 (closed defect: obsolete)

Opened 5 years ago

Last modified 5 months ago

Slow (text) scrolling with VirtualBox 2.2.x

Reported by: chasake Owned by:
Priority: major Component: VMM
Version: VirtualBox 2.2.2 Keywords: Slow scrolling
Cc: Guest type: Windows
Host type: Linux

Description (last modified by frank) (diff)

After installing 2.2.0 (and also in 2.2.2) the scrolling of (at least) text in a window is much slower than in 2.1.4. When I roll the mouse the CPU load goes to 100% and my processor clocks up to max speed.

Another test is to keep 'enter' pressed creating a lot of newlines in a text editor. The cpu goes to 100% and clocks up. I tried updating the Virtual Box Guest Additions, but that does not solve the problem. Then I tried switching 3d acceleration off and on but that does not change anything either. In the end I reinstalled 2.1.4 and things are just fine again.

First I was running virtualbox in Ubuntu Intrepid 64 bit with a 32 bit Windows XP client but I recently did a fresh install of Jaunty AMD64 with the same 32bit XP client on VirtualBox 2.1.4. In 2.2.0 and 2.2.2 the scroll problem reappeared as on Ubuntu Intrepid.

I must say that I only quickly tried if the problem persisted in 2.2.2 by starting 'IAR embedded workbench' in a Windows XP client and then started pressing enter in the editor window. In 2.2.x you can see that the creation of new lines is slow and that scrolling takes time and the processor clocks from an idling 1.0 GHz to 1.8GHz with 100% CPU on 1 core. In 2.1.4 the CPU remains on 1 GHz with a lot less load. Also the number of lines created per second by pressing enter is much higher.

I also noted this problem on the forum:  http://forums.virtualbox.org/viewtopic.php?f=7&t=16402 and maybe the same problem is posted by someone else in thist post  http://forums.virtualbox.org/viewtopic.php?f=2&t=16388

Change History

comment:1 Changed 5 years ago by frank

Please start a virtual machine like follows:

VirtualBox --startvm VM_NAME --rmode sdl

Does that make any difference on your system?

comment:2 Changed 5 years ago by chasake

Thank you Frank, using the '--rmode sdl' option seems to eliminate the problem completely! But why should I do this now, where in 2.1.4 it's all ok without the option?

comment:3 Changed 5 years ago by frank

chasake, the drawing mode was changed from sdl to qimage starting with version 2.2.0 because sdl had some problems for other users. Seems we have to let the user choose the drawing mode ...

comment:4 Changed 5 years ago by ermac

You can set it directly in the graphical interface or xml file?

comment:5 Changed 5 years ago by frank

Starting with VirtualBox 2.2.4 you can do

VBoxManage setextradata global "GUI/RenderMode" sdl

comment:6 follow-up: ↓ 8 Changed 5 years ago by sthames

Same OS, same VBox, same Guest, same problem. Hardware is HP DV7-1245dx. "--rmode sdl" and "VBoxManage setextradata global "GUI/RenderMode" sdl" make no difference. Laggy in mouse, window movement, and keyboard. When I was trying to install Office 2007 and was putting in the product key, I typed five characters and they displayed five seconds later.

HELP, PLEASE!!! I want to use VBox but I can't use it this way. I do not want to lay down Windows/XP on my machine.

comment:7 Changed 5 years ago by chasake

I just upgraded VirtualBox to 2.2.4 (from still using 2.1.x). Without changing any options, the slow scrolling speed was still there but after running the 'VBoxManage' command Frank suggested, everything is back to normal when I start VirtualBox from the applications menu.

Too bad the problem is not solved for 'sthames' above. (Although for me the slowdown was not in the order of seconds, but merely a lagged system because of slower screen updates)

comment:8 in reply to: ↑ 6 Changed 5 years ago by eraserhd

Replying to sthames:

Same OS, same VBox, same Guest, same problem. Hardware is HP DV7-1245dx. "--rmode sdl" and "VBoxManage setextradata global "GUI/RenderMode" sdl" make no difference.

I had exactly the same situation. I could pull up a cmd.exe window and do a dir and get back an answer almost as soon as I hit enter, but if I was at the bottom of the window, it could take 5-10 seconds to scroll the same info.

I'm not sure which solved it, but I finally got it resolved. What I swear that I did was turn off 3D acceleration, Nested tables, and AMD-V; however (I had already set the global RenderMode option as listed above), afterward I went into the settings, and AMD-V and nested page tables were off, but 3D is on. I turned AMD-V back on, and it still works, although VboxManage reports it off, while the GUI reports it on.

So I'm not sure what's really off and what's really on, but there is some interaction between the display mode and one of those options. I'm not sure which, and I'm hesitant to touch it now.

Hope this helps.

comment:9 Changed 5 years ago by diver

I have the same problem with  Haiku

VBoxManage setextradata global "GUI/RenderMode" sdl

improves situation
I am using VirtualBox-3.0.2_49928_fedora8-1.i386.rpm
lspci -nn | grep VGA

00:02.0 VGA compatible controller [0300]: Intel Corporation 82Q35 Express Integrated Graphics Controller [8086:29b2] (rev 02)

comment:10 Changed 4 years ago by Technologov

Updated to 3.1.0. Scrolling and system overall works very fast here. When scrolling, CPU usage is at 20% in UP VM.

Host: RHEL 5.3, x64, Core 2 P8600, NVIDIA GeForce 9700M GTS, VBox 3.1.0

Guest: Windows XP

-Technologov

comment:11 Changed 5 months ago by frank

  • Status changed from new to closed
  • Resolution set to obsolete
  • Description modified (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use