VirtualBox

Ticket #390 (closed defect: duplicate)

Opened 7 years ago

Last modified 7 years ago

Shared folder crash

Reported by: Xpheroid Owned by:
Priority: critical Component: other
Version: VirtualBox 1.4.0 Keywords:
Cc: Guest type: other
Host type: other

Description

I'm still having problems with copying from shared folders. If I use either the standard GUI or VBoxSDL it aborts or crashes while copying. I have attached VBox.log.

Attachments

VBox.log Download (26.4 KB) - added by Xpheroid 7 years ago.
VBox.log

Change History

Changed 7 years ago by Xpheroid

VBox.log

comment:1 Changed 7 years ago by Xpheroid

Forgot to say I am using PCLinuxOS host and WinXP pro guest. I have just noticed there is a reopened report also so please delete this post if not needed, thanks.

comment:2 Changed 7 years ago by Joulupukki

I would like to add a bugcheck analysis of my shared folder bugcheck. But looking on the stack it seems to be useless because none of the virtual box modules are involved. Additionally I've different bugcheck codes on each crash.

Microsoft (R) Windows Debugger  Version 6.7.0005.0
Copyright (c) Microsoft Corporation. All rights reserved.


Loading Dump File [\Cavalieri\temp\MEMORY.DMP]
Kernel Summary Dump File: Only kernel address space is available

Symbol search path is: C:\WINDOWS\Symbols\vista
Windows Vista Kernel Version 6000 UP Free x86 compatible
Product: WinNt, suite: TerminalServer SingleUserTS
Built by: 6000.16386.x86fre.vista_rtm.061101-2205
Kernel base = 0x81800000 PsLoadedModuleList = 0x81908ab0
Debug session time: Sat Jun  9 21:05:41.929 2007 (GMT+2)
System Uptime: 0 days 0:04:01.697
Loading Kernel Symbols
........................................................................................................................
Loading User Symbols

Loading unloaded module list
....
*******************************************************************************
*       *
*                        Bugcheck Analysis       *
*       *
*******************************************************************************

Use !analyze -v to get detailed debugging information.

BugCheck 50, {99fc3d04, 1, 81a8ed47, 2}

Page 1670f not present in the dump file. Type ".hh dbgerr004" for details
Page 16ad3 not present in the dump file. Type ".hh dbgerr004" for details
Probably caused by : ntkrnlmp.exe ( nt!ExpUpdateDebugInfo+13e )

Followup: MachineOwner
---------

kd> !analyze -v
*******************************************************************************
*       *
*                        Bugcheck Analysis       *
*       *
*******************************************************************************

PAGE_FAULT_IN_NONPAGED_AREA (50)
Invalid system memory was referenced.  This cannot be protected by try-except,
it must be protected by a Probe.  Typically the address is just plain bad or it
is pointing at freed memory.
Arguments:
Arg1: 99fc3d04, memory referenced.
Arg2: 00000001, value 0 = read operation, 1 = write operation.
Arg3: 81a8ed47, If non-zero, the instruction address which referenced the bad memory
    address.
Arg4: 00000002, (reserved)

Debugging Details:
------------------

Page 1670f not present in the dump file. Type ".hh dbgerr004" for details
Page 16ad3 not present in the dump file. Type ".hh dbgerr004" for details

WRITE_ADDRESS:  99fc3d04

FAULTING_IP:
nt!ExpUpdateDebugInfo+13e
81a8ed47 890e            mov     dword ptr [esi],ecx

MM_INTERNAL_CODE:  2

DEFAULT_BUCKET_ID:  INTEL_CPU_MICROCODE_ZERO

BUGCHECK_STR:  0x50

CURRENT_IRQL:  0

TRAP_FRAME:  8f18dba4 -- (.trap 0xffffffff8f18dba4)
ErrCode = 00000002
eax=833a87f8 ebx=83413f44 ecx=00000abc edx=16bafd90 esi=99fc3d04 edi=834801f8
eip=81a8ed47 esp=8f18dc18 ebp=8f18dc50 iopl=0         nv up ei pl nz na pe nc
cs=0008  ss=0010  ds=0023  es=0023  fs=0030  gs=0000 efl=00010206
nt!ExpUpdateDebugInfo+0x13e:
0008:81a8ed47 890e            mov     dword ptr [esi],ecx ds:0023:99fc3d04=????????
Resetting default scope

LAST_CONTROL_TRANSFER:  from 81849304 to 81857535

STACK_TEXT:
8f18db8c 81849304 00000001 99fc3d04 00000000 nt!MmAccessFault+0x14b
8f18db8c 81a8ed47 00000001 99fc3d04 00000000 nt!KiTrap0E+0xdc
8f18dc50 819dcd7d 834801f8 833a87f8 0000004c nt!ExpUpdateDebugInfo+0x13e
8f18dc70 819c7049 0000004c 00000001 0000004c nt!ExMapHandleToPointerEx+0x63
8f18dcac 819e01e4 0000004c 00000001 8277ebf0 nt!ObReferenceObjectByHandle+0x11c
8f18dd38 818461fa 0000004c 00000000 00000000 nt!NtReadFile+0x44
8f18dd38 77af0f46 0000004c 00000000 00000000 nt!KiFastCallEntry+0x12a
WARNING: Frame IP not in any known module. Following frames may be wrong.
001adc00 00000000 00000000 00000000 00000000 0x77af0f46


STACK_COMMAND:  kb

FOLLOWUP_IP:
nt!ExpUpdateDebugInfo+13e
81a8ed47 890e            mov     dword ptr [esi],ecx

SYMBOL_STACK_INDEX:  2

FOLLOWUP_NAME:  MachineOwner

MODULE_NAME: nt

IMAGE_NAME:  ntkrnlmp.exe

DEBUG_FLR_IMAGE_TIMESTAMP:  4549ad6c

SYMBOL_NAME:  nt!ExpUpdateDebugInfo+13e

FAILURE_BUCKET_ID:  0x50_W_nt!ExpUpdateDebugInfo+13e

BUCKET_ID:  0x50_W_nt!ExpUpdateDebugInfo+13e

Followup: MachineOwner
---------

comment:3 Changed 7 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to duplicate

Thanks for the info. I think I've found the root cause of all the instabilities. See defect 57.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use