VirtualBox

Ticket #389 (closed defect: invalid)

Opened 7 years ago

Last modified 7 years ago

Freeze/Crash when installing Windows XP

Reported by: Majandi Owned by:
Priority: major Component: other
Version: VirtualBox 1.4.0 Keywords: windows, xp, ubuntu, freeze, crash
Cc: Guest type: other
Host type: other

Description

I'm using the new Virtualbox 1.40 in Ubuntu Feisty (7.04). When I'm starting to start Windows XP, the installer says that I must format the drive to NTFS or FAT. Then, when I choose an option, the format progress bar freezes at 0% and after some minutes the VM shut down.

Attachments

dmesg.txt Download (15.0 KB) - added by nantallen 7 years ago.
lsmod.txt Download (3.8 KB) - added by nantallen 7 years ago.
lspci.txt Download (1.9 KB) - added by nantallen 7 years ago.
syslog.txt Download (345.7 KB) - added by nantallen 7 years ago.
VBox.log Download (22.7 KB) - added by nantallen 7 years ago.

Change History

comment:1 Changed 7 years ago by nantallen

I am experiencing the same problem with Debian Etch. I used the apt-get install method after adding the source and key. Everything installed with no errors. I can run VirtualBox from the run dialog in Gnome, and I have the ability to set up a VM and VDI with no issues. When the install of XP gets to formatting, everything, including the host OS begins to lock up until the VM crashes with no real errors. After viewing the logs and trying other OSes such as Mac OSX and Fiesty, as well as Knoppix, it seemed to be an access issue with the vdi. I moved the vdi to a new directory and issued a chmod 777. Still no luck. It seems the vbox kernel driver can not access the vdi.

uname: Linux 2.6.18-4-486 i686

I attached the log from one of the failed attempts. I have also attached excerpts from lspci, lsmod, syslog, and dmesg.

Changed 7 years ago by nantallen

Changed 7 years ago by nantallen

Changed 7 years ago by nantallen

Changed 7 years ago by nantallen

Changed 7 years ago by nantallen

comment:2 Changed 7 years ago by nantallen

One other thing to note is that the vdi exists on a ReiserFS partition, although that shouldn't be an issue.

comment:3 Changed 7 years ago by sandervl73

If your VDI file is stored on an NTFS partition, then try another file system. Other users have reported weird problems with the Linux NTFS driver. Sounds to me the NTFS fs driver isn't entirely reliable (to put it mildly).

comment:4 Changed 7 years ago by sandervl73

There are also many atapi errors in your log. Perhaps your cd is simply damaged.

comment:5 follow-up: ↓ 6 Changed 7 years ago by skrollan

i have the same problem ( http://www.virtualbox.org/ticket/589) is it possible that there is no solution for this problem at this time? i've been diggin google for 3-4 or 4 days now and can't find any solution :(

comment:6 in reply to: ↑ 5 Changed 7 years ago by akashman

Replying to skrollan:

i have the same problem ( http://www.virtualbox.org/ticket/589) is it possible that there is no solution for this problem at this time? i've been diggin google for 3-4 or 4 days now and can't find any solution :(

I'm happy to say there is a solution, at least one that worked for me. I was struggling with the same problem for many days (XP install hangs host at around the 20% formatted mark) and finally found that the simple solution is to make the virtual drive fixed size rather than dynamically growing.

It seems, logically so, that while XP/Win2K/etc is trying to format away, the virtual HD (real hd as far as Windows is concerned) keeps expanding in size, and this seems to result in an infinite loop of sorts (note that the physical HD keeps spinning infinitely when the machine starts to hang). It seems logical that an OS install that wasn't designed for virtualization wouldn't be prepared for a disk drive that changes in size. Try creating a new fixed drive. It worked for me and it's now running perfectly.

Good luck, Amit

comment:7 Changed 7 years ago by geonix

Your solution works when user has a problem on 15-20% or more percents of formatting. Unfortunately It didn't work for me , when my virtual machine crashed on 0% of formatting. The cause of the problem was simple : Please check the amount of memory assigned to virtual machine. For me it was 2GB assigned, when my real memory was only 1Gb! I reduced assigned memory to 300MB it just started work!

comment:8 Changed 7 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to invalid

That was indeed a bad idea. Never assign more than half your RAM to a VM. We'll add some checks in the GUI later on. Closing this defect now.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use