VirtualBox

Ticket #3826 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

Solaris host crashes resuming after suspend resume

Reported by: ckiick Owned by:
Priority: major Component: host support
Version: VirtualBox 2.2.0 Keywords: suspend resume
Cc: Guest type: Solaris
Host type: Solaris

Description

Host: solaris (nv111 dev build) on a tecra M10 laptop running virtualbox 2.2.0 r45846. Guest: either debian or solaris (s10u7). The guest OS doesn't seem to matter. Do this:

  • start guest OS virtual machine
  • Machine->Pause
  • suspend host system
  • resume host system
  • Machine->resume

Host OS crashes and immediately reboots.

The log file only has "startvm" in it. Reproducible on demand. Config: OS Type:

Solaris (64 bit) Base Memory:

512 MB Video Memory:

12 MB Boot Order:

Hard Disk ACPI:

Enabled IO APIC:

Enabled VT-x/AMD-V:

Enabled Nested Paging:

Disabled PAE/NX:

Disabled 3D Acceleration:

Disabled

NOTE: could not add log file due to errors in tracback.

Change History

comment:1 Changed 5 years ago by sandervl73

Try again then please. I'll close the 2nd ticket you've created.

comment:2 Changed 5 years ago by ckiick

still can't attach a file. Here's the contents of the log file: Log created: 2009-04-23T17:50:10.670777000Z Executable: /opt/VirtualBox/amd64/VirtualBox Arg[0]: /opt/VirtualBox/amd64/VirtualBox Arg[1]: --comment Arg[2]: calloutbackport Arg[3]: --startvm Arg[4]: e3a0cdcd-c900-4eab-9916-23a81ec67e4c

That's it.

comment:3 follow-up: ↓ 4 Changed 5 years ago by Aha

Acer Aspire 5920G

I observe the same behavior on snv101: start guest Vista -> suspend host (guest can be paused but it is not necessary) -> resume host -> observe unexpected reboot of host machine

Also I see different behavior in similar situation: start guest Vista -> start opengl application (3D-game) -> suspend host -> resume host -> unexpected reboot of host. At start of laptop boot - at POST stage - I see strange behavior of videocard: it looks like CRT-display with no any synchronization. Solaris is booted well but no any image on the screen - no "synchronization". This situation can be repaired by reinsertion of laptop's battery. Does Virualbox write some trash into DAC?!? The same situation (no synchro after reboot) in another situation: start guest Vista (no any applications are started) -> connect second monitor top laptop (HDMI out) -> init second monitor -> start/stop playback some movie on second monitor -> remove cable from second monitor -> remove power cable from laptop -> observe immediate hung -> after hard reboot (press power button >3 sec) I observe the same "no synchro"

comment:4 in reply to: ↑ 3 Changed 5 years ago by Aha

Replying to Aha:

Acer Aspire 5920G

I observe the same behavior on snv101: start guest Vista -> suspend host (guest can be paused but it is not necessary) -> resume host -> observe unexpected reboot of host machine

Forgot to mention configuration

Host: Acer aspire 5920G, Opensolaris 101b

Guest: OS - MSWVista RAM - 768 Mb Video - 128 Mb Hard Disk ACPI: Enabled IO APIC: Enabled VT-x/AMD-V: Enabled Nested Paging: Disabled PAE/NX: Enabled 3D Acceleration:Enabled

comment:5 Changed 5 years ago by sandervl73

VirtualBox doesn't use the Solaris hooks for getting notifications about suspend/resume right now. Until this is fixed don't leave VBox up and running when suspending the machine.

comment:6 Changed 5 years ago by sandervl73

  • Summary changed from Host OS crashes resuming after suspend resume to Solaris host crashes resuming after suspend resume

comment:7 Changed 5 years ago by sandervl73

This only applies to VT-x/AMD-V by the way.

comment:8 Changed 5 years ago by Aha

Without VT-x/AMD-V my laptop is not rebooted after resume but anyway I cannot to continue working because video driver appears to be crashed: black screen.

comment:9 Changed 5 years ago by ramshankar

Could you please try the experimental test build from (remove both SUNWvbox and SUNWvboxkern and reinstall) (link expires in 14 days):  http://virtualbox.org/download/testcase/VirtualBox-rel-SunOS-r47512.tar.gz

Note: this build could be unstable in other parts and it's highly recommended you go back to your 2.2.2 once you have tested what is required.

This contains the changes to suspend/resume notifications on the host.

comment:10 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in 3.0

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use