VirtualBox

Ticket #3756 (closed defect: duplicate)

Opened 5 years ago

Last modified 4 years ago

Shared Folders - selecting Other causes R6025 -> Duplicate of #3694

Reported by: compeoree Owned by:
Priority: major Component: GUI
Version: VirtualBox 2.2.0 Keywords: R6025
Cc: Guest type: other
Host type: Windows

Description

Overview

Under Windows XP SP3 host and a Windows XP SP2 client selecting "Other..." on the shared folders dialog results in a "R6025 - pure virtual function call" error. This aborts the client. Client OS gets corrupted and has to revert to current snapshot.

How to Create

  • Start client
  • Right click on shared folder icon in lower right
  • Select Other... from Folder Path drop down list

Work arounds

  • Create a new snapshot
  • Click on Folder Name box before selecting folder path

I changed two things, so not sure which one actually fixed it.

Notes

  • Recently upgraded version 2.0.6 r39760 to 2.2.0 r45846.
  • Reverting back to current snapshot has no effect.
  • Installed all Microsoft updates on host.
  • On the same host but with an Ubuntu variant client (ArtistX), the shared folders work as expected.
  • VBox Additions installed

Similar Bugs

Change History

comment:1 Changed 5 years ago by compeoree

Update

Work arounds allow folder selection, but causes a silent (no errors) abort of client upon clicking "OK"
Reverting snapshot and attempting again, success!

comment:2 Changed 5 years ago by compeoree

Work arounds seem hit or miss. Sometimes it will properly map, other times it aborts the client.

comment:3 Changed 5 years ago by x3non

I confirm this issue, I think it should be fixed asap!

comment:4 Changed 5 years ago by cobrin

This also hit me. I had just creating a new virtual machine, and hadn't even had the chance to boot off .iso to install.

I then tried creating my virtual machine (Fedora 11 Beta on Wind0ws XP SP2) and then tried adding a shared folder, and again, it crashed.

I've never even got to the point where I use snapshots.

This is pretty much of a showstopper for me, as I use VirtualBox to test OS builds.

comment:5 Changed 5 years ago by gmjs

Can confirm the same bug (qt4vbox4.dll) under Windows XP SP3 host with Windows Server 2008 client (suspect this error is not client specific). Bug appears to be specific to the 2.2.0 version.

comment:6 Changed 5 years ago by gmjs

Of course, you can still type the path to the folder you want to share in the "Folder Path" box, rather than invoking the folder selection dialogue as a workaround.

comment:7 Changed 5 years ago by sunlover

  • Status changed from new to closed
  • Resolution set to duplicate
  • Component changed from shared folders to GUI
  • Guest type changed from Windows to other
  • Summary changed from Shared Folders - selecting Other causes R6025 to Shared Folders - selecting Other causes R6025 -> Duplicate of #3694

Duplicate of #3694. The fix will be available in the next maintenance release.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use