VirtualBox

Ticket #3694 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

Shared Folders GUI Error on Windows Host -> Fixed in SVN

Reported by: matthew_eli Owned by:
Priority: major Component: GUI
Version: VirtualBox 2.2.0 Keywords:
Cc: Guest type: other
Host type: Windows

Description

The problem occurs on VirtualBox 2.2.0 when we are in Settings and we select the Shared Folder and when we start to select the folder the GUI hangs and reports an error and VirtualBox exit.

Guest Additions installed are 2.2.0, Windows Vista Home Premium are the Host and Windows XP Professional SP3 are the Guest.

Attachments

error_when_happens.png Download (43.7 KB) - added by matthew_eli 5 years ago.
the error when occurs during the selection of the shared folder
Untitled.jpg Download (153.9 KB) - added by conficker.e 5 years ago.
vboxcrash.JPG Download (55.9 KB) - added by snoibert 5 years ago.
dll

Change History

comment:1 Changed 5 years ago by matthew_eli

In 2.1.4 we do not have this problem and all works perfectly

Changed 5 years ago by matthew_eli

the error when occurs during the selection of the shared folder

Changed 5 years ago by conficker.e

comment:2 Changed 5 years ago by conficker.e

I've been having the exact same issue from a host machine running Windows XP Professional SP3 and creating any guest OS VM. I somehow managed to get a Shared Folder added to the Windows 7 guest VM, but now when I try it with the Ubuntu guest VM, VirtualBox instantly crashes.

comment:3 Changed 5 years ago by snoibert

Hi,

i have the same problem. But I use Windows XP Home SP2 as host. I first got a shared folder set up, but now i cant change anything. It crashes and shows the pictures posted above. And when you press the button to see what data is reported, you can see that qtcorevbox4.dll is the cause.

Changed 5 years ago by snoibert

dll

comment:4 Changed 5 years ago by choekstra

Hi,

I can confirm the issue as well. It hapens when selecting a folder or just before that (both shared folder and folder browse folder appear grey and crash).

I have Windows Vista Enterprise SP1 64 bit with the latest security patches. The guest is Windows XP SP3, migrated Guest from VBox 2.1.4.

Maybe important as well: The error is not releated to when you use it. Whether I use it from a started guest or from the configuration panel when the guest is shutdown, 90% change the error appears. Also what I notice it default opens the browse windows in %systemroot%\system32, this may cause problems on Vista due to the UAC (User Access Control) and therefore it may crash?.

Please let me know if you need additional information like screenshots, logs and so on. I am happy to provide them if I am instucted how to provide them (e.g. debug logs)

Regards,

Christian

comment:5 Changed 5 years ago by choekstra

Hi Again,

Please find below the extracted evenlog messages....

It seems to involve "QtCoreVBox4.dll" and "USER32.dll".

Regards,

Christian

Log Name: Application Source: Application Error Date: 16-4-2009 14:24:31 Event ID: 1000 Task Category: (100) Level: Error Keywords: Classic User: N/A Computer: INCONF08 Description: Faulting application VirtualBox.exe, version 2.2.0.0, time stamp 0x49dba8b4, faulting module QtCoreVBox4.dll, version 4.4.3.0, time stamp 0x49d69e8b, exception code 0xc0000005, fault offset 0x000ed689, process id 0x17a0, application start time 0x01c9be8e462b41ea. Event Xml: <Event xmlns=" http://schemas.microsoft.com/win/2004/08/events/event">

<System>

<Provider Name="Application Error" /> <EventID Qualifiers="0">1000</EventID> <Level>2</Level> <Task>100</Task> <Keywords>0x80000000000000</Keywords> <TimeCreated SystemTime="2009-04-16T12:24:31.000Z" /> <EventRecordID>9059</EventRecordID> <Channel>Application</Channel> <Computer>INCONF08</Computer> <Security />

</System> <EventData>

<Data>VirtualBox.exe</Data> <Data>2.2.0.0</Data> <Data>49dba8b4</Data> <Data>QtCoreVBox4.dll</Data> <Data>4.4.3.0</Data> <Data>49d69e8b</Data> <Data>c0000005</Data> <Data>000ed689</Data> <Data>17a0</Data> <Data>01c9be8e462b41ea</Data>

</EventData>

</Event>

Log Name: Application Source: Application Error Date: 16-4-2009 14:22:10 Event ID: 1000 Task Category: (100) Level: Error Keywords: Classic User: N/A Computer: INCONF08 Description: Faulting application VirtualBox.exe, version 2.2.0.0, time stamp 0x49dba8b4, faulting module USER32.dll, version 6.0.6001.18000, time stamp 0x4791a773, exception code 0xc0000409, fault offset 0x00065203, process id 0x1d7c, application start time 0x01c9be8dc71eb0da. Event Xml: <Event xmlns=" http://schemas.microsoft.com/win/2004/08/events/event">

<System>

<Provider Name="Application Error" /> <EventID Qualifiers="0">1000</EventID> <Level>2</Level> <Task>100</Task> <Keywords>0x80000000000000</Keywords> <TimeCreated SystemTime="2009-04-16T12:22:10.000Z" /> <EventRecordID>9056</EventRecordID> <Channel>Application</Channel> <Computer>INCONF08</Computer> <Security />

</System> <EventData>

<Data>VirtualBox.exe</Data> <Data>2.2.0.0</Data> <Data>49dba8b4</Data> <Data>USER32.dll</Data> <Data>6.0.6001.18000</Data> <Data>4791a773</Data> <Data>c0000409</Data> <Data>00065203</Data> <Data>1d7c</Data> <Data>01c9be8dc71eb0da</Data>

</EventData>

</Event>

comment:6 Changed 5 years ago by sunlover

  • Guest type changed from Windows to other
  • Summary changed from Shared Folders Error on Windows Vista Host to Shared Folders GUI Error on Windows Host -> Fixed in SVN

Ticket #3756 has been marked as a duplicate of this one.

The fix will be available in the next maintenance release.

comment:7 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

comment:8 Changed 4 years ago by Barron123

Resource:  gotomypc

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use