VirtualBox

Ticket #3723 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

VB guest crashed while typing into window => Fixed in SVN

Reported by: stephanecharette Owned by:
Priority: major Component: clipboard
Version: VirtualBox 2.2.0 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description

Deleted previous version of VB and upgraded to VB220-r45846 64-bit today. Host is Ubuntu 8.10-64bit, guest is Debian Etch 4-64bit. Re-installed guest additions and rebooted guest.

After about 3 hours of uptime, my guest window "went away" (complete crash) while I was in the middle of typing into a Source Navigator Window. At the time I was editing a C++ source file. No information window, warning, or anything else was displayed. The Sun VirtualBox GUI says my guest state is "aborted".

My VBox.log file ends with the following: 02:59:23.658 TM: Giving up catch-up attempt at a 60000723588 ns lag; new total: 1382984766968 ns 03:15:39.774 TM: Giving up catch-up attempt at a 60000333222 ns lag; new total: 1442985100190 ns 03:22:54.590 vboxClipboardConvertToUtf8ForX11: VBoxX11ClipboardReadVBoxData returned VERR_TIMEOUT

Is this clipboard message the cause of the crash? If not, I have no idea where else to look to find the cause of the crash.

Attachments

VBox.log Download (46.9 KB) - added by stephanecharette 5 years ago.
vboxClipboardConvertToUtf8ForX11: VBoxX11ClipboardReadVBoxData returned VERR_TIMEOUT
VBoxSharedClipboard.so-x86 Download (32.5 KB) - added by michael 5 years ago.
32bit version of the fixed file
VBoxSharedClipboard.so-amd64 Download (33.8 KB) - added by michael 5 years ago.
64bit version of the fixed file

Change History

Changed 5 years ago by stephanecharette

vboxClipboardConvertToUtf8ForX11: VBoxX11ClipboardReadVBoxData returned VERR_TIMEOUT

comment:1 Changed 5 years ago by frank

Of course a  core dump of that session would be highly interesting but I assume you don't have one...

comment:2 Changed 5 years ago by alexk

I can reproduce this reliably when copy/pasting data from Excel to Access. I will try to create a core dump and post it here.

comment:3 Changed 5 years ago by alexk

Frank, I've got the dump but it's huge even after compression (90MB). I will upload it somewhere and email you the link.

I didn't have this problem in previous versions (2.1.4 and before), so it looks like a regression in version 2.2.0

I can reproduce the error on Ubuntu 8.10 64-bit and Ubuntu 9.04 64-bit hosts running the same Windows XP Professional SP3 32-bit guest.

Please let me know if you need more information and thanks for looking into this issue.

Cheers, Alex

comment:4 Changed 5 years ago by frank

Alex sent me a core dump which will probably help finding the problem. Seems to be indeed a clipboard problem.

comment:5 Changed 5 years ago by tlbdk

I having the same problem with Ubuntu host and Windows XP and Vista guests one two machines.

comment:6 Changed 5 years ago by everette.denney

I have the same problem with Fedora 10 (2.6.27.19-170.2.35.fc10.x86_64). Using 2.2 r45846. Exactly the same error. I'm using MS Project 2K7, and I'm copying and pasting inside the same program. Ouput from VBox.log:

00:02:25.822 Guest Log: VBoxTray: Started. 00:02:31.650 Shared clipboard: starting host clipboard thread 00:02:36.636 Guest Additions capability report: (0x5) seamless: yes, hostWindowMapping: no, graphics: yes 00:02:37.397 Display::handleDisplayResize(): uScreenId = 0, pvVRAM=00007f87c4000000 w=1424 h=770 bpp=32 cbLine=0x1640 00:02:37.397 VBVA: Disabled. 00:02:37.445 VBVA: Enabled. 00:03:02.168 Guest Log: VBOXNP: DLL loaded. 00:03:06.960 PIT: mode=2 count=0x2ead (11949) - 99.85 Hz (ch=0) 00:04:30.098 Guest Log: VBOXNP: DLL unloaded. 01:09:41.248 vboxClipboardConvertToUtf8ForX11: VBoxX11ClipboardReadVBoxData returned VERR_TIMEOUT

Where is the core file located? I'll upload via dropbox if need be and provide a link for download.

Thanks.

Best regards,

Everette

comment:7 Changed 5 years ago by frank

Everette, thank you but I think your core dump isn't required anymore. It seems that we found the problem.

comment:8 follow-up: ↓ 9 Changed 5 years ago by frank

  • Summary changed from VB guest crashed while typing into window to VB guest crashed while typing into window => Fixed in SVN

comment:9 in reply to: ↑ 8 Changed 5 years ago by everette.denney

Replying to frank: Thanks. Is there anyway I can get an RPM of the latest build with the fix? (I don't want to build from source, if that's ok.)

Changed 5 years ago by michael

32bit version of the fixed file

Changed 5 years ago by michael

64bit version of the fixed file

comment:10 follow-ups: ↓ 11 ↓ 12 Changed 5 years ago by michael

I have attached updated versions of the files containing the bug, for 32bit and 64bit hosts. To try them out, replace VBoxSharedClipboard.so with the correct one of these for your host (keep a backup of the old one of course!)

comment:11 in reply to: ↑ 10 Changed 5 years ago by alexk

Replying to michael:

I have attached updated versions of the files containing the bug, for 32bit and 64bit hosts. To try them out, replace VBoxSharedClipboard.so with the correct one of these for your host (keep a backup of the old one of course!)

Thanks Michael, replacing VBoxSharedClipboard.so fixed it for me (on a 64-bit host)

comment:12 in reply to: ↑ 10 ; follow-ups: ↓ 13 ↓ 14 Changed 5 years ago by Dominic Battre

The VBoxSharedClipboard.so-x86 fixed the crashing for me but broke the shared clipboard. Copying something does not work in either direction.

comment:13 in reply to: ↑ 12 Changed 5 years ago by alexk

Replying to Dominic Battre:

The VBoxSharedClipboard.so-x86 fixed the crashing for me but broke the shared clipboard. Copying something does not work in either direction.

Just checked, the 64-bit version works fine.

comment:14 in reply to: ↑ 12 ; follow-up: ↓ 15 Changed 5 years ago by NoOp

Replying to Dominic Battre:

The VBoxSharedClipboard.so-x86 fixed the crashing for me but broke the shared clipboard. Copying something does not work in either direction.

Same problem w/x86. Host: linux (Ubuntu 8.04.02) Guest: Win2KPro. I can no longer copy & paste between the Host & Guest. The good news is that MS Office 97 no longer crashes immediately following application (Word, Excel, etc) startup.

comment:15 in reply to: ↑ 14 Changed 5 years ago by NoOp

Replying to NoOp:

Replying to Dominic Battre:

The VBoxSharedClipboard.so-x86 fixed the crashing for me but broke the shared clipboard. Copying something does not work in either direction.

Same problem w/x86. Host: linux (Ubuntu 8.04.02) Guest: Win2KPro. I can no longer copy & paste between the Host & Guest. The good news is that MS Office 97 no longer crashes immediately following application (Word, Excel, etc) startup.

Out of curiosity, I replaced the VBoxSharedClipboard.so file with the one from my 2.1.4 installation & I can now copy/paste both directions and, MS Office no longer crashes the Guest. Perhaps the issue is/was that the VBoxSharedClipboard.so-x86 file supplied in the attachment is an html file rather than an .so file & it simply wasn't running when I tested previously?

comment:16 Changed 5 years ago by NoOp

Well now I feel a bit silly... I'd forgotten that you need to click on the attachment in order to download the binary file (raw). Both files are .so files now. Sorry about the noise. Note: given that the 2.1.4 .so is working I'll leave that one in place unless there is a compelling reason to replace with the patched x86 .so.

comment:17 Changed 5 years ago by ToddAndMargo

I have the same problem. See bug 3801#1 and 1921#19, which are probably duplicates of this one

comment:18 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

comment:19 Changed 5 years ago by jedmonds

  • Status changed from closed to reopened
  • Resolution fixed deleted

I have the same problem with an OpenSolaris x64 host and a Win XP 32-bit guest. Is there a patched version of VBoxSharedClipboard.so available for OpenSolaris?

comment:20 Changed 5 years ago by frank

jedmonds, are you 100% sure that you tried VirtualBox 2.2.2? If so, please attach a VBox.log file of such a crashed VM session.

comment:21 Changed 5 years ago by jedmonds

No, I'm currently running VirtualBox 2.2.0 as per the bug specified in this ticket. Once 2.2.2 is available from the OpenSolaris Extras repository I will upgrade.

comment:22 Changed 5 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

Please reopen if this problem persists. Make sure you test VirtualBox 2.2.2 or later (2.2.4 was just released).

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use