VirtualBox

Ticket #3722 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

Slow startup after installing Virtualbox 2.2.0

Reported by: ikerrg Owned by:
Priority: major Component: network
Version: VirtualBox 2.2.0 Keywords: slow startup vista x64
Cc: Guest type: Linux
Host type: Windows

Description

I've just installed Virtualbox 2.2.0 in Vista x64 host over the old 2.1.0 version. Now the time to start my system has increased enormously after the logon screen. It seems like Vista x64 is trying to setup the network connections and lasts a long time. I've tried many times but always happens the same. Now I have disabled the new network adapter and the system is again starting up fast. I use NAT for all my virtual machines, however the problem is not related with that.

Best regards

Change History

comment:1 follow-up: ↓ 7 Changed 5 years ago by misha

Just for confirmation: the problem disappears after you disable the VirtualBox Host-Only Ethernet Adapter, right?

This happens because windows is trying to establish all network connections on logon and fails to do it for the Host-Only adapter.
We will investigate this problem.

comment:2 Changed 5 years ago by ikerrg

Yes, you are right. After disabling the VirtualBox Host-Only Ethernet Adapter the system logs on fast.

Thank you for your support.

comment:3 Changed 5 years ago by rasta

With a WinXP host, and Solaris 10 guest using NAT networking, I had the same problem with VERY slow host booting (10x slower than normal). When you say "disable Vbox host-only adapter," what is your recommended way of doing so?

I removed 2.2 and then re-installed it WITHOUT the Vbox networking package, and booting returned to normal. Is there a better way of disabling the host-only adapter? Device manager?

From forum:

"My experience with 2.2 on a WinXPsp3 32-bit host on Active Directory network, Solaris 10 guest with NAT networking.

Installed 2.2 over 2.1.4. With 2.2, guest could connect to web normally and to host (with new shared folders). However, host would boot 10x slower than before, and host-only networking icon in system tray showed no connectivity. Tried re-install of 2.2 with repair, and repair via Add/Remove programs, both to no effect. Then removed 2.2 completely via Add/Remove and rebooted. "Clean" install of 2.2 failed with rollback. Tried re-installing again, this time unchecking Vbox networking package. Install completed, everything works fine now, no host-only networking icon in system tray, normal host boot speed, guest STILL connects to web normally."

comment:4 Changed 5 years ago by misha

The optimal way for now is either disable the host-only adapter in a device manager.
or set a static IP config for it.
The latter could be done either by VBox GUI: menu File->Settings->Network->Open settings dialog for the host-only network -> in "Adapter" tab select "Manual" & type manual settings
or via standard Windows Network connection properties UI.

Not installing a network component would work as well, however you will not be able to use bridged & host-only networking without it.

comment:5 follow-up: ↓ 6 Changed 5 years ago by rasta

Great. Thank you, misha. When 2.2.1 comes out with networking bugs hopefully fixed, should I be able to install the Vbox networking component and not experience the slow booting (as was the case with 2.1.4 and earlier), or do you think that I should install everything and disable the host-only networking? Since I use NAT with my guest, I probably won't need bridged or host-only networking, but I would like to have the networking component installed so that I can try it when I need it in the future.

comment:6 in reply to: ↑ 5 Changed 5 years ago by misha

Replying to rasta: Yup, we hope to have this fixed soon

comment:7 in reply to: ↑ 1 ; follow-up: ↓ 8 Changed 5 years ago by schmoemi

Replying to misha:

We will investigate this problem.

I think it's obvious what happens here and it all seems quite logical that it has to be like it is :-)

VB adds a new maiden network adapter on the host, called "Virtualbox Host-only Network". The poor little thing is treated by the host OS like any other network adapter, and as such, to work properly, it must be provided with an IP adress/netmask assigned to... you know, the network config stuff.
By default this config would be obtained by DHCP, i.e. there has to be a DHCP-server somewhere on the network the adapter is connected to to provide that config information and this is usually done on bootup.
But, there is a little problem here with our "Virtualbox Host-only Network"-Adapter here: As it is only connected to any (running) VMs connected to the host-only network, there is no DHCP-Server anwhere on the net which could provide the config data. (especially not on host bootup, where we can assume virtualbox is not running.)

Setting a fixed IP/netmask for the "Virtualbox Host-only Network"-Adapter by default should fix that.

But I think you knew that already.

comment:8 in reply to: ↑ 7 Changed 5 years ago by misha

Replying to schmoemi: see comment 4

comment:9 Changed 5 years ago by misha

We've fixed this issue.
For those willing to try a fix: please send me a mail at Mikhail dot Sennikovsky at sun dot com. I'll then send you a link to a new test VBox version containing the fix.

comment:10 Changed 5 years ago by ikerrg

Thank you. However I prefer not to install the Virtualbox Network Adapter because I do only use NAT connection for my VMs. Anyway, thank you very much for your support. For sure this fix will be very useful for many advanced users.

Best regards.

comment:11 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

Should be fixed in 2.2.2.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use