VirtualBox

Ticket #3721 (closed defect: duplicate)

Opened 5 years ago

Last modified 5 years ago

Unable to allocate and lock memory

Reported by: wamorita Owned by:
Priority: major Component: VMM
Version: VirtualBox 2.2.0 Keywords: handy pages
Cc: Guest type: other
Host type: other

Description (last modified by frank) (diff)

I am unable to run VB 2.2.0. Error occurs running both OpenSolaris and OpenBSD. Host system is an XP Pro 2002 system: Dual 2.4 Ghz Intel Core2 Duo P8600 with 2G RAM

From the tail of VBox.log:

00:05:45.504 PGM: Failed to procure handy pages; rc=VERR_NO_MEMORY rcAlloc=VINF_SUCCESS 
    rcSeed=VERR_NO_MEMORY cHandyPages=0x14
00:05:45.504      cAllPages=0x4106c cPrivatePages=0x34be4 cSharedPages=0x0 cZeroPages=0xc488
00:05:45.505 PGM: Failed to procure handy pages; rc=VERR_NO_MEMORY rcAlloc=VINF_SUCCESS
    rcSeed=VERR_NO_MEMORY cHandyPages=0x14
00:05:45.505      cAllPages=0x4106c cPrivatePages=0x34be4 cSharedPages=0x0 cZeroPages=0xc488
00:05:45.505 VM: Raising runtime error 'HostMemoryLow' (fFlags=0x2)
00:05:45.505 Changing the VM state from 'RUNNING' to 'SUSPENDED'.
00:05:45.566 Console: VM runtime error: fatal=false, errorID=HostMemoryLow
message="Unable to allocate and lock memory. The virtual machine will be paused.
Please close applications to free up memory or close the VM"

Virtual Box System configuration: OpenSolaris
Base Memory: 1024
Video Memory: 12
Rest are default settings

Change History

comment:1 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate
  • Description modified (diff)

Sounds like a duplicate of #3657.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use