VirtualBox

Ticket #3657 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

HostMemoryLow => Fixed in SVN

Reported by: rasta Owned by:
Priority: major Component: other
Version: VirtualBox 2.2.0 Keywords: host memory low
Cc: Guest type: other
Host type: Windows

Description (last modified by frank) (diff)

HOST:

  • WinXPsp3 32-bit with VT (dual quad-core E5345 processors)
  • 4 GB RAM
  • NVIDIA Quadro FX 3500 video card, 256 MB VRAM
  • ACPI, IO APIC, VT-x enabled

GUEST:

  • Solaris 10 u5 x86
  • 32- and 64-bit
  • 1524 MB RAM allocated
  • 128 MB VRAM

When running a process in the Solaris guest that worked under Vbox 2.1.4, the guest pauses with this error:

Error ID: HostMemoryLow
Severity: Non-fatal Error

The guest cannot be resumed, and must be powered off. Log file made after brutal power off is attached.

This error happens if the guest is run as 32- or 64-bit. Allocating several hundred more MB of RAM to the guest did not help.

Attachments

rasta_08-2009-04-08-14-17-41.log Download (56.4 KB) - added by rasta 5 years ago.

Change History

Changed 5 years ago by rasta

comment:1 follow-up: ↓ 2 Changed 5 years ago by frank

  • Description modified (diff)
  • Summary changed from Host Memory Low errors stops Solaris 10 guest : Vbox 2.2 to Host Memory Low

Try to reduce the amount of memory allocated to that VM. It seems that VBox 2.2 on Windows / x86 has some problems allocating suitable memory pages for the guest.

comment:2 in reply to: ↑ 1 Changed 5 years ago by rasta

Replying to frank:

Frank,

I reduced the guest memory allocation to 1280 MB, and the process ran as before. Thank you VERY MUCH for your suggestion!!!!!

By the way, the Solaris guest additions for Vbox 2.2 are FANTASTIC, a real improvement. The shared folders work great! However, the Changelog mentions "OpenGL 3D acceleration for Linux and Solaris guests (see chapter 4.8, Hardware 3D acceleration (OpenGL)" but that chapter mentions only Linux and Windows guests. Does the 3d accel really work with Solaris guests or not?

Thanks again!

comment:3 Changed 5 years ago by frank

Should work with Solaris as well though support is still experimental. The manual was apparently not properly updated.

comment:4 Changed 5 years ago by marcomsousa@…

Same problem "Host Memory Low" in Windows XP SP3 host and guest.

comment:5 Changed 5 years ago by marcomsousa@…

I reduce the memory of the guess to 300MB, and it seems works well.. But in vmware I can have the same vm, with 1024MB.

I have 2GB in my machine.

It seems that have VirtualBox have problems with reserve memmory.

comment:6 Changed 5 years ago by frank

Sure, this is a regression and will be fixed. Thanks for your report.

comment:7 Changed 5 years ago by mathias

I have the following HOST:

Windows Server 2003 (64bit)
8GB RAM
DualCore CPU

5 GUESTS:

Windows Server 2003 Web-Edition (32bit)
750MB - 1GB RAM

On starting all virtual maschines I get the message 'Host Memory Low'. This message seems to appear if the required memory of all virtual maschines together are 4GB. But there are nearly 3GB free physical memory. So now I can start only 4 maschines.

comment:8 Changed 5 years ago by Riga

The same problem on Windows XP SP3 x86 and Win XP x64(!) SP1 during Debian guest x86 and x64 installation. I did't try 300 mb to guest yet, but 300 is too small for normal tasks. It remains only to wait for a fix.

comment:9 Changed 5 years ago by chdh

I have the same problem with WinXP SP3 host and guest.

comment:10 Changed 5 years ago by doudoudoudou

I have the same problem with WinXP SP2 host, It never happends on 2.1.4

comment:11 Changed 5 years ago by eythort

same problem here on a winxp pro sp3 host, kubuntu 8.10 guest (1337 MB allocated memory, 128 MB to video mem). Almost 1 GB of host memory free.

comment:12 Changed 5 years ago by frank

  • Summary changed from Host Memory Low to HostMemoryLow

comment:13 Changed 5 years ago by frank

  • Guest type changed from Solaris to other

comment:14 follow-up: ↓ 15 Changed 5 years ago by mgwolters

I have exactly the same problem. Everything worked okay untill the install of VB 2.2.0. There is more then enough physical memory on my machine (4 GB) and I have to reduce the memory allocated to the VM's (all of them: VISTA, Intrepid, Windows 2007) to 512 MB to stop the annoying freezes and HostMemoryLow error. This must be a bug in the new release! To be clear the VM's are not running together (i.e. at the same time).

comment:15 in reply to: ↑ 14 Changed 5 years ago by jamescary

Same problem with a Windows host and CentOS 5 guest. Windows host is 32 bit XP SP 3 with 2gb ram. Guest is CentOS 5. Ran fine under previous versions of VirtualBox with 950 MB ram allocated and 32 mb video ram allocated. Now will not run for more than about 10 minutes running eclipse in the Virtual machine if more than 750 mb of ram are allocated.

comment:16 follow-up: ↓ 20 Changed 5 years ago by frank

  • Summary changed from HostMemoryLow to HostMemoryLow => Fixed in SVN

We think we found the problem. The fix will be available with the next maintenance release.

comment:17 Changed 5 years ago by dianzihe

I get the same problem ,Windows host is 32 bit VISTA ,memory allocated for the guest is 384MB,Guest OS is cent OS 5

comment:18 Changed 5 years ago by choekstra

Hi Guys,

Just additional information that may help or even confirm the problem.

My configuration is:

  • AMD Phenon II X4 920
  • 8GB DDR2, Four Modules
  • AMD 770 Chipset

Host:

  • Windows Vista Enterprise, SP1, x86 64-bit
  • When just started, 6GB memory free

Guest:

  • Windows 2008 x86 64-bit
  • 4096 Memory allocated
  • sATA disks
  • All the CPU features enabled

Problem: When starting the guest, it will show the initial black windows text start up screen, that the guest is paused and vBox presents the already known error message.

However it seems to work as long I do not configure the guest with more that 2048MB memory. Which is in this case an issue, because Windows 2008 x86 64bit Small Business Server requires 4GB of memory to even run.

comment:19 Changed 5 years ago by JoCat

Same problem here. Configuration:

Intel Core 2 Duo 2 Gigs DDR2

Host:

Windows Vista 64

Guests:

Debian 5.0 (Runs out of memory with every permutation of features) Ubuntu 8.10 (Runs out of memory with every permutation of features) OpenSuse 11.1 (Runs out of memory with every permutation of features)

No matter how much memory I allocate to the Linux guests, I have a paused VM without enough memory. I've tried enabling and disable PAE, VX-T, and changing the amount of ram present, but to no avail. These worked fine in VBox 2.14.

comment:20 in reply to: ↑ 16 Changed 5 years ago by rgtripathi

Replying to frank:

We think we found the problem. The fix will be available with the next maintenance release.

Hello,

Do we know when could we expect the next maintenance release ? Is it possible to degrade the VBox version to 2.1.4 (from 2.2.0) as an interim solution ?

Thanks,
Rakesh

comment:21 Changed 5 years ago by JoCat

I was able to uninstall VirtualBox 2.2.0 and reinstall 2.1.4, then add the virtual disks from my old VMs. You'll have to reconfigure the machines (and rebuild the guest addons if you installed them), but it should work.

comment:22 follow-up: ↓ 23 Changed 5 years ago by marcomsousa@…

Hi Frank,

It's possible to release the exe/dll for this fix? Or the 2.2.1Beta..

Thanks

comment:23 in reply to: ↑ 22 Changed 5 years ago by tamjaraujo

Replying to marcomsousa@gmail.com:

Hi Frank,

It's possible to release the exe/dll for this fix? Or the 2.2.1Beta..

Thanks

Hi. I agree with marcomsousa. I use VirtualBox in my laptop for many tests, but due to this error I can't run more than one virtual machine at a time. This is becoming a very critical issue to me, and to many others, I'm sure.

I know you guys have a schedule, and by all means I don't intend to tell you what to do, for I am not your boss or anything. I also know that a fix is available through SVN, but that's not an option for me. I just want to bring some more attention to this matter, as it's really affecting my tests. Please know that I support vbox, and think it is the best virtualization alternative so far.

Thanks a lot!

comment:24 Changed 5 years ago by JoCat

Thirded. VirtualBox 2.2.0 is no longer usable, even with only one VM running and no other programs running.

comment:25 Changed 5 years ago by hurryHu

BTW: VB 2.2.0 runs perfect (with 4 or 5 guests on host XP-x64, 8GB RAM) _before_ last patchday from Microsoft. Any connection?

comment:26 Changed 5 years ago by titantux

Still happen to me with VB 2.2.0 Host Vista 2 GB RAM an guest Ubuntu 8.10. I had using 1 Gb with my virtual machine even when warning me about the memory with VB 2.1.4 I had no problems, now I did a try it with 768 MB in RAM and still happen it. Does exist any fix yet ?

Thanks, great work!!!

comment:27 Changed 5 years ago by ko-ga

I've the same problem. I'm using Lenovo T61 notebook with 2GB, XP SP3 Host. Various guests, but I cannot run more than one at the same time.

In 2.1.4 I was suffering of hibernation issue of VTx, and I've upgraded as soon as 2.2.0 was released.

Have read al the comments under this topic I found that it is some memory allocation error and started to experiment with memory sizes. I did not spent more than 15 minutes.

I found that I could rune two XP guests, with 512MB and 256MB allocated memory.

The original values were 512MB and 384MB, but using those figures I could run only one VM. Whichever I started as the second one, it was paused due to HostMemoryLow and had to be "switched off". Alternatively I was able to save state of the one, then resume the other.

In another experiment with XP/512MB and Vista/512MB guests starting the Vista as the second one caused a more serious problem, because BOTH got paused, and without switching one off, I could not resume either of them.

Guys, I really am an enthusiast of VirtualBox, but such anoying problems making me frustrated. Appart from the repetitive trouble of network adapters upgrading is a smooth thing. You should provide a similar way of downgrading at least to the last previous release. Or provide a simple way of full backup/restore, so that all virtual disks and machine configurations could be backed up to an external harddrive and restored with a rollback to the previous release.

Today, doing so requires so much of efforts, that I try to avoid it, despite VDI backups are taken prior to every single upgrade.

Thanks in advance for considering.

comment:28 follow-up: ↓ 29 Changed 5 years ago by coolbiker

I have low memory with 3 512MB windows server 2008's. Title says fixed in SVN, where do I get it?

Thanks

comment:29 in reply to: ↑ 28 ; follow-up: ↓ 31 Changed 5 years ago by tamjaraujo

Replying to coolbiker:

I have low memory with 3 512MB windows server 2008's. Title says fixed in SVN, where do I get it?

Thanks

SVN is the source code version control system. You'd have to set up an environment with all the required libraries, download the source and build it yourself. No need to say it requires programming skills and time. You can browse the SVN at:  http://www.virtualbox.org/browser.

[]s

comment:30 Changed 5 years ago by brice

I have 1.7 Gb of host RAM, and can reproduce this bug when assigning 792Mb (I settled around 512Mb, so far so good, but useless for more resource hungry images). This is rather critical, considering that it's not easy to go back to the previous VB version.

Any idea when the new maintenance release is planned for ? I would build from SVN, but considering this bug occurred in a production release, who knows what might happen with an unstable development version.

comment:31 in reply to: ↑ 29 Changed 5 years ago by coolbiker

Replying to tamjaraujo:

Replying to coolbiker:

I have low memory with 3 512MB windows server 2008's. Title says fixed in SVN, where do I get it?

Thanks

SVN is the source code version control system. You'd have to set up an environment with all the required libraries, download the source and build it yourself. No need to say it requires programming skills and time. You can browse the SVN at:  http://www.virtualbox.org/browser.

[]s

If I had a good idea of your folder scheme it might be something to try but I'm unsure what to add if I tried. Is there a nice manual of how to put this together?

for now I can at least run a few vb's by turning down the memory needs but even then it won't let me have more than 2 boxes running at a time. SO far 2 server 2008's at 300MB and then trying to add 1 256 MB server 2003 to a 4GB system only using 1.22GB wont allow and pausing the other boxes doesn't release memory for the other boxes As I was hoping.

btw does on the browser site "svn iqnore= out " mean release is coming soon so I shouldn't be bothering? Would love to see releaseprep=true/false

comment:32 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

comment:33 Changed 5 years ago by rgtripathi

Hello - Can a veteran please shed some light on when could we expect a fix for this bug, and whether there is a next maintenance release lined up soon ? Thanks.

comment:34 Changed 5 years ago by marcomsousa@…

rgtripathi you allready can download the vmware 2.2.0 from the website.

comment:35 Changed 5 years ago by marcomsousa@…

VMware no, Sorry.. Virtualbox.

comment:36 Changed 5 years ago by mgwolters

It could be that I'm completely lost marcomsousa but the problems are with 2.2.0.

comment:37 Changed 5 years ago by marcomsousa@…

erm... download 2.2.2 that are in the website..

Sorry for the two mistake

comment:38 Changed 5 years ago by Riga

Many thanks to the VB team for the recent rapid release!

comment:39 Changed 5 years ago by tamjaraujo

Great! Guys, you're the best! Long live VirtualBox!

comment:40 Changed 5 years ago by rgtripathi

Kudos to the VirtualBox team for releasing v2.2.2. A quick turnaround on this problem deserves appreciation.

I have been able to cross the hurdle of HostMemoryLow that I was facing on WinXP (2GB physical memory) host and Oracle Enterprise Linux guest.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use