VirtualBox

Ticket #3710 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

Incomplete uninstall; installation failure

Reported by: dduster Owned by:
Priority: major Component: installer
Version: VirtualBox 2.2.0 Keywords:
Cc: Guest type: Windows
Host type: Windows

Description

I installed VirtualBox-2.2.0-45846-Win.exe then decided to remove it and install it on a different machine.

I now have an unknown "Net" device in the device manager. Re-installing failed midway.

I considered installing 2.1.4, but the link is broken.

Please advise.

Change History

comment:1 follow-up: ↓ 3 Changed 5 years ago by huygens_25

Same problem here. After reboot, Windows is looking for a Net device and does not find any suitable driver. In addition (potentially a side effect from this) upon login, the system is kind of frozen for about a minute (no hard disk or network activity visible, no responds to keyboard actions like even Ctrl+Alt+Del, the only visible thing is the user desktop wallpaper, no tasks bar yet...). I am on Windows XP SP3 32bit. I have upgraded from VBox 2.1.4. I wanted to do a clean install to see if it would correct the problem but it is not working: Bug #3701

comment:2 in reply to: ↑ description Changed 5 years ago by misha

Replying to dduster:

I installed VirtualBox-2.2.0-45846-Win.exe then decided to remove it and install it on a different machine.

I now have an unknown "Net" device in the device manager. Re-installing failed midway.

Some questions for clarification:

  1. Which SO version are you running?
  2. Which VBox version did you have installed before updating to 2.2 ?
  3. Did you install on top of the previously installed VBox or uninstalled it first?
  4. Please attach  msi & setupapi logs for your installs/uninstalls
    <windir>\setupapi.log & <windir>\inf\setupapi.dev.log & <windir>\inf\setupapi.app.log files should already contain the info about the failed 2.2 uninstall(since some logging should be enabled by default).
    So it would be useful to have the complete setupapi log files from you.

comment:3 in reply to: ↑ 1 Changed 5 years ago by misha

Replying to huygens_25:

Same problem here. After reboot, Windows is looking for a Net device and does not find any suitable driver.

Please enable  msi & setupapi loging and reboot to repeat the scenario of "Windows is looking for a Net device.." (to make the details be logged in setupapi logs)
Please also try installing with  msi & setupapi loging enabled
and attach the complete msi & setupapi logs here.

comment:4 Changed 5 years ago by huygens_25

I have been deleting the faulty device (Net) so that now Windows does not prompt me again for the driver. So I cannot reproduce the problem. And as I cannot uninstall and install again VBox (Bug #3701), I cannot get back that driver... If this device appears again, I will follow the instructions you pointed and send you back the necessary log files.

comment:5 Changed 5 years ago by misha

To all having issues with bridged interfaces not being displayed or having the install problems on windows:
Please send me a mail at Mikhail dot Sennikovsky at sun dot com. I'll then send you a link to a new test VBox version containing installation fixes.

To all not being able to uninstall VBox 2.2 on windows:
Please see my comment 6 to #3701

comment:6 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

Please try again with 2.2.2 and reopen if necessary.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use