VirtualBox

Ticket #3663 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

bridge network dont work in virtualbox 2.2 on windows vista x64 host

Reported by: ZOleg Owned by:
Priority: critical Component: network
Version: VirtualBox 2.2.0 Keywords:
Cc: Guest type: Windows
Host type: Windows

Description

“net filter” driver dont installed ( VBoxNetFlt.sys not copied nor to Windows\System32\drivers nor to \Program Files\Sun\xVM VirtualBox\drivers\network\netflt\miniport )

Attachments

vbox-2.2-1.png Download (109.9 KB) - added by ZOleg 5 years ago.
Screenshot 1
vbox-2.2-2.png Download (97.3 KB) - added by ZOleg 5 years ago.
Screenshot 2
vbox-2.2-3.png Download (26.0 KB) - added by ZOleg 5 years ago.
Screenshot 3
VBox.log Download (46.8 KB) - added by ZOleg 5 years ago.
vbox_glitch.jpg Download (47.0 KB) - added by neo314 5 years ago.
Error on bridged connection preventing start of VM

Change History

Changed 5 years ago by ZOleg

Screenshot 1

Changed 5 years ago by ZOleg

Screenshot 2

Changed 5 years ago by ZOleg

Screenshot 3

Changed 5 years ago by ZOleg

comment:1 Changed 5 years ago by misha

Could you try re-installing the VirtualBox 2.2, and let me know whether this helps

comment:2 Changed 5 years ago by supernikita

I have the same problem. Actually I think the NAT doesn't work as well. So I can't connect to Internet from the guest anyway. I have guest: WinXP, host: Win Vista x64.

comment:3 Changed 5 years ago by ZOleg

I repair installed VirtualBox 2.2 from Control Panel and now bridge network work for me.

comment:4 Changed 5 years ago by supernikita

Uninstallation doesn't work (see #3701) but repairing helped me as well.

comment:5 Changed 5 years ago by ncastrog

Same behavior on ubuntu 8.10 x86_64 and XP professional x86.

comment:6 follow-up: ↓ 11 Changed 5 years ago by baroldgene

I have the same issue. No errors, but the guest cannot see anything on the network. I've tried both DHCP and Static IP. The interface shows zero packets received.

comment:7 Changed 5 years ago by baroldgene

I should have mentioned I'm running both XP and Ubuntu on a Vista x64 host.

comment:8 follow-up: ↓ 9 Changed 5 years ago by neo314

I have the same issue. Vista x64 Ultimate. I upgraded from the last version without uninstalling. I get an unknown device in network adapters I cannot find a drive for including in the VBox drivers directory. With or without the unknown device removed, regardless of which of the two adapters I choose, I get an error that the VM cannot start if I try a bridged connection, and it starts with a NAT connection, but I did get it to work once, other times not in trying to fix the problem.

I need to go back to a prior backup until this is resolved.

Changed 5 years ago by neo314

Error on bridged connection preventing start of VM

comment:9 in reply to: ↑ 8 Changed 5 years ago by neo314

Replying to neo314: P.S. I did try the repair option under several different scenarios without any success.

comment:10 Changed 5 years ago by misha

To all seeing install/uninstall problems please attach  msi & setupapi logs to #3701
Others seeing bridged network issues try re-installing as per Comment 1
All: please also specify from which version you upgraded, i.e. 2.1.4 or 2.2beta[1 or 2]

comment:11 in reply to: ↑ 6 Changed 5 years ago by misha

Replying to baroldgene:

I have the same issue. No errors, but the guest cannot see anything on the network. I've tried both DHCP and Static IP. The interface shows zero packets received.

What kind of networking do you use here? Bridged? NAT? ..?

comment:12 Changed 5 years ago by Diago

Running on Vista x64 Host using Windows Server 2008 x64 Guest. No network adapters found under the bridge networking setup. NAT and Host-Only networking works fine.

comment:13 Changed 5 years ago by misha

To all having issues with bridged interfaces not being displayed or having the install problems on windows: Please send me a mail at Mikhail dot Sennikovsky at sun dot com. I'll then send you a link to a new test VBox version containing installation fixes.

To all not being able to uninstall VBox 2.2 on windows: Please see my comment 6 to #3701

comment:14 Changed 5 years ago by rusi

Deinstalling virtualbox, reinstalling again and recreating my guests worked well for men (copying only the harddisk images, but not the configs). This worked under Win Vista x64 as host and Win XP (x86) and Ubuntu 9.04 (x64) as guests.

comment:15 follow-up: ↓ 16 Changed 5 years ago by Nephom

This issue in virtualbox 2.2.2 on windows vista x64 host is the same.

comment:16 in reply to: ↑ 15 Changed 5 years ago by misha

Replying to Nephom:

This issue in virtualbox 2.2.2 on windows vista x64 host is the same.

What kind of issue do you see with VBox 2.2.2 ?

comment:18 Changed 5 years ago by andrewchoi

I have been having this bug in My Windows Vista x64 host.

But now, the problem is fixed. I think it is a VMx Upgrade Bug.

My System OS : Windows Vista x64

History :

  1. First time install VMx 2.0.x, Everthing is good and no any problem.
  2. Upgrade to VMx 2.2.0, The Bridge network and NAT cannot function. The Bridge Network cannot find my physical network interface. I have not do anything for repair these problem.
  3. Upgrade to VMx 2.2.2, Ooooo the USB Proxy display Error Message. The Bridge still cannot work.
  4. I try to looking the bug of Bug Ticket #3663 on here. Someone sugggest reinstall the VMx.
  5. I trying to uninstall VMx 2.2.x from Windows Control pannel, The result is I cannot uninstall it. After that I trying to using repair function, Ooo Some hardward detected by Windows System. and the message popup, "Please restart you computer". I just do it.
  6. After restart computer, I have not run VMx. I trying to install VMx 2.2.2. THE RESULT is EVERTHING NO PROBLEM.

Conclusion :- I think the VMx Upgrade procedure have some problem of Virtual Hardware at Windows Vista x64.

comment:19 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if still relevant with VBox 3.1.6.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use