VirtualBox

Ticket #3656 (closed defect: obsolete)

Opened 5 years ago

Last modified 3 months ago

Auto-resize Guest Display does not work anymore

Reported by: patrick.steiner Owned by:
Priority: major Component: other
Version: VirtualBox 2.2.2 Keywords:
Cc: Guest type: Linux
Host type: Mac OS X

Description (last modified by frank) (diff)

Since I habe updated to Virtualbox 2.2.0 the Auto-resize of the Guest Display does not work any more.

My host system is a Mac OS X (10.5.6) machine in my guest is a Fedora 10 Machine.

I also can not set the display resolution to 1280x800 on the guest system. it is only 1024x768 is available. But i have choosen a generic 1280x800 lcd display.

Attachments

xorg.conf Download (2.9 KB) - added by seiryu 5 years ago.
xorg.conf from OpenSolaris 2009.06

Change History

comment:1 Changed 5 years ago by michael

Patrick, could you provide the output (in a terminal on the guest) of 'ps ax | grep VBox'? And could you also attach (*not* copy and paste) your guest xorg.conf file and the VirtualBox log file for that VM (you can get that via the menus in the machine selector window on the host).

You might want to take a look at the user manual, section Advanced Topics/Configuring the maximum resolution of guests when using the graphical frontend regarding the second issue you reported.

comment:2 Changed 5 years ago by patrick.steiner

here are the running VBox processes:

# ps ax | grep VBox

2231 ? Sl 0:00 /usr/bin/VBoxClient --seamless 2892 ? Sl 0:03 /usr/bin/VBoxClient --clipboard

btw. i used vbox 2.1.4 before without problems.

i have tried to attach my xorg.conf but i always get an internal trac error so i posted it here:  http://pastebin.com/f59df19ed

comment:3 Changed 5 years ago by seiryu

I'm seeing the same problem with OpenSolaris 2009.06 as the guest. MacOSX host with Vbox 2.2.2. Guest is not responding to the auto-resize request. Will attach xorg.conf

Changed 5 years ago by seiryu

xorg.conf from OpenSolaris 2009.06

comment:4 Changed 5 years ago by michael

Patrick, sorry for my slow responses. Could you do the following when the problem occurs: enable  core dumps on your Linux guest, restart "VBoxClient --autoresize" and do whatever is needed to make autoresizing stop again? Then either make the core file available somewhere where I can download it (the core file from VBoxClient should not contain any "dangerous" information) or post a comment here (and tell me the compressed size of the core file) and I will send you private mail to tell you how to get it to me.

comment:5 Changed 5 years ago by patrick.steiner

Hi,

my problem seems to be fixes with VBox 2.2.2. I do not have any problems any more.

comment:6 Changed 5 years ago by seiryu

In Vbox.log I'm seeing:

00:01:26.213 VMMDev::SetVideoModeHint: got a video mode hint (1024x768x0) at 0 00:24:00.507 VMMDev::SetVideoModeHint: got a video mode hint (1099x846x0) at 0 00:24:09.121 VMMDev::SetVideoModeHint: got a video mode hint (1051x808x0) at 0 00:24:09.389 VMMDev::SetVideoModeHint: got a video mode hint (1052x808x0) at 0 00:24:09.721 VMMDev::SetVideoModeHint: got a video mode hint (1194x941x0) at 0

in response to changes in the window size.

Created a core of the guest - compressed it's 381M. I can make it and the associated Vbox.log available.

pkgchk of the guest additions is clean, running with 2.2.2 installed.

comment:7 Changed 5 years ago by jystickman

I am having similar problems using Solaris 10 Update 6 on an OS X VM. Regardless of the VirtualBox Additions software installed, the Xserver will not resize. In fact, it won't even expand into full screen mode. It seems permanently stuck at 1024x768. Even if I shrink the window, the Xserver will not resize - I end up getting scrollbars. Installing 2.2.0 back fixed the problem with no settings changes.

comment:8 Changed 5 years ago by michael

seiryu: removing all lines starting with "Modes" from your guest xorg.conf might help (please let me know if it does). Please do take all the usual precautions though (including a backup!) if/when editing xorg.conf.

comment:9 Changed 5 years ago by seiryu

Confirmed! Removed the Modes lines from xorg.conf and auto-resize is working again.

comment:10 Changed 5 years ago by jystickman

I didn't have any Modes lines in my xorg.conf.

Log files I'm seeing show that someone is sending hints, but it looks like the X server is not listening to them.

00:10:16.017 VBVA: Enabled.
00:10:16.017 Guest Additions capability report: (0x4) seamless: no, hostWindowMapping: no, graphics: yes
00:10:16.355 Guest requests mouse pointer integration
00:10:47.084 Audio: set_record_source ars=0 als=0 (not implemented)
00:10:47.086 Audio: set_record_source ars=0 als=0 (not implemented)
00:10:47.091 Audio: set_record_source ars=0 als=0 (not implemented)
00:11:22.837 VMMDev::SetVideoModeHint: got a video mode hint (1167x834x0) at 0
00:11:23.807 VMMDev::SetVideoModeHint: got a video mode hint (1222x834x0) at 0
00:11:24.433 VMMDev::SetVideoModeHint: got a video mode hint (1241x834x0) at 0
00:11:24.684 VMMDev::SetVideoModeHint: got a video mode hint (1246x834x0) at 0
00:11:25.690 VMMDev::SetVideoModeHint: got a video mode hint (1278x834x0) at 0

Those hints are showing up as I try to increase the window size.

BTW, I am using the same xorg.conf as seiryu (he sent it to me).

comment:11 Changed 5 years ago by jystickman

Another note - resizing seems to work intermittently - if I am logged in as root. It does not work when I'm logged in as myself. Or at least this seems to be the case as best as I can tell. I think I'm going to have to go back to 2.2.0 unless I get an idea on how to resolve this....

And I'm stuck on Solaris 10 Update 6. I can't move to OpenSolaris if that resolves the issue...

comment:12 Changed 5 years ago by jystickman

I think I figured it out. When I log in as root, VBoxClient --{seamless,autoresize,clipboard} start and run.

As myself, VBoxClient refuses to run, even if I try to start them by hand.

This sounds similar to ticket 1699. But I see no core files. Any opinions on whether I should transfer my issue to 1699?

comment:13 Changed 5 years ago by michael

  • Version changed from VirtualBox 2.2.0 to VirtualBox 2.2.2

jystickman: since the issue in #1699 was resolved, we can continue on this ticket for simplicity. Just to reconfirm the usual things: have you updated your Guest Additions to the latest version? If so, does reinstalling the 2.2.0 Guest Additions make a difference? (You won't have to downgrade your VirtualBox installation to 2.2.0 for this of course, the 2.2.0 Additions should work fine with VirtualBox 2.2.2.) I assume you have checked that the VBoxClient processes are no longer running when you have the problems. When you try to start them manually, do you get any particular error messages? Can you try deleting the files .vboxclient-*.pid? And does it make a difference if you start the autoresize service with "VBoxClient --autoresize --nodaemon"?

Thanks.

comment:14 Changed 5 years ago by jystickman

Michael:

Yes, I updated Guest Additions to version 2.2.2. Behavior is: works as root, does not work as regular user.

I reverted to Guest Additions 2.2.0. Behavior is: works as root, does not work as regular user.

Conclusion - Guest Additions version makes no difference.

Verified processes weren't running. No .vboxclient-*.pid files laying around.

Starting things with --nodaemon showed part of what's going on. I was attempting to manually start VBoxClient but thought I had to do it as the root user. When I did that, I got authorization errors from the X server - which make sense once I realized VBoxClient actually appears to be an X client. xhost + (highly undesirable) or starting VBoxClient processes as myself allowed the daemons to start and stay running. I chose to start the daemons as myself.

Going back to the Guest Additions 2.2.2 and checking for (and then starting) the 3 VBoxClient daemons by hand after logging in results in correct resizing behavior (well, except that GNOME bails when you shrink the window, but that's not VBox'es fault I don't think?).

So the question for me now seems to be, why aren't the 3 VBoxClient daemons starting automatically for me anymore when I log in as myself?

As a further test point, I did create a whole new user to log in as, and this new user also does not get is VBoxClient daemons started up automatically.

comment:15 Changed 5 years ago by ramshankar

Could you please show ls -l VBoxClient in the case where you say it does not work?

comment:16 Changed 5 years ago by jystickman

kindaspam(14)% pwd /opt/VirtualBoxAdditions kindaspam(15)% ls -l VBoxClient -rwxr-xr-x 1 root other 976644 2009-05-29 13:02 VBoxClient* kindaspam(16)%

I can start the processes manually as me (regular user uid) by typing /opt/VirtualBoxAdditions/VBoxClient --autoresize (and so on for clipboard and seamless).

It's not a permissions problem on the executable.

comment:17 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if still relevant with VBox 4.0.4.

comment:18 Changed 3 years ago by smarotta

  • Status changed from closed to reopened
  • Resolution fixed deleted

When running VirtualBox on a Win7 64-bit host and Ubuntu 10.10, Auto-resize Guest Display no longer works as it did in version 3.2.10. The display will blink as though it was acknowledging the change in window size, but it will not automatically resize the display. If I go to System->Preferences->Monitors, I can see the custom window size that corresponds to the size of my resized Vbox window, and if I select it, I get a display that matches my resized window. So part of it works, but it's not actually setting the display to my custom size.

If, however, I go to full-screen mode, it will automatically resize. It might have something to do with resizing to a known, tried & true resolution like 1280x1024 rather than 1186x917 or whatever size my Vbox window is right now.

comment:19 Changed 3 months ago by frank

  • Status changed from reopened to closed
  • Resolution set to obsolete
  • Description modified (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use