VirtualBox

Ticket #1699 (closed defect: fixed)

Opened 6 years ago

Last modified 4 years ago

VBoxClient does not start automatically on some Linux guests -> fixed in SVN

Reported by: ademar Owned by:
Priority: major Component: guest additions
Version: VirtualBox 2.1.4 Keywords:
Cc: Guest type: Linux
Host type: other

Description

I've upgraded virtualbox from 1.6.0 to 1.6.2 (including guest-additions) and now I'm stuck at 1024x768 on my linux guest (on a 1920x1200 monitor!). I have "Auto resize guest display" turned on and on 1.6.0 it worked fine: I could used xrandr or start the X server with the correct resolution.

I'm using OS-X 10.4 on a Macbook pro. My guest is a Mandriva Linux 2008.1. Virtualbox 1.6.2 (including guest additions), installed from virtualbox.org.

I followed the procedures from tickets #1689 and #1691 (apparently related to this bug), but they didn't solve my problem.

I also tried to debug the problem with someone from IRC (who reviewed all the guest-additions installation, my vm configuration and the VBoxManage commands), without success. :-(

Again, it was working without any problem with 1.6.0 (I use the guest daily, it's my desktop and development platform).

Change History

comment:1 Changed 6 years ago by ademar

In the meantime, does anybody know where I can download virtualbox 1.6.0 for OS-X? It would be nice to be able to work until this is sorted out. :-)

(on the sun site only 1.6.2 is available)

comment:2 Changed 6 years ago by ademar

michael-vb (@IRC) nailed the issue: VBoxClient is not being started for some reason (was it being started in 1.6.0 or was it working here for some other reason? I don't know).

So, starting VBoxClient by hand solves the problem (it now works like a charm). :-)

I'll keep this ticket open as the fix requires manual intervention and probably affect other users as well. The bug can now be described as "VBoxClient is not started by default on my linux guest".

comment:3 Changed 6 years ago by michael

  • Summary changed from limited screen resolution on os-x host (1.6.2 regression) to VBoxClient does not start automatically on a Mandriva 2008.1 guest (1.6.2 regression)

comment:4 Changed 6 years ago by ademar

The correct way to start VBoxClient on Mandriva Linux (and probably other linux distros as well), so that it's called no matter what window manager is used, is by adding a script in /etc/X11/xinit.d/ with a VBoxClient call.

comment:5 Changed 6 years ago by frank

  • Guest type changed from other to Linux

comment:6 Changed 6 years ago by ademar

BTW, just tested with Ubuntu Linux 8.04 (latest) and it has the exact same problem (VBoxClient is not started).

Could someone please update the bug title?

comment:7 Changed 6 years ago by frank

  • Component changed from other to guest additions
  • Summary changed from VBoxClient does not start automatically on a Mandriva 2008.1 guest (1.6.2 regression) to VBoxClient does not start automatically on some Linux guests (1.6.2 regression)

comment:8 Changed 6 years ago by michael

Sorry for the delay in answering. It looks like the problem, at least on Mandriva 2008.1, is that they install the VirtualBox guest additions (in an older version) by default, but their installation interferes with ours. Specifically, the /dev/vboxadd device is owned by user vbox by default, and we assume that it is owned by user vboxadd.

comment:9 Changed 6 years ago by ademar

I don't have guest-additions from Mandriva installed. I'm quite sure that even if it was indeed installed (by default), I removed it before proceeding, as I reviewed the guest-additions installation steps several times to make sure it was not a stupid error from my side. Permissions on /dev/vboxadd are OK.

On Ubuntu 8.04 (see previous comment), there's no virtualbox package installed either.

I think the problem is that VBoxClient is not being started because it's in the wrong place (it should be called by the xinit/xdm scripts but it's not). In both distributions, if I start VBoxClient by hand, things work as expected.

comment:10 Changed 6 years ago by frank

Does this problem still persist? Starting with 1.6.6, there shouldn't be a startup issue for Mandriva anymore. And we were never able to reproduce problems with Ubuntu.

comment:11 Changed 5 years ago by ademar

Unfortuantely I don't use Mandriva Linux anymore and I don't have enough time to download and setup a test environment... :-(

Anyway, as this bug was listed in the release-notes (changelog) a couple of months ago and nobody complained since then, I guess it's safe to close it as fixed.

Thanks.

comment:12 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

comment:13 Changed 5 years ago by samwise

  • Status changed from closed to reopened
  • Resolution fixed deleted

VirtualBox: 2.1.4
Host: Windows XP Pro SP2 (32-bit)
Guest: Debian Squeeze AMD64 (incl. DKMS 2.0.20.4 and VirtualBox 2.1.4 Guest Additions)

I've just experienced, as described in  this topic in the Linux Guests forum, this same issue with the latest version of VirtualBox, I think (from reading  snake's post in the Resolutions higher than 1200x768 aren't possible Deb SID topic in the Linux Guests forum) this was because I was booting into KDE as the default window manager.

I had to overcome it by adding an entry to run VBoxClient in ~/.kde/Autostart.

This appears to be a recurrence of the issue described in this ticket, so I thought it best to re-open it. I published logs, including vboxadd-install.log in the topic linked above, but I can re-post them here, if required.

Thanks,

Sam.

comment:14 Changed 5 years ago by michael

  • Version changed from VirtualBox 1.6.2 to VirtualBox 2.1.4
  • Summary changed from VBoxClient does not start automatically on some Linux guests (1.6.2 regression) to VBoxClient does not start automatically on some Linux guests -> fixed in SVN

We fixed an issue with the autostart of VBoxClient on guests running KDE just before releasing 2.2 beta 2, so if you are interested in testing this and have a non-production machine available for the purpose you could give that a try.

comment:15 Changed 5 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

Reopen if the problem persists with release 2.2.2.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use