VirtualBox

Ticket #3624 (closed defect: fixed)

Opened 5 years ago

Last modified 3 years ago

host interface networking unstable in 2.1.4

Reported by: nbi Owned by:
Priority: critical Component: network/hostif
Version: VirtualBox 2.1.4 Keywords:
Cc: nbi@… Guest type: Windows
Host type: Linux

Description

Host interface networking works upon startup (I can see promiscuous mode in /var/log/messages) of the VM, but eventually all connections are lost. It isn't even possible to ping the gateway. By contrast NAT seems to work ok. Unfortunately this poses a critical problem since VPN is only supported in Host mode. IPV4 is used so it can't be anything related to IPV6 as mentioned in the manual.

Platform is Debian Lenny 64 bit, kernel 2.6.28.

Change History

comment:1 Changed 5 years ago by frank

Please add the type of your host network card. And which network card emulation did you select for the guest (PCnet or E1000)?

comment:2 Changed 5 years ago by nbi

My physical card is a Linksys WMP54G wireless (RT2500 chipset). It has kernel support in the 2.6.28 kernel.

I tried all the emulations. The Intel Pro 1000 doesn't seem to work in any of the interface modes, I even tried updating to the latest Intel drivers as suggested in another bug report.

The Fast PCnet seems to work flawlessly in NAT, but is unstable in HostIf.

comment:3 follow-up: ↓ 4 Changed 5 years ago by jamespgray

I am having the same issue.

guest (virtual) NIC: PCnet-FAST III (Am79C973)

host (physical) NIC: 82566DC-2 Gigabit Network Connection (made by Intel)

VirtualBox version: 2.1.4 (non-OSE)

Host OS: Ubuntu 8.10 (intrepid)

Guest OS: Windows XP SP 3

I am also using VPN. I've tried both Microsoft and Cisco clients the problem happens with both of them.

comment:4 in reply to: ↑ 3 Changed 5 years ago by jamespgray

Replying to jamespgray:

64 bit kernel version 2.6.27.

comment:5 Changed 5 years ago by Licho

Same issue, all adapters in all modes. Sometimes it works for days before connection is lost.

comment:6 Changed 5 years ago by nbi

Unstable in NAT as well. Just at a lesser frequency and longer after a reboot.

comment:7 follow-up: ↓ 8 Changed 5 years ago by nbi

NAT seems to have been fixed with version 2.2.0. Bridged mode looks ok too, but I only checked the outbound direction.

comment:8 in reply to: ↑ 7 Changed 5 years ago by nbi

2.2.0 bridged works except for one critical thing: can't reach the Internet using the instructions given here at the vbox site. In my previous comments by "outbound" I meant to the host, but obviously a useful configuration includes Internet access too.

Replying to nbi:

NAT seems to have been fixed with version 2.2.0. Bridged mode looks ok too, but I only checked the outbound direction.

comment:9 Changed 5 years ago by kwhat

This is not fixed in 2.2.0 for Bridged mode and is still an issue for me using openvpn on a tap interface. Vbox keeps switching to promiscuous mode and eventually hangs the guest systems.

This is my client config for open vpn. Openvpn client is running on the host.

remote domain.tld
port 1194
dev tap
secret static.key
proto udp
comp-lzo
ifconfig 192.168.128.50 255.255.255.0
route 192.168.128.0 255.255.255.0 192.168.128.1

Please fix.

comment:10 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

The last releases contain some hostif-related fixes. Please reopen if this problem is still current with VBox 3.0.8.

comment:11 Changed 4 years ago by Licho

  • Status changed from closed to reopened
  • Resolution fixed deleted

Its still an issue, but there is solution now, virtio-net appears to be stable.

comment:12 Changed 4 years ago by Technologov

It seems to be WiFi related.

Please change topic: "host interface networking unstable in 2.1.4" --> "WiFi bridge networking unstable"

-Technologov

comment:13 Changed 4 years ago by Licho

No its NOT WIFI RELATED.

Wifi problems are separate issue.

This problem affects both host-only and bridge networking for very long time. It causes virtual network adapter to fail under very heavy load and you lose connection to host.

comment:14 Changed 3 years ago by aleksey

Does the problem still occur in 4.0? If it does could you please provide the following information (it should be collected when the connectivity to the host has been lost):

  • vbox log
  • tcpdump output in guest while pinging the host
  • tcpdump output on host while guest pings the host

Thanks in advance.

comment:15 Changed 3 years ago by jamespgray

I can no longer reproduce this issue. Previously this was an issue with both the OSE and proprietary versions.

(From the host OS)

$ dpkg -s VirtualBox-OSE | grep Version Version: 3.1.6-dfsg-2ubuntu2 $ uname -a Linux sage 2.6.32-27-generic #49-Ubuntu SMP Thu Dec 2 00:51:09 UTC 2010 x86_64 GNU/Linux

comment:16 Changed 3 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

Thanks for the feedback!

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use