VirtualBox

Ticket #49 (closed defect: fixed)

Opened 7 years ago

Last modified 4 years ago

Failed to create virtual COM object - Dapper Drake

Reported by: bducharme Owned by:
Priority: critical Component: other
Version: VirtualBox 1.3.4 Keywords: COM Failed
Cc: Guest type: other
Host type: other

Description

After installing VirtualBox 1.3.4 on Ubuntu Dapper Drake (6.06 LTS) I get the following error upon trying to launch it:

VirtualBox - Critical Error

Failed to create virtual COM object

The Application will now terminate.

Callee RC 0x80004004

Attachments

VBoxSVC.log Download (166.0 KB) - added by gbuonfiglio 7 years ago.
VBoxSVC.log with strace when mp3 player connected
VirtualBox.zip Download (102.4 KB) - added by gbuonfiglio 7 years ago.
VirtualBox.log with strace when mp3 player connected. It failed to start.

Change History

comment:1 Changed 7 years ago by Cpt.Schmock

The solution is simple - you just have to delete the directory ".VirtualBox" in your home directory.

comment:2 Changed 7 years ago by michael

Please be careful doing this, since the ~/.VirtualBox directory contains all your virtual machines and associated information.

comment:3 Changed 7 years ago by tigerfoot

Sorry but this happen on the first launch ...

Any other ideas ??

System is OpenSuse 10.1

comment:4 Changed 7 years ago by michael

Did you add your user to the "vboxusers" group on the host? Do restart your host after you do, because Linux is a bit funny with adding users to groups (it doesn't take effect straight away).

comment:5 Changed 7 years ago by gbuonfiglio

I think I found the correct way to reproduce this problem. I'm using VirtualBox for a month and today when opening VirtualBox it fails with "Callee RC: 0x80004004". I did a "ps -ef | grep VBox" but no daemon was started. Then I called VBoxManage and the VBoxSVC and VBoxXPCOMIPCD where started. Calling VirtualBox again gives the same error and the daemons are gone. Then I realize that today my usual sequence to start things were different. Because my mp3 player battery died, I plugged it in my computer and mounted it before calling VirtualBox. Then I unplugged my mp3 player and VirtualBox worked fine! My system here is an Ubuntu 6.10 and VirtualBox is 1.3.6.

comment:6 Changed 7 years ago by gbuonfiglio

One more comment: I'm not able to reproduce it with a new usb drive, but I can reproduce it with the mp3 player. This is weird because the mp3 player (sansa e260) looks like a normal usb drive to Linux. The only visible difference is that my mp3 player volume name has a space. It's "Sansa e260".

comment:7 follow-up: ↓ 8 Changed 7 years ago by frank

That sounds interesting. However, you could help us a little bit more by doing the following: Make sure that no VBox daemon is started. Then start VBox with

  cd /opt/VirtualBox-1.3.6
  LD_LIBRARY_PATH=. strace -f -F -s1024 -o /tmp/VBoxSVC.log ./VBoxSVC &
  LD_LIBRARY_PATH=. strace -f -F -s1024 -o /tmp/VirtualBox.log ./VirtualBox

and post both log files here. Thanks in advance.

comment:8 in reply to: ↑ 7 Changed 7 years ago by frank

I mean with your mp3 player plugged of course.

comment:9 Changed 7 years ago by tigerfoot

Here's what happen (I've a long discussion on irc channel and I can run the OSE version direct in it's building directory .. ) My Env is openSUSE 10.1, I've no ~/.VirtualBox at the start.

So I try what you propose here you can find the two logs.

As they're a bit big you could found them at  http://ftp.ioda.net/ioda-net/VBoxSVC.log and  http://ftp.ioda.net/ioda-net/VirtualBox.log

Happy debug.

comment:10 Changed 7 years ago by frank

May I ask you to post the content of your /proc/bus/usb/devices when your mp3 stick is plugged? Thanks again.

Changed 7 years ago by gbuonfiglio

VBoxSVC.log with strace when mp3 player connected

comment:11 Changed 7 years ago by frank

BTW: Did you use the OSE version for generating the trace?

Changed 7 years ago by gbuonfiglio

VirtualBox.log with strace when mp3 player connected. It failed to start.

comment:12 Changed 7 years ago by gbuonfiglio

I used the Debian Package (binary, not OSE).

comment:13 Changed 7 years ago by gbuonfiglio

Sorry, Ubuntu 6.10 Package... :-)

comment:14 Changed 7 years ago by frank

Ok. Please don't forget to post your /proc/bus/usb/devices with your mp3 player plugged.

comment:15 Changed 7 years ago by tigerfoot

Trace have been made with the Virtualbox 1.3.6 .run installer.

OSE is the version which work under my openSUSE 10.1

comment:16 Changed 7 years ago by frank

Actually by inspecting your log files I found the bug in our code. I've fixed it in SVN -- it will be contained in the next release.

comment:17 Changed 7 years ago by umoeller

  • Status changed from new to closed
  • Resolution set to fixed

comment:18 Changed 7 years ago by lolow

I have the same error/diagnostic/usb problem with gentoo and virtualbox-bin 1.3.8. In which release version, the fixed source will appear? version 1.4? I have a laptop and virtualbox needs my usb mouse to be deconnected to run...

comment:19 Changed 7 years ago by frank

Exactly.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use