VirtualBox

Ticket #3565 (closed defect: invalid)

Opened 5 years ago

Last modified 5 years ago

logical network interface not working

Reported by: sfehrman Owned by:
Priority: critical Component: network/hostif
Version: VirtualBox 2.1.4 Keywords: logical network
Cc: Guest type: Solaris
Host type: Solaris

Description

Solaris logical interface was working with 2.0.6, fails with 2.1.4.

The Host OS (OpenSolaris 2008.11) has a logical interface cnfigured:

ifconfig nge0:1 plumb ifconfig nge0:1 192.168.100.100 netmask 255.255.255.0 up

The guest OS (OpenSolaris 2008.11) is configured to use Host Interface with a static IP address (192.168.100.101).

Everything worked great with 2.0.6. The host OS could access the quest OS. After upgrading, the host OS can not "see" the guest OS, no ping or anything.

Uninstalled 2.1.4 and re-installed 2.0.6 ... everything worked fine ???

Attachments

2.0.6_VBox.log Download (41.9 KB) - added by sfehrman 5 years ago.
VBox.log from 2.0.6
2.0.6_ifconfig-a.txt Download (503 bytes) - added by sfehrman 5 years ago.
ifconfig -a output
2.1.4_VBox.log Download (47.4 KB) - added by sfehrman 5 years ago.
VBox.log from 2.1.4
2.1.4_ifconfig-a.txt Download (503 bytes) - added by sfehrman 5 years ago.
ifconfig -a output (2.1.4)

Change History

comment:1 Changed 5 years ago by ramshankar

Could you please upload the log file of the VM here. Also the output of ifconfig -a from the host.

A 'logical' interface will not work because logical interfaces are plumbed under IP (not layer 2 MAC) and are IP constructs, VirtualBox internally would resolve to use the real interface anyway unless you're forcing something explicitly. More information is required.

Changed 5 years ago by sfehrman

VBox.log from 2.0.6

Changed 5 years ago by sfehrman

ifconfig -a output

Changed 5 years ago by sfehrman

VBox.log from 2.1.4

Changed 5 years ago by sfehrman

ifconfig -a output (2.1.4)

comment:2 Changed 5 years ago by sfehrman

I've attached the files you ask for.

With regard to the "will not work" ... I did get it to work on 2.1.4 like I have it working with 2.0.6 (i might have had a typo when i first tried it).

I'm concerned that you say this "will not work". My team is actively using this feature. It's important to allow the Host OS to communicate to the "Internet" (via DHCP) and still access the vbox image (which has a static IP). We treat the image as a "server", boot it and access it remotely from the Host OS native tools (browser, ssh, scp). We have successfully used "logical networks" on MacOS X 10.5 and OpenSolaris 2008.11.

There's no virtualbox documentation for how to do "use" a logical network. We had to manually edit the Machine XML file. The "logical networks" do not show-up in the Settings->Network panel. Here is what we do ...

  • Select the physical network (nge0).
  • Stop VirtualBox
  • Manually edit the XML config file:

OLD: <HostInterface name="nge0 - Nvidia Gigabit Ethernet"/>

NEW: <HostInterface name="nge0:1 - Nvidia Gigabit Ethernet"/>

  • Restart VirtualBox
  • The Logical network (nge0:0) is selected in the Settings->Network panel (it is italic text)
  • Boot the image
  • Access it via logical IP address

We have tried to use "logical networks" on Linux (ubuntu) and the VirtualBox image fails to boot. In this case, we had had to create a "bridge" interface (not ideal).

Can this be supported?

comment:3 Changed 5 years ago by ramshankar

Specifying nge0:1 or nge0 shouldn't make a difference. If you would notice from the log files VirtualBox still would use nge0 regardless of the 'logical' interface. This is from a purely technical point of view, logical interfaces are simply IP constructs. We wouldn't be able to get any layer 2 packets on them, it's purely a host-side abstraction, VirtualBox injects itself below this. You can *use* logical interfaces by passing them to VirtualBox, but remember technically the netfilter driver wouldn't be on the logical interface - though it gives the end result you want.

Also don't edit the VirtualBox XML manually. It is NOT recommended you do this. Instead use VBoxManage to muck around with such stuff e.g something like VBoxManage modifyvm <vmname> -hostifdev1/bridgedadapter "nge0:1" etc. But note this is kind of moot anyway because VirtualBox resolves it internally to use the correct one :)

comment:4 Changed 5 years ago by ramshankar

  • Status changed from new to closed
  • Resolution set to invalid
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use