VirtualBox

Ticket #3518 (closed defect: worksforme)

Opened 5 years ago

Last modified 5 years ago

Host interface connection does not work

Reported by: MrRagga Owned by:
Priority: major Component: network/hostif
Version: VirtualBox 2.1.4 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description (last modified by frank) (diff)

Hi, I use VBox on Mandriva 2009. If i try to use a "host interface" connection using eth0 on the host system, it does not reponse to ping or anything else. I've tried it with all 4 nic drivers available in the guest. Setup:

host: ifconfig eth0 192.168.23.100/24
guest ifconfig eth1/2/3/4 192.168.23.1/24 (I've tried all 4 nics in the guest. And yes, I changed the old ethX to another subnet before assgning the 23 net to the new nic.).

Host information:

# rpm -qa|grep -i virtual
virtualbox-kernel-2.6.24.5-laptop-2mnb-1.5.6-1mdv2008.1
virtualbox-kernel-desktop-latest-2.0.2-1.20090218.2.1mdv2009.0
virtualbox-kernel-2.6.24.7-laptop-1mnb-1.5.6-1mdv2008.1
virtualbox-guest-additions-2.1.4-1mdv2009.0
virtualbox-kernel-2.6.27.14-desktop-1mnb-2.0.2-2.1mdv2009.0
virtualbox-kernel-laptop-latest-1.5.6-1.20080729.1mdv2008.1
virtualbox-2.1.4-1mdv2009.0
dkms-virtualbox-2.1.4-1mdv2009.0

# uname -a
Linux localhost.localdomain 2.6.27.19-desktop586-0.uc1mnb #1 SMP
   Tue Mar 3 17:21:48 EST 2009 i686 Intel(R) Core(TM)2 Duo CPU
   T8300  @ 2.40GHz GNU/Linux

eth0      Link encap:Ethernet  HWaddr 00:1C:25:7C:D8:44
          inet addr:192.168.23.100  Bcast:192.168.23.255  Mask:255.255.255.0
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Memory:fe200000-fe220000

00:19.0 Ethernet controller: Intel Corporation 82566MM Gigabit Network Connection (rev 03)

Guest is Fedora 8 based on kernel kernel-2.6.24.7-92.fc8.i686.rpm

Attachments

VBox.log Download (30.9 KB) - added by MrRagga 5 years ago.

Change History

Changed 5 years ago by MrRagga

comment:1 Changed 5 years ago by frank

  • Description modified (diff)

comment:2 Changed 5 years ago by MrRagga

Today I figured out, that my OS has a bridged interface called pan0: # brctl show bridge name bridge id STP enabled interfaces pan0 8000.000000000000 no

The interesting thing is, that this interface works as a hostif.

Cheers Jonas

comment:3 Changed 5 years ago by frank

So it works if you connect to that pan0 bridge but it does not if you connect to eth0?

comment:4 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to worksforme

No response, closing.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use