VirtualBox

Ticket #3509 (closed defect: duplicate)

Opened 5 years ago

Last modified 4 years ago

Blackberry USB connection to Desktopmanager not working properly

Reported by: mklingspor Owned by:
Priority: major Component: USB
Version: VirtualBox 2.1.4 Keywords: Blackberry
Cc: Guest type: Windows
Host type: Mac OS X

Description

Running XP or Windows 7 in the guest, the Blackberry gets connected via USB, USB-Storage is working, the Desktopmanager connects the Blackberry. When try to add Software however, the Desktopmanager hangs with an empty progress bar stating "connecting JVM".

The log says: 00:00:01.467 Driver <string> = "VUSBRootHub" (cch=12) 00:00:01.468 Driver <string> = "VUSBRootHub" (cch=12) 00:00:03.710 VUSB: attached '001bfe60[proxy 0fca:8004]' to port 1 00:00:46.604 OHCI: USB Reset 00:00:46.660 OHCI: USB Operational 00:00:47.100 EHCI: USB Operational 00:00:54.656 OHCI: USB Suspended 00:01:53.296 OHCI: USB Operational 00:01:57.884 OHCI: USB Suspended

Change History

comment:1 Changed 5 years ago by ian@…

I am using VBox 3.0 on Jaunty 9.04 with a WinXP SP3 guest running Desktop Manager 4.7 and have a blackberry curve 8800 (0fca:0004). Prior to v3.0, I had not request for PIN even though windows detected the composite device. Now with 3.0, I get a PIN prompt, and the blackberry device manager tells me I am connected. For the brief moment when I connect, my Berry also flips to "connected to Desktop". At that point, Desktop Manager appears to freeze. If I open up Berry device manager at the same time, I see "Connected" still. If I unplug my Berry, and plug it back in everything comes back to life briefly after I enter my PIN. If I do not do any syncing, it seems to go "back to sleep" and freeze up the desktop within about 10 seconds. So, in order to configure syncronization I have to unplug it, and plug it in and resume the process. Then to get it to start syncing I have to also unplug it and plug it in again and immediately start the process. This starts the process of reading my contacts off the berry (some 1200+) but then results in this "timeout" when it completes that transfer (minutes later).

I see similar messages (re:above) in my logs, however the "Suspended" only after I unplug, and "Operational" only after I replug, so no evidence of sleeping.. I am wondering if there is something on the linux backend related to usb device sleeping that might influence.

comment:2 Changed 5 years ago by ian@…

Same strange timeout issues with my 8300 (not 8800 as incorrectly noted above) with Vista 64 Pro guest on Ubuntu 9.10 (2.6.31). Unpluging/re-plugging unfreezes the Blackberry desktop.. it seems the timeout does not impact the mass storage part of the connection which seems strange.

comment:3 Changed 5 years ago by ninboy

I have the same issue, using Ubuntu 9.04 and VirtualBox 3.0.6

comment:4 Changed 4 years ago by karolszk

On Ubuntu 8.04 LTS (and Guest Windows XP), 2.2.4 not recognizing Black Berry 8520, on 3.0.2 recognizing but freeze during running Black Berry Desktop Manager. On 3.0.12 back as in 2.2.4 Black Berry again is not recognized.

What is the current status of this ticket? Maybe somebody has some successfull tries in 3.1.x?!

comment:5 Changed 4 years ago by karolszk

On 3.1.0 sometimes BB 8520 is surprisingly recognized sometimes not. But nothing more than recognizing device and practically is impossible to do more via Black Berry Desktop Manager. Windows XP Guest is freezing. Unfreezing only when USB cable will be removed. Generaly still it doesn't work.

comment:6 Changed 4 years ago by moeis

using vbox 3.1.2 build r56127 on an opensuse-11.2-host with an win7-x32-home-premium-guest to sync a bb 8310 curve with bb os 4.5 and deskttop manager 5.01 multilanguage.

Error description as mentioned above: connection basically works (phone is recognized) but no syncing or updating action possible. would like to have a debug-build of vbox to investigate the usb-issues further and provide logs. BB Desktop Manager proceeds when disconnecting the bb, which basically aborts the update/syncing-process and is of no use for my actual problem. disconnecting the cable immediately aborts active vbox-session (crash!). there is traffic shown on the usb-device but nothing happens, i take this from the occasional flashing of the red dot next to the usb-icon in the bottom-bar of vbox but even after 7 hours of consecutive running and "letting it do what it wants" nothing changes in behaviour or progress. my guess: the bb changes some internal port or something during the process which is not passed over to vbox by the host, but only a guest.

same impossible syncing behaviour with a LG ku990 viewty phone and the lg desktop manager.

best regards moritz

comment:7 Changed 4 years ago by jib9119

I am using Ubuntu 10.04 with version 3.2.8. My virtual-box detects and connects to my device, desktop manager can see the device but will not finish connecting. Anyone with advice on how to troubleshoot this issue please post a reply to my post.

comment:8 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Let's close this as a duplicate of #6465 though this ticket is older. Hopefully fixed in VBox 3.2.10.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use