Ticket #6465 (reopened defect)

Opened 11 years ago

Last modified 4 years ago

Blackberry synchronization appears broken => Fixed in SVN

Reported by: GeorgeRYoung Owned by:
Component: USB Version: VirtualBox 3.1.4
Keywords: blackberry usb Cc:
Guest type: Windows Host type: Linux


Host Debian Lenny 64 bit, client Windows XP SP3.

Blackberry synchronization works fine in VB 3.0.2. Since then, I've tried VB versions 3.0.4, 3.0.6, 3.0.8, 3.1.2 and 3.1.4 and the Blackberry USB support fails in various ways, some quite comical, so I revert back to VB 3.0.2.

Change History

comment:1 Changed 10 years ago by frank

  • Summary changed from Blackberry synchronization appears broken to Blackberry synchronization appears broken => Fixed in SVN

Hopefully fixed in VBox 3.2.10.

comment:2 Changed 10 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

comment:3 Changed 10 years ago by spstarr

  • Status changed from closed to reopened
  • Resolution fixed deleted

This is not fixed. It hangs the desktop app if I detach and reattach it finds device, but goes no further after. This is with 3.2.10 r66523

Host: Fedora (14/15) Guest: Windows Vista

comment:4 Changed 10 years ago by rembspam@…

This is indeed NOT FIXED. The BlackBerry device connects and reconnects quite often. This seems to be NORMAL under Windows XP (NATIVE WITHOUT VBOX) as well. I guess that this connect/reconnect thing, is fooling USB in VirtualBOX. Whatever filter and/or setting on USB I apply in VBOX, it does not appear or appears for just a few seconds and then vanish.

Host: Fedora 12/x586, VBOX 3.2.10r66523 with Windows XP SP3 (previous versions I tried from VBOX 3.1 up to the 3.2.10 versions do not work either).

comment:5 Changed 10 years ago by fmarzocca

I can confirm this also on ubuntu 10.10 host and Windows 7 guest. Device disconnects too often.

comment:6 Changed 10 years ago by fmarzocca

It fails on VirtualBox v 4.0.0 too. The BB disconnects very often, not able to operate with Desktop Manager. Any temporary workaround available?

comment:7 Changed 10 years ago by StasisOS

I confirm this on VirtualBox v 4.0.2 as not working using Windows 7 guest and Ubuntu 10.10 as host. I can enable mass media mode where my BB is treated as a thumbdrive, however I cannot synchronize it with BB Desktop Software v6.0.1 B21.

comment:8 Changed 10 years ago by tokanizar

Confirm that VirtualBox v4.0.4 still not working with both Windows 7/Windows XP guest + BDM v4.6, 5.0.1 and 6.0 and Mac OS X 10.6.6 host. Really want this bug to be fixed ASAP.

comment:9 Changed 10 years ago by shongololo

Had the similar issues with VirtualBox 4.0.4 r70112 installed on Ubuntu 10.10 with a Windows XP SP2 guest and Blackberry Desktop software v

The workaround mentioned here worked for me :

long and short : Shutdown VM -> Settings -> USB -> Uncheck "Enable USB 2.0 (EHCI) Controller".

Both the 8900 and the 9800 synchronize/backup successfully with no issues.

comment:10 Changed 10 years ago by tokanizar

Doesn't work with VirtualBox 4.0.4 in MacOS X 10.6.6 host. The BlacBerry didn't even be recognised by Blackberry Desktop Software in Windows XP guest although Windows said that driver for the device "has been successfully installed". Really disappointed!

comment:11 Changed 9 years ago by supremedalek

Workaround mentioned by shongololo worked with VirtualBox 4.0.6 r71344 installed on Ubuntu 10.10 with a Windows XP SP2 guest and Blackberry Desktop software v

Had no problems synchronizing my Storm2. Will see if upgrading the software on phone also works.

comment:12 Changed 9 years ago by saporati

I tried with Virtualbox version 4.0.1 and 4.0.2 on Ubuntu 10.04 with Desktop manager 6.1 on a W7 virtual machine: my Bold 9700 was correctly recognized and all needed drivers installed but the desktop manager stuck on "connecting". Then i upgraded my VB setup to the latest version 4.1.0 but I'm still waiting for my Blackberry to be connected...

comment:13 Changed 9 years ago by rdeleonp

Still happening on VirtualBox 4.1.8 (Ubuntu 10.04 32-bit)...

Last edited 9 years ago by rdeleonp (previous) (diff)

comment:14 Changed 6 years ago by fermulator

Just tried this with:

  • Ubuntu 14.04 HOST
  • virtualbox 4.3.10
  • Windows 7 64-bit guest
  • Blackberry Classic BB10 device (NEW 2015)

Doesn't work. The device is detected in vbox USB list as "Research in Motion Ltd. Blackberry [0240]"

Windows detects the device as 'USB Composite Device" in Device Manager.

Opening the BB Desktop Software is stuck with "Connect your BlackBerry device", as though it's not connected. :(

Shifting the BB device on/off DOES push the device back and forth to Windows as expected (simulating connect/disconnect)

But ... again the BB software isn't detecting the device.

comment:15 Changed 4 years ago by fermulator

Tested with a newer version of VirtualBox (5.0.20 r106931), same host/guest settings as other posted in #comment:14 -> same issue

comment:16 Changed 4 years ago by fermulator

Just tested again with updated VirtualBox (5.0.22 r108108) with Windows 7 Enterprise. At /first/ the same issues were persistent. :( Wasn't going to bother posting an update here.

But, changed one setting in the VirtualBox guest USB section. Apparently it was configured for USB 1.1 ;/ -- shutdown guest, upgrade that to USB 2.0, boot guest, and tada it worked!

Note: See TracTickets for help on using tickets.
ContactPrivacy policyTerms of Use