VirtualBox

Ticket #3388 (closed defect: duplicate)

Opened 5 years ago

Last modified 5 years ago

High CPU load after stand by

Reported by: yen27028 Owned by:
Priority: major Component: VM control
Version: VirtualBox 2.1.4 Keywords:
Cc: Guest type: Windows
Host type: Windows

Description

The process VBoxSVC.exe starts to use 50% of the CPU, according to task manager, immediately after putting my physical PC (host) into stand by (sleep) mode for a while and then, waking it up. Eventually the CPU usage returns to normal, but the length of time it stays high seems to be related to how long the PC was asleep. If it is in stand by mode over night, it takes 5-10 minutes to return to normal. If it is only asleep for a minute or two (like while try to debug this problem) the CPU usage is only high for a few seconds, but it is always high for some time period.

This started to happen after I upgraded to 2.0.0 and continued with 2.0.2 and so on through the current version (2.1.4). (I think the last version I used before 2.0.0 was 1.5.6.) I upgraded the guest additions as well.

I can temporarily resolve the problem by saving the session, exiting the VirtualBox GUI, re-running the GUI, and reloading my virtual machine. At that point, everything is OK until I put the host into stand by mode again.

The host OS is XP Pro and the guest OSs are Win2k and Xubuntu. The problem is seen with both individually, when both are running, and when NEITHER is running. Therefore, the problem is probably with the console.

Other users have reported the same problem in replies to my initial post in the forum.

Attachments

Alpha (Win2kSP4)-2009-02-18-21-13-54.log Download (40.4 KB) - added by yen27028 5 years ago.
log file

Change History

Changed 5 years ago by yen27028

log file

comment:1 Changed 5 years ago by bzaujec

the same problem I have on my notebook, no guests are running

comment:2 Changed 5 years ago by pullunder

Same problem on my single core cpu. VBoxSVC takes 99 % CPU after return from standby. First observed after update from 1.5.6. to 2.1.2, still there with 2.1.4.

stack (displayed using Process Explorer):
ntkrnlpa.exeKiDispatchInterrupt+0x7f
!RTTimeDbgRaces+0x10
!RTTimeNanoTS+0x11
!RTThreadReadLockDec+0x1f0
!RTSemMutexRelease+0x112
!endthreadex+0xa0
!GetModuleFileNameA+0x1b4

comment:3 Changed 5 years ago by kobian

This is a duplicate of #2978

comment:4 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to duplicate
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use