VirtualBox

Ticket #2978 (reopened defect)

Opened 5 years ago

Last modified 8 months ago

VBoxSVC.exe 100% CPU after WinXP SP3 Hibernate -> fixed in SVN/3.0.2

Reported by: dmaker Owned by:
Priority: major Component: other
Version: VirtualBox 2.1.4 Keywords:
Cc: Guest type: other
Host type: other

Description (last modified by frank) (diff)

The title says almost all, VBoxSVC.exe takes all CPU for several minutes (~5-10mins) (on a P4 2.8GHz, 2GB RAM) so that Windows is almost completely frozen.. after a while the CPU hog stops and Windows is responding normally. No guest VMs loaded when hibernated! Only the VirtualBox main application window was open.

I'm not using a Win page file.. just mentioning if that counts, I've no problems with this other than that some games doesn't work perfectly.. but I suspect that it's not the problem here.

Sorry if this a duplicate ticket, tried to search and found only something vaguely similar related to this.

Attachments

VBox.log Download (43.7 KB) - added by dmaker 5 years ago.
Log of the guest OS session running when hibernating and waking back the host.

Change History

comment:1 Changed 5 years ago by dmaker

Just for clarification, here's steps to reproduce:

  1. Open VB
  2. Hibernate host
  3. Awake the system from hibernate

VBoxSVC.exe hogs CPU for several minutes (~5-10mins).. after a while the CPU hog stops and Windows is responding normally.

comment:2 Changed 5 years ago by dmaker

Updated to 2.1.2 and problem still persists. I just tested and the CPU hog after host hibernate lasted about 9 minutes!!

Am I the only one who has this problem? Could somebody test this and report back here if it's reproducible?

P.S. Should the version metadata be updated in this ticket?

comment:3 Changed 5 years ago by sandervl73

  • Version changed from VirtualBox 2.1.0 to VirtualBox 2.1.2

Add the VBox.log file of such a session please.

comment:4 Changed 5 years ago by dmaker

I'm sorry but how's that going to help? I mean, isn't VBox.log files only generated when running guest OS's? Look at my steps to reproduce this problem, there's no step to run guest OS's = no VBox.log files! Or am I missing something here?

comment:5 Changed 5 years ago by sandervl73

Misread then. Does the same happen when you have a VM running?

Changed 5 years ago by dmaker

Log of the guest OS session running when hibernating and waking back the host.

comment:6 Changed 5 years ago by dmaker

Yes it does.. of course I might add, because the VBoxSVC.exe is running whether I have or haven't got a guest OS running (or if only running guest OS, = main VB window closed).

I guess you were after the log file from that session? Maybe it's of some use. Only interesting IMHO is the following:

00:35:33.247 Changing the VM state from 'RUNNING' to 'SUSPENDED'.
00:35:47.401 ERROR [COM]: aRC=VBOX_E_INVALID_VM_STATE (0x80bb0002) aIID={e3c6d4a1-a935-47ca-b16d-f9e9c496e53e} aComponent={Console} aText={Invalid machine state: 5)} aWarning=false, preserve=false
10:46:13.320 Changing the VM state from 'SUSPENDED' to 'RUNNING'.

comment:7 Changed 5 years ago by sandervl73

What about suspend/resume? Same high cpu use by VBoxSVC? I can't reproduce this here with a Vista host.

comment:8 Changed 5 years ago by dmaker

You surely mean standby?

I think I got new data to this problem; it seems that the hang and the length of it is connected to the standby/hibernate length.

At first I tried the standby really quickly, standby and resume after about 10 seconds, no hang at all. I decided to test again, I put my PC to standby and went to make some food and watched a movie + tv for about 2½-3 hours, resume brought the desktop to the screen very slowly and the VBoxSVC.exe was again hogging the CPU.. this lasted about 2-3 minutes.

Last time I tried the hibernate, the system was in that state for about 3-4 hours and the hang lasted about 4 minutes after resume.

And my hibernate test before that lasted overnight and the hang lasted about 9 minutes after resume.

(yes, I do keep rough notes when I test bugs/problems.. I'm not a newbie with testing)

I think that this is an important observation and could lead to the culprit more easily.

comment:9 Changed 5 years ago by sandervl73

Interesting observation. Will give that a try.

comment:10 Changed 5 years ago by sandervl73

Still can't reproduce. Neither with Vista or XP SP3. Duration of hiberate doesn't make any difference here. Are you willing to test an instrumented build to log what's going on on your system?

comment:11 Changed 5 years ago by ennor

This also happens on my system (XP x64 SP2). VBoxSVC.exe runs at 100% on one of the cores for a good 20 minutes after the host was turned off for 24 hours.

comment:12 Changed 5 years ago by sandervl73

  • Version changed from VirtualBox 2.1.2 to VirtualBox 2.1.4

#3388 has been marked as a duplicate.

comment:13 Changed 5 years ago by GT

I have the same issue, Vista 64bit fully updated host, win 2003 guest

comment:14 Changed 5 years ago by pullunder

I can test an instrumented build to log what's going on on my system.

comment:15 Changed 5 years ago by jnilsson

I also have the same issue, running Vista Business SP1 (32-bit) as host OS and Virtual Box 2.1.4.

Let me know if I can be of any help.

comment:16 in reply to: ↑ description Changed 5 years ago by woongbin@…

This happens on my system when it comes back from S3 sleep, Vista 32bit SP1 host with VirtualBox 2.1.4.

comment:17 Changed 5 years ago by pullunder

This still happens on 2.2.0 of virtualbox (Windows XP 5.1.2600)

comment:18 Changed 5 years ago by whoknows

Same here with Windows Vista Ultimate SP1. I have this problem since 2.1.2 (I think!!!)

comment:19 Changed 5 years ago by whoknows

Same here with Windows Vista Ultimate SP1 32-bits. I have this problem since 2.1.2 (I think!!!)

comment:20 Changed 5 years ago by hallucinate

also seeing this problem in Windows Vista Home Basic. the cpu usage pegging by VBoxSVC.exe definitely seems directly associated to how long the system has been in suspend/hibernate/sleep.

comment:21 Changed 5 years ago by randydu

Just installed 2.2.2r46594, Same issue after I hibernate my laptop (DELL Inspiron 1545,Vista Home Premium SP1; Intel Dual-Core T4200)for a night and the VBoxSVC.exe forces the *second* CPU core running at almost 100% usage for several minutes. No VM or VBox GUI is running at all.

This bug is the same as #2274.

comment:22 Changed 5 years ago by CaptainFlint

I also have the same problem, VB 2.2.2.

Tested on hosts:

  1. WinXP Pro SP3 32-bit, AMD Athlon X2 4600+
  2. Vista Business SP1 32-bit; Intel Core 2 Duo E6600

comment:23 Changed 5 years ago by omoshiroi

I have the same issue with version 2.2.2 on Win7 64-bit (also had it with previous versions and on Vista 64-bit).

In Process Explorer, I see that the thread consuming the CPU is the following:
Thread 4812
50% CPU (100% of one of two 1.8GHz cores)
Start address: MSVCR80.dll!endthreadex+0x80
Stack:
0 MSVCR80.dll!operator new+0x2
1 VBoxSVC.exe+0x181e57
2 VBoxSVC.exe+0x1851cf
3 VBoxSVC.exe+0x18565a
4 VBoxRT.dll!RTTimerLRStop+0x108
5 VBoxRT.dll!RTThreadReadLockDec+0x1e4
6 VBoxRT.dll!RTSemMutexRelease+0x198
7 MSVCR80.dll!endthreadex+0x47
8 MSVCR80.dll!endthreadex+0x104
9 kernel32.dllBaseThreadInitThunk+0xd
10 ntdll.dllRtlUserThreadStart+0x21

comment:24 Changed 5 years ago by andy-ms

I have the same issue on Vista64 SP2 with Virtual Box Version 2.2.4., unfortunately the issue is still not fixed.

comment:25 Changed 5 years ago by ACqua

Same here: Vista64, Service Pack 1, Virtual Box 2.2.4 r47978

comment:26 Changed 5 years ago by hallucinate

still quite broken in vista32 sp2 vbox 2.2.4

comment:27 Changed 5 years ago by mgorelik

I do have this issue as well.

  • Lenovo T60p
  • Windows XP SP2
  • VirtualBox 2.2.4 (I did have the same problem with 2.2)

I do have this happen even when I have NO Virtual Machines running. This sort of sucks, because it take 2-7 min to bring laptop from the standby mode, because VBoxSVC.exe hugs CPU.

comment:28 Changed 5 years ago by pjank

I've just created an account just to say this:

SAME HERE!

Toshiba Tecra M7 Windows7 RC 32bit VirtualBox 2.2.4

One has to remember to shut down VirtualBox completely *before* suspend/hibernation... otherwise it gets very very busy after waking up.

comment:29 Changed 5 years ago by rkos

Same Issue: Windows XP Prof SP3 32bit and Virtualbox 2.2.0/2.2.4. (hibernating and standby)

comment:30 Changed 5 years ago by baseliner

Same problem here with VB 2.2.4r47978 on Windows Vista Business 64-bit w/ SP2 running Windows Vista Business 32-bit VM. I usually don't hibernate the machine, only do standby, and as soon as it comes out of standby, it ties up the CPU 100% for several minutes. I have a Core 2 Duo 2.53 GHz processor w/ 4 GB RAM.

comment:31 Changed 5 years ago by pjank

Seems like it's fixed in 3.0.0 :)

Thank you!

comment:32 Changed 5 years ago by sandervl73

Can others confirm this as well?

comment:33 Changed 5 years ago by pjank

I'm afraid I've said that too soon - the problem is still here :-(
Sorry for my mistake.

I guess the laptop didn't sleep long enough last time (just about 15-20 minutes or so) and that's why I didn't notice a high cpu usage.
This time, after waking up after about 10 hours, it's been thinking hard for sth like 10 minutes!?
It's the VBoxSvc.exe process showing 50% CPU usage on a Core2 Duo CPU.

comment:34 Changed 5 years ago by baseliner

I can also confirm that the problem still remains with the new 3.0.0 release as well. Still hogging the CPU at 50% for a long time.

comment:35 Changed 5 years ago by dmaker

Yep, problem still remains here too with 3.0.0. VBoxSVC.exe still churns away and hogs CPU completely. Just hibernated for about 3 hours and the "freeze" took about 3 minutes. Is there any progress on nailing this issue? Have any of the testers/coders been able to reproduce this?

comment:36 Changed 5 years ago by sandervl73

Unfortunately we are unable to reproduce the problem. I even have the exact same machine (Thinkpad T60p) as one of the reporters with XP and don't see it. Are all of you able to reproduce this even when no VM is running? (just the VirtualBox GUI)

comment:37 Changed 5 years ago by DaveyWavey

I am experiencing the exact same problem. I was using 2.2.4, but have recently upgraded to 3.0.0 and the problem remains.

My system: Windows XP Media Center Edition 2002 (basically the same as XP Pro), SP3 Dell Inspiron 6400 Intel Core 2 Duo T7200 @ 2.0GHz 1GB RAM Latest BIOS

I'm running Ubuntu Server 9.04 as a guest. I pause the guest and hibernate, but when I resume one of my CPU cores maxes out for an extended period (I've not yet waited to see how long for, but it's in excess of 10 mins). The offending process is VBoxSVC.exe.

Shutting down the guest does not stop this, however closing the VirtualBox GUI does.

comment:38 Changed 5 years ago by woongbin@…

@sandervl73: It happens as long as VBoxSVC.exe process is alive and you either go sleep or hibernate your machine and wake it up again.

comment:39 Changed 5 years ago by sandervl73

Volunteers that wish to try out test builds should say so here. I'll wait a few days and will then send out links to test binaries next week. We are still unable to reproduce this problem, so the only solution is to try out a few things. Thanks in advance.

comment:40 Changed 5 years ago by pullunder

@sandervl73: I am able to reproduce this with just the GUI (even when no VM is running) on a Vaio 1GB Pentium M 1.2 GHz with Win XP SP3 host. I am still using Vbox 2.2.0, because setup ends prematurely for 2.2.4 and 3.0.0 (but I don't need any update before #2978 is fixed ;-) ).

Yes, please send a test binary link.

comment:41 Changed 5 years ago by CaptainFlint

I can try the test build too.

comment:42 Changed 5 years ago by pjank

I volunteer as well.

comment:43 Changed 5 years ago by omoshiroi

I volunteer to try out test builds.

comment:44 Changed 5 years ago by woongbin@…

I'd like to try the test build as well.

comment:45 follow-up: ↓ 46 Changed 5 years ago by adda

This is still a problem in VirtualBox 3.0.0 r49315. I am running a Vista 64-bit host. I notice the problem when I have a VM running or paused and I put the host to sleep. I haven't tried other scenarios. After I kill VBoxSvc and unpause the VM and try to enter seamless mode, it errors saying that there isn't enough video memory allocated and I should allocate more than 1mb of video memory... when it has already been allocated 64mb.

comment:46 in reply to: ↑ 45 Changed 5 years ago by kevinnc

I've been experienced this symptom from 2.2.2 , 2.2.4 till 3.0.0, now I found that when I downgrade to install 1.6.6, it seems to be no such issue. Please give it a try if you like.

comment:47 Changed 5 years ago by bavanandel

I've only noticed this issue today for the first time. I've been using different versions from 1.6.x up to 3.0.0 (current). Could it have anything to do with hardware virtualization? Until yesterday, my system bBIOS was locked not to use it, and I've just unlocked it.

After sleeping tonight (not hibernating), I woke up my PC this morning to see that VBoxSvc.exe was hogging one of the two cores of my Core2Duo CPU. The VirtualBox.exe process that ran the machine (Ubuntu Server Jaunty) was very low on CPU, as usual, and both inside the machine and the VirtualBox GUI there were no signs of slowness whatsoever. I noticed however that the Session Information Dialogue, which I still had open, did not respond and I had to close it (which went smooth).

I haven't tested any further for now, but these observations were new to me.

comment:48 Changed 5 years ago by bavanandel

Forgot to mention, my host system runs Vista x86 (32bit), so apparently it affects both 32 and 64 bit versions of the software.

comment:49 Changed 5 years ago by sandervl73

Looks like I found the problem. Will be fixed in 3.0.2. No need for testing anymore as I've been able to reproduce it. Thanks anyway!

comment:50 Changed 5 years ago by sandervl73

  • Summary changed from VBoxSVC.exe 100% CPU after WinXP SP3 Hibernate to VBoxSVC.exe 100% CPU after WinXP SP3 Hibernate -> fixed in SVN/3.0.2

comment:51 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

comment:52 Changed 21 months ago by mozillla

I have this problem with VB 4.1.18, Win 7 Sp1 x64, i3-2120, 8Gb ram.

comment:53 Changed 21 months ago by mozillla

  • Status changed from closed to reopened
  • Resolution fixed deleted

comment:54 follow-up: ↓ 55 Changed 20 months ago by frank

  • Description modified (diff)

Please attach a VBox.log file for such a VM session as well as the VBoxSVC.log file.

comment:55 in reply to: ↑ 54 Changed 18 months ago by mozillla

Last edited 18 months ago by mozillla (previous) (diff)

comment:56 Changed 18 months ago by mozillla

repeat at random after reinstall or update program, problem can fix with reinstall.

comment:57 Changed 15 months ago by cleca

The problem shows up here as well.

VB: 4.2.6 Host: Win XP 64bit SP 2 Guest: Debian 2.6.32-5-amd64 HW: iCore7 950 with 12 GB RAM

Problem: Start host and guest. Hibernate host. Wake up host. VBox and Linux guest hangs with CPU at 100%.

The problem is new and occured after an update of VB to 4.2.6

Any ideas?

Last edited 15 months ago by cleca (previous) (diff)

comment:58 Changed 13 months ago by frank

Still reproducible with VBox 4.2.10?

comment:59 Changed 8 months ago by kellyc

I just installed 4.2.16 r86992 on a brand new Windows 7 system (Dell E6430, i5-3340M 2.7GHz, 8GB)

(brand new, as in 56 updates still in progress - I thought they were all done when I installed vbox, but this morning - after the problem - I see it has these 56 more to do).

Installed Solaris 11u1 from pre-built image from vbox site.

Everything was great yesterday and last night.

This morning I find the Windows 7 host has gone to sleep, which I guess is good.

When I opened the virtual S11 window to see what Solaris thought of this, it started using 100% of the CPU. It took 10 minutes to nudge the mouse to hit the pause button on the virtual system.

Last edited 8 months ago by kellyc (previous) (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use