VirtualBox

Ticket #3361 (closed defect: fixed)

Opened 5 years ago

Last modified 3 years ago

ALT+Left Mouse click in Photoshop doesn't work -> fixed in 3.0.12

Reported by: MarkE Owned by:
Priority: major Component: guest additions
Version: VirtualBox 2.1.4 Keywords: Photoshop ALT mouse keyboard
Cc: Guest type: Windows
Host type: Linux

Description

The host is Linux Ubuntu 8.10. The guest is Windows XP Pro SP 3. Virtual box version 2.1.4. Windows guest additions: 2.1.4.r42893

I am really wanting to drop my need to ever boot into windows native. The issue is that when I'm using Adobe Photoshop CS3, the "healing" tool uses a key+mouse combination to work. The ALT on the keyboard is held down and then the left mouse is clicked to set an anchor point for the healing brush to start from. After doing this, when I left-click alone to perform the healing action I am informed by Photoshop that I must use the ALT+mouse to set the point. Basically, that combination doesn't appear to be captured and Photoshop treats it as though it never occurred.

I would appreciate any progress that could be made in correcting this issue.

-Mark E.

Change History

comment:1 Changed 5 years ago by MarkE

This issue can be worked around when disabling the mouse integration. I had previously reported an issue with my ability to do that in issue #3362 but, somehow, this seems to be resolved.

My issue is essentially closed as I have a working workaround.

Thanks, -Mark

comment:2 Changed 4 years ago by MarkE

As of 3.0.12, this issue appears completely resolved. I don't have to disable mouse integration for this to work. Under normal usage (full screen), the ALT+LEFT_CLICK and SPACE+LEFT_CLICK+DRAG in Photoshop work correctly. This is in Ubuntu 9.10.

Please close the issue.

comment:3 Changed 4 years ago by michael

  • Status changed from new to closed
  • Resolution set to fixed
  • Summary changed from ALT+Left Mouse click in Photoshop doesn't work to ALT+Left Mouse click in Photoshop doesn't work -> fixed in 3.0.12

Thanks for the feedback.

comment:4 Changed 3 years ago by what

  • Status changed from closed to reopened
  • Resolution fixed deleted

The issue reappears in Virtualbox 4.0.0 Beta4. Disabling mouse integration does not help either.

Host: Opensuse 11.3 Client: Windows XP

Clone Stamp in Photoshop does not work. Alt+Click

comment:5 Changed 3 years ago by what

Please close it. It was a KDE Problem. KDE assigns the Alt-Key for special Actions therefore it does not work in Virtualbox and Wine at all. You have to change it from Alt to Meta in Kde itself, then it works.

comment:6 Changed 3 years ago by klaus

  • Status changed from reopened to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use