VirtualBox

Ticket #3362 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

Disable Mouse Integration breaks mouse in host

Reported by: MarkE Owned by:
Priority: major Component: guest additions
Version: VirtualBox 2.1.4 Keywords: disable mouse integration
Cc: Guest type: Windows
Host type: Linux

Description

The host is Linux Ubuntu 8.10. The guest is Windows XP Pro SP 3. Virtual box version 2.1.4. Windows guest additions: 2.1.4.r42893

In trying to workaround my issue #3361, I tried to disable the mouse integration hoping that it would let me do what I wanted. However, when this is done, the mouse is no longer working in the guest or the host. After using HOST+I to toggle it, the host mouse is displayed but it will not interact with anything on the Host desktop. I have to ALT+F4 to close applications and then CTRL+ALT+BACKSPACE to restart the desktop manager.

The option does not appear to work for me at all.

-Mark E.

Attachments

VBox.log Download (45.6 KB) - added by MarkE 5 years ago.
Requested log file for issues with mouse integration

Change History

comment:1 Changed 5 years ago by frank

After you disabled the mouse pointer integration, the mouse will be captured by the current VM window. To release the mouse from that window, press the host key once. Can you confirm this so far? Of course, after pressing Host+I, the mouse should normally work on the desktop as well.

Please could you attach a VBox.log file from such a session when you lost your mouse?

comment:2 Changed 5 years ago by MarkE

I have tried this and it does work before the virtual machine additions are added. Once added, it does not work for me. I will attach the log file for this usage scenario:

  1. Start the vm (Win XP Pro SP3)
  1. Login to desktop
  1. Hit Host+I - initially the mouse pointer was invisible or unpainted. Then, after fiddling some, it became visible and I could see that it was correctly "boxed" by the VM (in a window).
  1. Hit Host+I to release (or Host alone), the Host mouse re-appears but cannot click on anything on the host desktop (Ubuntu 8.10). It cannot focus windows, move them or register button clicks.

I closed the VM using keyboard prompted shutdown. I then logged out of my host desktop and logged back in to send this.

Changed 5 years ago by MarkE

Requested log file for issues with mouse integration

comment:3 Changed 5 years ago by MarkE

When I was browsing the log file, I saw it mention entering seamless mode. I thought I could mention something that may or may not have anything to do with the problem. That is, on previous uses, I have had problems with seamless mode.

In this use and the log use, no seamless mode was ever attempted. Previously (several uses back), I had attempted seamless mode, when prompted, I hit cancel. The VM was not behaving properly at this point. The seamless mode displayed selected in the Machine menu. I struggled to get it fully out of that mode. Eventually, (don't recall what actions were needed) I was able to get it out. If, however, internally it still believes that it is in seamless mode on some level then that could contribute to the mouse integration issue.

Just thought I'd add this.

-Mark

comment:4 Changed 5 years ago by j.resina

The solution can be here  http://www.desertblizzard.com/?p=165 Download the mouse.reg, copy in a share folder in Linux and acces it from XP using keyboard, open and accept, the registry mouse settings will be changed.

Juan

comment:5 Changed 5 years ago by MarkE

The suggested solution at the link partially worked. When the mouse integration is disabled, the mouse properly worked and processed the ALT+MOUSE click handling in photoshop. :D

The problem was with the VM HOST+I to re-enable the mouse integration. I still lost mouse interactivity with the Host desktop.

comment:6 Changed 5 years ago by MarkE

With no changes to my install of VirtualBox, this same process that failed before works now. I don't know if I had done something wrong before, if some other system update has fixed something or what. At any rate, I am now able to properly use the HOST+I through the keyboard or the menu to disable mouse integration and properly use my ALT+LEFT MOUSE click behavior in Photoshop reported here #3361.

comment:7 Changed 5 years ago by knadian

Same issue here. The host is Linux : openSuse 11.1. The guests are : windows XP SP3, Windows 2003 SP2, RedHAT Enterprise Linux 4 update 3.

comment:8 Changed 4 years ago by Technologov

Please retry with 3.2.0, and tell us if this issue fixed.

-Technologov

comment:9 Changed 4 years ago by MarkE

Fixed. Cannot duplicate the bug anymore. Thanks for following up.

comment:10 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Thanks for the response.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use