VirtualBox

Ticket #3308 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

Virtual disk inaccessible problem

Reported by: guoguy Owned by:
Priority: major Component: virtual disk
Version: VirtualBox 2.1.2 Keywords: disk inaccessible
Cc: Guest type: Windows
Host type: Linux

Description

The size of one of my vm disk and snapshots was close to the limit of the LVM volume which hosts the vm, so I enlarged the volume inconsecutively. But After then when I discarded a shapshot, it ended up with "disk full" error which caused the virutal disk inaccesible(the volume had remounted with new size, and it's absolutely sufficient for this change in size). and I can't start the vm with it since then. It may be the lvm problem though. A relating ticket:  http://www.virtualbox.org/ticket/1832
Besides, is there any way to recover the inaccesible disk?
Many thanks.

Attachments

vbox.log Download (952 bytes) - added by guoguy 5 years ago.

Change History

Changed 5 years ago by guoguy

comment:1 Changed 5 years ago by guoguy

Strangely, this time I can discarded other snapshots of the said vm while it couldn't be done previously(I didn't do anything on the vm for the duration, so I can't point out the difference of these situations). The fact is that the "inaccessible disk" refers to the unsuccessfully discarded snapshot rather then the base disk, and it's inaccessible because it's deleted while vbox couldn't recognize this change. So I released the problematic snapshot in the virtual media manager, and the vm can boot up, working fine.
But the "disk full error" problem is still unresolved, then what is the cause?

comment:2 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if still relevant.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use