VirtualBox

Ticket #3309 (new defect)

Opened 5 years ago

Last modified 5 years ago

HostMemoryLow

Reported by: adaldeia Owned by:
Priority: major Component: host support
Version: VirtualBox 2.1.2 Keywords: hostmemorylow, centos 5
Cc: adaldeia@… Guest type: Linux
Host type: Linux

Description

I have a Centos 5 Host and I install a Debian Lenny Guest. It's a 4 GB RAM/Dual Xeon Server. I create the VM with only 200 MB and when I do simple tasks (like an apt-get), I got this error.

Bellow, the tail of VBox.log and the free command. I don't understand why I have a lot of buffers and cached memory (2.5 MB) and the system can't allocate this. Have I do tune any sysctl parameters to coorect this ???

00:00:24.834 PCNet#0: Init: ss32=1 GCRDRA=0x0c11b000[32] GCTDRA=0x0c11a000[16]
00:00:27.355 NAT: DHCP offered IP address 10.0.2.15
00:00:27.691 NAT: IPv6 not supported
00:02:55.969 pgmr3PhysGrowRange: out of memory. pause until the user resumes execution.
00:02:55.969 Changing the VM state from 'RUNNING' to 'SUSPENDED'.
00:02:57.050 Console: VM runtime error: fatal=false, errorID=HostMemoryLow message="Unable to allocate and lock memory. The virtual machine will be paused. Please close applications to free up memory or close the VM"

server1@server1 [~/.VirtualBox/Machines/debian]# free
             total       used       free     shared    buffers     cached
Mem:       4152072    4001504     150568          0     410616    2522284
-/+ buffers/cache:    1068604    3083468
Swap:      2096472      20672    2075800

Attachments

VBox.log Download (33.3 KB) - added by adaldeia 5 years ago.

Change History

comment:1 Changed 5 years ago by frank

Please retry with 2.1.4. In case this happens again, please attach the whole VBox.log file.

Changed 5 years ago by adaldeia

comment:2 Changed 5 years ago by adaldeia

The error persists in 2.1.4. I attach the whole VBox.log. Bellow, some more info:

1) free command before start:

total used free shared buffers cached

Mem: 4152072 3981080 170992 0 155748 3014896 -/+ buffers/cache: 810436 3341636 Swap: 2096472 1288 2095184

2) free command after freeze:

total used free shared buffers cached

Mem: 4152072 3987568 164504 0 154056 2804356 -/+ buffers/cache: 1029156 3122916 Swap: 2096472 1288 2095184

3) Version

adaldeia@server1 [~/.VirtualBox/Machines/debian/Logs]# VBoxManage -version 2.1.4r42893

Best regards.

comment:3 Changed 5 years ago by frank

Interesting. Btw, you should install the RHEL5 rpm which should fit better to the CentOS host.

comment:4 Changed 5 years ago by frank

Not able to reproduce with a PAE kernel on CentOS 5.2, though with a 2GB system. Please could you attach the output of dmesg after you tried to start the VM?

comment:5 Changed 5 years ago by adaldeia

Hi Frank. I installed whe rpm version from site (VirtualBox-2.1.4_42893_rhel5-1.i386.rpm).

adaldeia@server1 [~]# uname -a Linux server1.aldeiadigital.com.br 2.6.18-92.1.10.el5.centos.plusPAE #1 SMP Thu Aug 7 12:55:59 EDT 2008 i686 i686 i386 GNU/Linux

I use the VBOXHeadless to start the machine because this is a remote server. This Debian VM, the system starts normally, but after sometime it freezes, with the error explained by VBox.log. I tried to install OpenSUSE and the error occurs in the instalation. This machine has the VirtualBox 1.6 version. I removed it with rpm -e and then install the 2.1.2 and 2.1.4. I sucessfull installed the debian in VirtualBox 1.6... When I install the 2.1.2, I removed the .VirtualBox dir to start again with a new Debian and OpenSUSE, without success.

Why the Centos does not reclaim the cache space to supply more 'normal' memory ?

Thanks.

comment:6 Changed 5 years ago by frank

Please could you check if this problem still happens with the last release (2.2.2)? There were some important memory-related changes.

comment:7 Changed 5 years ago by adaldeia

Hi frank,

After update to 2.2.2, the problem has not been solved yet. But I update the kernel too (2.6.18-128.1.6.el5.centos.plusPAE) and recompile the module. After this, everthing is fine !!!

Thank you very much and thanks to all VB team for this awesome product !

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use