VirtualBox

Ticket #3288 (closed defect: fixed)

Opened 5 years ago

Last modified 3 years ago

Peaks in CPU-load on Vista 32 bit when VirtualBox is installed

Reported by: pk Owned by:
Priority: major Component: network/hostif
Version: VirtualBox 3.0.8 Keywords:
Cc: Guest type: other
Host type: Windows

Description

I have regular (approx. every 10 seconds) peaks in CPU load (up to ~50% utilization on a Core2Duo-system) on my Win Vista host when VirtualBox is installed. The load is caused by the "System" process (i.e., the Windows kernel), and it happens even if VirtualBox is not running. However, the peaks seemed to have disappeared after I had removed VirtualBox completely and reappeared after I reinstalled it, so I'd guess that some kernel module/driver installed by VirtualBox might be responsible for this.

I also seems that those peaks disappear as soon as I unplug my network cable.

Attachments

VBox.log Download (30.5 KB) - added by vksubs 5 years ago.
VBox.log.1 Download (1.4 KB) - added by vksubs 5 years ago.
VBox.log.2 Download (45.9 KB) - added by vksubs 5 years ago.
VBox.log.3 Download (51.4 KB) - added by vksubs 5 years ago.

Change History

comment:1 Changed 5 years ago by pk

I just found out that it happens with 2.1.0 as well. So I either didn't notice it in the past, or it is because of some conflict with other components/drivers on my system. I think the former is more likely.

comment:2 Changed 5 years ago by pk

I could not reproduce the problem on my home PC which runs Vista x64. So it's either a bug in the 32bit drivers only, or it is some conflict with other drivers.

comment:3 Changed 5 years ago by pk

After some more analysis, the problem is getting really weird.

It seems that those peaks are independent of the network traffic that arrives at the real interface: I unplugged the uplink of the switch to which my PC is connected, and the peaks were still there. However, as soon as Windows realized that the are problems with my network connection (because of the unplugged uplink) and assigned a link-local IP to the interface, the peaks were gone. I made some more experiments such as manually assigning and IP instead of using DHCP, and putting the PC in a different network that uses NAT. The conclusion from these experiments is that the peaks are there as long as Windows "thinks" that the network connection is ok (no matter if it actually is), and that they are gone when Windows discovers problems with the connection.

Additionally, it seems that the WLAN interface is not affected by that problem: I could successfully connect to the internet via WLAN without observing any peaks.

comment:4 Changed 5 years ago by pk

I just found out that the driver isn't required if NAT is used for the guest. ;)

Disabling it in the interface properties thus seems to be a suitable workaround for that problem.

comment:5 Changed 5 years ago by vksubs

OS: WinXP SP2, CPU: Intel Core 2 T7200 2Ghz, RAM: 2GB, VBox: 3.0.8-53140, Guest: FreeBSD 7.2 Stable

There was no any problem for about a month. And one day it started to load CPU heavily even if VBox and all the guests are closed. Was doing everyday things, working on a remote machine via SSH.

Uninstalled VBox - no result - latest Firefox, Chrome, Skype, System process and others ate my CPU time. Reinstalled windows - the problem was gone. Installed VBox again and experienced the problem again. Tried removing the Host-Only adapter, tried disabling VirtualBox Bridged Networking Driver - no effect - my hp nx7400 freezes every 5 minutes for a minute or two. Noticed that if I disable all the network interfaces no any CPU loads occur. Seems like the problem is in VBox networking.

Really tired of searching for a solution. The problem is very annoying and makes it impossible to use VBox in production environment. Please, comment asap.

comment:6 Changed 5 years ago by Hachiman

  • Host type changed from other to Windows
  • Version changed from VirtualBox 2.1.2 to VirtualBox 3.0.8
  • Component changed from other to network/hostif

Could you please attach log file?

comment:7 Changed 5 years ago by sandervl73

No, it's most like related either the host interface or host only drivers that come with VirtualBox. First thing you can try is to disconnect the host-only driver from your network card. Go to the property page of your network card in Windows and delselect the vbox host-only interface.

If that doesn't help, then uninstall VirtualBox and reinstall without the host interface option.

What kind of network hardware/drivers do you have installed on your system?

Changed 5 years ago by vksubs

Changed 5 years ago by vksubs

Changed 5 years ago by vksubs

Changed 5 years ago by vksubs

comment:8 Changed 5 years ago by vksubs

Hello, friends.

sandervl73,

I'd diselected the host interface from my network before you last post. Now tried to reinstall without host interface as you've suggested, some time is needed to see if it helps. And is there a solution if it is the problem?

My Network hardware:

Wired: Broadcom 440x 10/100 Integrated Controller Wireless: Intel(R) PRO/Wireless 3945ABG Network Connection

comment:9 Changed 5 years ago by vksubs

Seems like disabling host interface helps - while the guest is idle cpu is ok, but if I start doing any actions including switching to host window or VirtualBox main window CPU starts to load heavily by VirtualBox.exe and other processes (firefox, antivirus, etc.) Any suggestions?

comment:10 Changed 5 years ago by vksubs

My host was idle, but VirtualBox.exe was still loading CPU until I closed the host and the main window of VBox. I'll try to install VirtualBox-3.0.4-50677-Win which I initially installed and worked with.

comment:11 Changed 5 years ago by vksubs

OMG, a lot of time is wasted but my VBox is back and running as it used to after reinstalling to an older 3.0.4...

But, please, don't close the ticket as the problem isn't actually solved. Still waiting for suggestions.

comment:12 Changed 5 years ago by sandervl73

So what can be concluded now? The CPU load problems when vbox is installed (not running) are gone after uninstalling the host interface drivers?

comment:13 follow-up: ↓ 14 Changed 5 years ago by vksubs

For now I'm not sure if host interface is a problem as CPU loads occured after uninstalling it.

The one thing that helped is turning back to older 3.0.4 version of VBox. And at the moment I'm running 2 guests FBSD and WinXP without any CPU peaks while no guest activity.

comment:14 in reply to: ↑ 13 Changed 4 years ago by misha

Replying to vksubs: Could you try the latest VBox 3.1 to see if it solves your issue, and if not, could you please specify whether you have any custom networking-related software installed, e.g. VPN clients, Anti-virus, other hypervisors (like VMWare or Virtual PC), etc.

comment:15 Changed 3 years ago by misha

What's the status of this? Still valid with the latest VBox release?

comment:16 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

No response, closing.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use