VirtualBox

Ticket #3279 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

"There are no more files" Error for IO tru the Shared folder

Reported by: Kjeld Owned by:
Priority: major Component: other
Version: VirtualBox 2.1.2 Keywords: javas windows 2003 mac os x coldfusion iis
Cc: Guest type: Windows
Host type: Mac OS X

Description

"There are no more files" is an IO error that occurs when we try to use Java (Jrun) in an Windows 2003 standart edition server image with IIS and ColdFusion development.

The image runs fine on a windows XP host OS but on de Mac OS X it returns this strange error.

It is simmilar to this  http://www.jetbrains.net/jira/browse/RSPL-830 bug report.

The source files are mapped tru the IIS server from the host's (Mac OS X) file system.

This is the ColdFusion/Java error: java.io.IOException: There are no more files

at java.io.WinNTFileSystem.canonicalize0(Native Method) at java.io.Win32FileSystem.canonicalize(Win32FileSystem.java:375) at java.io.File.getCanonicalPath(File.java:559) at coldfusion.jsp.JRunTagLibraryInfo.lookupTLI(JRunTagLibraryInfo.java:115)

Change History

comment:1 follow-up: ↓ 2 Changed 5 years ago by frank

It could be related to the maximum number of open files for a process. Can you increase the limit somehow, perhaps opening some command line window, doing ulimit -n 8192 and starting the VM?

comment:2 in reply to: ↑ 1 Changed 5 years ago by Kjeld

Replying to frank:

No that didn't seem to work. Same problem unfortunatly

comment:3 follow-up: ↓ 4 Changed 5 years ago by frank

Sorry for asking, but how did you exactly start the VM and how did you increase the limit? Note that I have only limited knowledge about the Mac platform and I want to make sure that we didn't miss an important step.

comment:4 in reply to: ↑ 3 Changed 5 years ago by Kjeld

I have opened a terminal and typed the command. Then I launched virtualbox.

We also tryed launching VM via "sudo". No worries about the questions, email me directly if you want I am happy to help. I realy like VM but this error kills it for our dev teams sandboxes.

As you can read here  http://www.jetbrains.net/jira/browse/RSPL-830 the error also occuers in a Linux enviroment.

comment:5 follow-up: ↓ 6 Changed 5 years ago by frank

So you launched VBox from the same terminal after you executed the ulimit -n 8192 command, right? It is necessary to execute VirtualBox -startvm VM_NAME from the same terminal.

comment:6 in reply to: ↑ 5 Changed 5 years ago by Kjeld

We have tryed doind it in the method you have just descibed. it doens't help.

comment:7 Changed 5 years ago by Kjeld

Any new ideas? The new release didn't solve this problem.

comment:8 Changed 5 years ago by lkraav

i ran into a "no more files" error on fresh install win7. i have a persistent vbox share mapped to a drive letter, which is "reconnect at logon". after a fresh reboot of VM, trying to download a file with Internet Explorer results in this error, if i choose mapped drive as the Save location.

i believe the error went away, if i first opened the network share from "Computer" with windows explorer. after that Internet Explorer could save the file to the share drive letter. i will need to do another verification run on this.

comment:9 Changed 5 years ago by psidrum

I have the same problem, I am running a ubuntu linux host and a win7 guest using the latest virtualbox 3. I encountered this problem running Photoshop CS4 in guest, i would try to save a photoshop file in the Shared folder, but it will return a "there are no more files" error.

comment:10 Changed 5 years ago by psidrum

I tried running Vista 64 as guest on Linux host, i ran Photoshop CS4 and tried to save in the shared folder and i did not encounter the error, it only shows up on Win7

comment:11 Changed 5 years ago by Obvious

I'm another affected by this.

Host: Unbuntu 9.04 64 bit Guest: win 7 RC 64 bit VBox 3.0.2

AMD 64 processor

Can create folders, files with windows explorer but attempting to save files via the "Save As" dialogue from any windows application that I have tried throws "There are no more files" error.

Mapping via shared folders = no good Access via Samba = files save ok

comment:12 Changed 5 years ago by steppres

I'd like to confirm this.

Guest: Windows 7 (x86). Host: Ubuntu 9.04 (x64).

The Windows 7 guest is able to save files into a shared folder when running under a Windows XP x86 host machine.

comment:13 Changed 5 years ago by lazylady

I too can sadly confirm this. Any progress regarding this? I would gladly try a temporary solution, if it's offered.

comment:14 Changed 5 years ago by muzafsh

' There are no more files '

Ummmm.......another affected user.

Host : Ubuntu 9.04 Remix Guest : Windows 7 Beta

Network shares mapped to drives checked to reconnect at logon.

Able to copy files on the explorer, even right click and create files directly in the explorer.

JUST RETURNS THE ABOVE ERROR WHEN TRYING TO SAVE FROM WITHIN AN APPLICATION (doesn't work even with a simple app as notepad)

Has thrown a very important utility out of gear (saving your work files on the network share from within our professional applications)

Hoping to find a fix/workaround ASAP :(

comment:15 Changed 5 years ago by andri

I'm experiencing the same issue on Windows 7 when using Save As with Notepad. Happens both with the mapped drive and \vboxsvr approach.

comment:16 Changed 5 years ago by jaberg

First time here, forgive me if I inadvertently breach a protocol. I'm seeing this same problem.

I was attempting to share the Documents and Downloads folder from my home directory on the Macintosh. I mounted these as Network Drives. It seems that I can save changes to an existing document but I can not do a Save As or save a new document. Programs I tested this with were (originally) Puxing 6-in-1 (a program to save channel settings to a handheld VHF radio) and, as proof against that program being at fault, WordPad.

After some online research I was lead to believe that this might be a permissions issue. Not wanting to alter the permissions of key folders in my home directory, I created a new folder and did a chmod 1777 [folderpath/name]. I then mapped that folder as a network drive--this time making sure that the sharename was all lower case (per my research.) Unfortunately, the result is the same: I cannot save new documents or, as I originally intended, a new document based on changes made to an existing document.

My temporary work around is to save the document "locally" (on the guest "drive") and then drag the file over to the desired destination. For my relatively light workflow this isn't a huge problem but for some, or for me in the future, this could be a near deal-breaker.

Host: Mac OS X 10.6.1 Guest: Windows 7 Ultimate RC (Eval Copy, Build 7100) up-to-date as of this morning. VirtualBox 3.0.8 r53138

Please let me know if any of terms were unclear (or incorrect) or if there is more information you would like me to provide. Again, this is my first time here (looking for answers to this problem) and I don't have the lay of the land yet.

comment:17 follow-up: ↓ 22 Changed 4 years ago by jbaruch

Confirmed, Ubuntu 8.10 host, Windows 7 guest, "Save as" returns "There are no more files", both with mapped drive and \vboxsvr, otherwise perfectly writeable.

comment:18 Changed 4 years ago by jshank

Confirmed problem for me. Host Mac OSX 10.6.1 running Virtual Box 3.0.8 r53138 Guest: Windows 7 RTM.

comment:19 Changed 4 years ago by lazylady

The bug still exist in the newly released 3.0.10.

comment:20 Changed 4 years ago by frank

Are you sure you upgraded the guest additions?

comment:21 Changed 4 years ago by lazylady

My sincerest apologies for being such a schmuck that I forgot to install the guest additions.

Amazing, from hanging with the head to being happy as puppy in a split second.

The bug for me is now long gone. Thanks a lot!

comment:22 in reply to: ↑ 17 Changed 4 years ago by jaberg

Happy to report that after installing VB 3.0.10 and the accompanying guest additions this bug has disappeared. ( Mac OSX 10.6 host/Win 7 Guest.)

comment:23 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use