VirtualBox

Ticket #3169 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

Guru mediation (pgmPoolTrackPhysExtDerefGCPhys) while linux guest shutdown/log out

Reported by: whiskey Owned by:
Priority: major Component: guest additions
Version: VirtualBox 2.1.2 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description

After upgrade VBox from 2.1.0 to 2.1.2 (on WinXP SP2) guest OS (AltLinux Desktop 4.1) crashes with the message "A critical error has occured while running the virtual machine...". It happens on guest shutdown/user logout. The Guest Additions was upgraded from 2.0.6 to 2.1.2 (because 2.1.0 did not work properly with keymap switching). Downgrading the Guest Additions to 2.0.6 did not solve the problem.

Attachments

AltLinux Desktop 4.1-2009-01-26-09-57-40.log Download (233.5 KB) - added by whiskey 5 years ago.
ZW54GnomeBeta-2009-01-26-21-10-13.log Download (201.8 KB) - added by laprjns 5 years ago.
Critical error message - Zenwalk host, ZenwalkGnome guest
Slackware-12.2-guest.log Download (124.8 KB) - added by ppr-kut 5 years ago.
Slackware-current-guest.log Download (135.1 KB) - added by ppr-kut 5 years ago.

Change History

Changed 5 years ago by whiskey

comment:1 Changed 5 years ago by frank

  • Summary changed from Critical error message while linux guest shutdown/log out to Guru mediation (pgmPoolTrackPhysExtDerefGCPhys) while linux guest shutdown/log out

comment:2 Changed 5 years ago by laprjns

I seem to have the same problem. I get a critical error messages after shutting down the vm or logging out. I get the error message right after getting the message that that the os reports the mouse integration is not active. My host is Zenwalk 5.4 and the guests that are experiancing this problem are also variations of Zenwalk. I do have two windows vm; one is XpPro and the other is Windows 7. They do not have this critical error problem, although I do swear that it happen once on the Win 7 the first time I started under VB2.1.2. All these vm were created with early version of VB and worked normally under 2.1.0. When intial started on 2.1.2, they all had GuestAdditions 2.1.0 installed. Also, even though I get thses critical error, the vm's all boot up and seem to be operating without any other issues.

Changed 5 years ago by laprjns

Critical error message - Zenwalk host, ZenwalkGnome guest

comment:3 Changed 5 years ago by sandervl73

Can you reproduce this easily? If so, would you be willing to try out a test build?

comment:4 Changed 5 years ago by laprjns

Well, if your asking me, then yes I can reproduce the problem. and yes I am willing to try out a test build. I actually package VirtualBox -OSE for Zenwalk distribution, so I could even build from source if you want . I was testing my build of 2.1.2 when I got the error . I have four different Zenwalk variants VMs that all throw the critical error message when either logging out or shutting down. My Windows 7 VM does not throw the critical error message. My host is Zenwalk 5.4.

comment:5 Changed 5 years ago by sandervl73

laprjns: in that case you can build from OSE right now to see if it's fixed. Thanks.

comment:6 Changed 5 years ago by laprjns

ok, will build a package from svn tonight. Thanks

comment:7 Changed 5 years ago by laprjns

Sorry,I'm having some problems building the package (not VirtualBox related) but I think I've got them resolved now. Will be testing soon.

comment:8 Changed 5 years ago by laprjns

I downloaded and built svn version 16491. With this build I get normal shutdowns on all my ZW virtual machine. Problem seems to be resolved, thanks Rich

comment:9 Changed 5 years ago by ppr-kut

I think I'm still affected by this bug with version 2.2.2. The VM crashes in the described way, always on logout, sometimes even on login, but only if the virtualbox-guest additions are installed and vboxvideo is used as driver. It happens with both ose-additions (built from source) and binary additions.

Changed 5 years ago by ppr-kut

comment:10 Changed 5 years ago by ppr-kut

Seems I have been wrong with my previous assumption. I just installed Slackware-current in a new VM and it crahed right after the first "startx". Log attached.

Changed 5 years ago by ppr-kut

comment:11 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Closing as we think the problem was fixed, see #3124.

comment:12 Changed 5 years ago by frank

Well, reading through the comments above I'm not that sure that this is indeed a duplicate of #3124. So please reopen if that problem still occurs for someone with VBox 2.2.4 or VBox 3.0.4.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use