VirtualBox

Ticket #3151 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

XP Host crash with BSOD (DRIVER_IRQL_NOT_LESS_OR_EQUAL) with hostif

Reported by: tkroenert Owned by:
Priority: blocker Component: network/hostif
Version: VirtualBox 2.1.2 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description

Im running vbox 2.1.2 on WinXP with Linux2.6 as guest.

After switching from NAT to Hostinterface my Host-System crashs every time I boot the guest..

BSOD:

DRIVER_IRQL_NOT_LESS_OR_EQUAL
...
STOP: 0x00000000D1

Attachments

Mini012409-01.7z Download (2.7 KB) - added by tkroenert 5 years ago.
MiniDump
opalix-2009-01-24-23-21-48.log Download (34.0 KB) - added by tkroenert 5 years ago.
Vbox.log
Minidumps.zip Download (50.3 KB) - added by dmvbox 5 years ago.
3 Minidump files
setupapi.zip Download (5.0 KB) - added by dmvbox 5 years ago.
setupapi log

Change History

Changed 5 years ago by tkroenert

MiniDump

Changed 5 years ago by tkroenert

Vbox.log

comment:1 Changed 5 years ago by frank

  • Summary changed from XP Host crash with BSOD - only with "Hostinterface"... to XP Host crash with BSOD (DRIVER_IRQL_NOT_LESS_OR_EQUAL) with hostif

comment:2 Changed 5 years ago by pentagonik

To all who have problems (Bluescreens) with the VBoxNetFlt component: Please send me a mail at <my nickname> at sun dot com. I'll then send you a link to a new test version.

comment:3 Changed 5 years ago by misha

tkroenert: the minidump you posted does not contain a valid module list, so I can not detect the call-stack of a fault. Could you attach here another log in case you see this fault again?

comment:4 Changed 5 years ago by dmvbox

I'm having a similar issue, except I get the BSOD during install of the VBoxNetFlt driver. Attaching my 3 minidumps...

Changed 5 years ago by dmvbox

3 Minidump files

Changed 5 years ago by dmvbox

setupapi log

comment:5 Changed 5 years ago by dmvbox

I removed the Cisco VPN client and uninstalled my network card/drivers. I rebooted the PC and installed the latest driver from intel (Pro/100 VE). The installation of VirtualBox than worked and using Host Interface worked fine. I have it installed fine at work on my laptop with the Cisco VPN client installed, so I have a feeling my network driver stack was just messed up from adding and removing the VPN client, VMWare (multiple version), driver updates, etc... over the last couple years, and removing everything and starting fresh cleared it out.

comment:6 follow-up: ↓ 7 Changed 5 years ago by dmvbox

It was/is the Cisco VPN client, as soon as I reinstalled it and tried to make a connection, blue screen. The version of the Cisco VPN client I have is 5.0.01.0600.

comment:7 in reply to: ↑ 6 Changed 5 years ago by misha

Replying to dmvbox:
I'm unable to reproduce the issue, however we've made some significant fixes to the driver and the installation that should probably fix your issue.
I can share with you a test build containing the fixes. Please send me a mail at Mikhail dot Sennikovsky at sun dot com if you're willing to test it. I'll then send you a link to a test version containing a fix.

comment:8 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

Retry with 2.1.4 and reopen if necessary please.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use