VirtualBox

Ticket #3152 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

OPENSTEP 4.2 guest doesn't completely startup anymore after updating VirtualBox from version 2.0.6 to 2.1.0 or 2.1.2 => fixed in SVN

Reported by: iooi Owned by:
Priority: major Component: other
Version: VirtualBox 2.1.2 Keywords:
Cc: Guest type: other
Host type: other

Description

I used to run an OPENSTEP 4.2 guest in version 2.0.6 of VirtualBox. After updating at first to version 2.1.0 and today to 2.1.2 I am no longer able to completely boot up the OPENSTEP guest. The booting is almost complete, just the login screen does never appear, I get just a grey screen with a moveable mouse pointer. I had to revert the update, so now I am using version 2.0.6 again, I was lucky to have backups.

See the attached screenshots of what is happening and of what I am expected to happen.

Attachments

OPENSTEP_4.2_hangs_here_under_VirtualBox_2.1.png Download (188.7 KB) - added by iooi 5 years ago.
This is what happens on VirtualBox 2.1.0 and 2.1.2 - a hang after boot up - no login screen
OPENSTEP_4.2_login_screen_on_VirtualBox_2.0.png Download (247.8 KB) - added by iooi 5 years ago.
This is what I expected: a login screen appears about two seconds after the grey screen under Virtual Box 2.0.6
OPENSTEP_4.2_lafter_login_on_VirtualBox_2.0.png Download (263.1 KB) - added by iooi 5 years ago.
This is what it looks like after login on VirtualBox 2.0.6 (to prove it really works)
VBox.log Download (40.7 KB) - added by iooi 5 years ago.
the log file out of /Library/VirtualBox/Machines/OPENSTEP 4.2/Logs/

Change History

Changed 5 years ago by iooi

This is what happens on VirtualBox 2.1.0 and 2.1.2 - a hang after boot up - no login screen

Changed 5 years ago by iooi

This is what I expected: a login screen appears about two seconds after the grey screen under Virtual Box 2.0.6

Changed 5 years ago by iooi

This is what it looks like after login on VirtualBox 2.0.6 (to prove it really works)

Changed 5 years ago by iooi

the log file out of /Library/VirtualBox/Machines/OPENSTEP 4.2/Logs/

comment:1 Changed 5 years ago by ni81036

Are there freely available demo ISO of OpenStep in question? Otherwise we cannot reproduce nor fix the issue.

comment:2 Changed 5 years ago by iooi

OPENSTEP 4.2 is practically abandonware, it's no longer sold by Apple but available from time to time on Ebay (that's how I got my copy) and here:  http://www.blackholeinc.com/specials/survey.shtml .

I can offer you to upload an freshly installed OPENSTEP 4.2.vdi (fixed size 2GB vdi but maybe less when compressed) on a place you specify for your debugging purposes if that's o.k. for you.

comment:3 Changed 5 years ago by ni81036

  • Status changed from new to closed
  • Resolution set to fixed

comment:4 Changed 5 years ago by ni81036

  • Summary changed from OPENSTEP 4.2 guest doesn't completely startup anymore after updating VirtualBox from version 2.0.6 to 2.1.0 or 2.1.2 to OPENSTEP 4.2 guest doesn't completely startup anymore after updating VirtualBox from version 2.0.6 to 2.1.0 or 2.1.2 => fixed in SVN
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use