VirtualBox

Ticket #3042 (closed defect: duplicate)

Opened 5 years ago

Last modified 5 years ago

BUG: unable to handle kernel paging request under Linux host & guest

Reported by: ronys Owned by:
Priority: major Component: host support
Version: VirtualBox 2.1.0 Keywords:
Cc: Guest type: other
Host type: Linux

Description

Host: Debian Etch using custom built kernel (2.18 based). Guest: Debian Lenny.

Occasionally, I get the following console/dmesg output. I think it occurred when I tried to ping from the guest via a host interface virtual NIC. The ping fails, btw, as arp relies appear to be ignored:

BUG: unable to handle kernel paging request at virtual address ffffff94

printing eip:

f8b13683 *pde = 00004067 *pte = 00000000 Oops: 0000 #1 SMP Modules linked in: vboxnetflt vboxdrv iscsi_tcp libiscsi scsi_transport_iscsi cr c32c libcrc32c button ac battery dm_snapshot dm_mirror dm_mod loop evdev pcspkr psmouse serio_raw rtc sg sr_mod cdrom ext3 jbd sd_mod amd74xx generic ide_core r 8169 ohci_hcd ehci_hcd forcedeth usbcore sata_nv libata scsi_mod thermal process or fan CPU: 0 EIP: 0060:[<f8b13683>] Not tainted VLI EFLAGS: 00010286 (2.6.18iscsitgt2 #1) EIP is at vboxNetFltLinuxXmitTask+0x17/0x17a [vboxnetflt] eax: 00000000 ebx: dfb6df60 ecx: dfbc4158 edx: 00000296 esi: e1d7f0b8 edi: ffffff5c ebp: 00000296 esp: dfb6df5c ds: 007b es: 007b ss: 0068 Process events/0 (pid: 6, ti=dfb6c000 task=dffefab0 task.ti=dfb6c000) Stack: dfb6df60 00000000 e1d7f0b4 e1d7f0b8 dfbc4140 00000296 c0129978 f8b1366c

00000000 dfbc4154 dfbc4140 dfbc414c 00000000 c012a25f 00000001 00000000 00000000 00010000 00000000 00000000 dffefab0 c01165bc 00100100 00200200

Call Trace:

[<c0129978>] run_workqueue+0x78/0xb5 [<f8b1366c>] vboxNetFltLinuxXmitTask+0x0/0x17a [vboxnetflt] [<c012a25f>] worker_thread+0xd9/0x10a [<c01165bc>] default_wake_function+0x0/0xc [<c012a186>] worker_thread+0x0/0x10a [<c012c633>] kthread+0xc2/0xef [<c012c571>] kthread+0x0/0xef [<c0101005>] kernel_thread_helper+0x5/0xb

Code: 72 c7 31 c0 86 45 60 83 c4 0c b8 01 00 00 00 5b 5e 5f 5d c3 55 57 8d b8 5c

ff ff ff 56 53 83 ec 04 89 e3 c7 04 24 00 00 00 00 53 <ff> 77 38 e8 12 39 00 00 8a 47 40 5e 5d 84 c0 74 1c ba 01 00 00

EIP: [<f8b13683>] vboxNetFltLinuxXmitTask+0x17/0x17a [vboxnetflt] SS:ESP 0068:df b6df5c

Change History

comment:1 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

I'm quite sure this is a duplicate of #2827. Please try the patch which proposed there.

comment:2 Changed 5 years ago by ronys

Indeed - the patch works perfectly. Thanks!

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use