VirtualBox

Ticket #2827 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

vboxnetflt kernel panic with pre-2.6.20 host kernels => Fixed in SVN

Reported by: ToddAndMargo Owned by:
Priority: blocker Component: network/hostif
Version: VirtualBox 2.1.0 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

Hi All,

As critical as it gets:

After removing 2.0.6 and installing 2.1.0, I now get a kernel panic when booting up

XP-Pro-SP3 guest. Panic occures at the splash screen just before the desktop appears. Problem occurs with or without 3D support. VTx is enabled.

Host: CentOS 5.2 (RHEL 5.2 clone)

$uname -r: 2.6.18-92.1.22.el5

Guest: Windows XP Pro Service Pack 3

My mobo:  http://www.supermicro.com/products/motherboard/Xeon1333/5000X/X7DAL-E+.cfm

My chipset:  http://www.intel.com/products/server/chipsets/5000x/5000x-overview.htm

-T

Attachments

VB-WinXP.xml Download (6.8 KB) - added by ToddAndMargo 5 years ago.
VBox.log Download (35.2 KB) - added by ToddAndMargo 5 years ago.

Change History

Changed 5 years ago by ToddAndMargo

Changed 5 years ago by ToddAndMargo

comment:1 Changed 5 years ago by ToddAndMargo

Host Interface is selected as my networking. Please note that bug 2829 is a duplicate of this bug (RHEL5 and CentOS 5 are the same OS).

comment:2 Changed 5 years ago by ToddAndMargo

My messages log at the time of the kernel panic:

Dec 19 14:44:02 rn1 kernel: device eth0 entered promiscuous mode Dec 19 14:44:28 rn1 dhcpd: Dynamic and static leases present for 192.168.255.197. [kernel panicked here] Dec 19 14:46:21 rn1 syslogd 1.4.1: restart.

comment:3 Changed 5 years ago by mamnmamn

I'd like to add that we have also seen this behaviour on Centos 5.2. We do not have VTx enabled but do use host interface networking.

If we use another network mode then the issue goes away.

comment:4 Changed 5 years ago by zilvis

After upgrading to 2.1.0 from 2.0.6 starting XP guest (SP2 or SP3) with host attached interface freezes host computer immediately. Centos 5.2 64 bit on HP Proliant DL360G5 CPU E5410. 2.6.18-92. Changing interface to NAT or disabling it allows to boot normally. No tweaks - VTx disabled, no 3d acceleration. p.s. I used 2.0.6 for couple of days but networking (via br0) was stopping to work in guest after several hours. Was looking in host and guest logs for clues - there were no errors or warnings. So I decided go 2.1.0...

comment:5 Changed 5 years ago by aleksey

The problem appears with pre-2.6.20 kernels only. The fix will be included into the next maintenance release. Since netflt driver always comes with source code those who urgently need the fix may apply the following patch to src/vboxnetflt/linux/VBoxNetFlt-linux.c (the path is relative to your vbox installation directory):

1031c1031 < INIT_WORK(&pThis->u.s.XmitTask, vboxNetFltLinuxXmitTask, NULL); ---

INIT_WORK(&pThis->u.s.XmitTask, vboxNetFltLinuxXmitTask, &pThis->u.s.XmitTask);

Then, kernel modules need to be re-built with

/etc/init.d/vboxdrv setup

comment:6 Changed 5 years ago by aleksey

Formatting of the previous message got ugly so I am reposting the corrected version:

The problem appears with pre-2.6.20 kernels only. The fix will be included into the next maintenance release. Since netflt driver always comes with source code those who urgently need the fix may apply the following patch to src/vboxnetflt/linux/VBoxNetFlt-linux.c (the path is relative to your vbox installation directory):

1031c1031
<     INIT_WORK(&pThis->u.s.XmitTask, vboxNetFltLinuxXmitTask, NULL);
---
>     INIT_WORK(&pThis->u.s.XmitTask, vboxNetFltLinuxXmitTask, &pThis->u.s.XmitTask);

Then, kernel modules need to be re-built with

/etc/init.d/vboxdrv setup

comment:7 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate
  • Summary changed from kernel panic with CentOS 5.2 host and XP-Pro-Sp3 and VB 2.1.0 to vboxnetflt kernel panic with pre-2.6.20 host kernels => Fixed in SVN

comment:8 Changed 5 years ago by frank

  • Status changed from closed to reopened
  • Resolution duplicate deleted

comment:9 Changed 5 years ago by frank

  • Component changed from other to network

comment:10 Changed 5 years ago by frank

  • Component changed from network to network/hostif

comment:11 Changed 5 years ago by sandervl73

  • Status changed from reopened to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use