Ticket #2985 (reopened defect)

Opened 7 years ago

Last modified 2 weeks ago

no screen refresh until some change is made "inside" host

Reported by: macias Owned by:
Priority: major Component: 3D support
Version: VirtualBox 2.1.0 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description (last modified by frank) (diff)

I run KDE4Daily as guest (host: Vista). After first login&logout from KDE session (within guest) I return to WDM. At that point through log in, entering KDE again, till logging out again there are no automatic screen refreshes at all.

The screen looks static, in order to see what is going on on the screen I have to keep clicking mouse outside the guest screen (for in example in VirtualBox menu, or in _host_ taskbar). Such manual refresh works fine, the screen is not distorted. Of course the point is the screen refresh should be done automatically as always.

Video card: intel 4500 mhd.


VBox.log.norefresh Download (114.5 KB) - added by jrminky 3 years ago.
Refresh Issue.PNG Download (322.3 KB) - added by Colin McT 18 months ago.
Screen not re-painting unless change happens in guest, in this case change is right clicking to open menu repaints a portion of the screen

Change History

comment:1 Changed 7 years ago by frank

Do you have the guest additions installed? Did you ever try an older version of VirtualBox, for instance 2.0.6?

comment:2 Changed 7 years ago by macias

Additions -- of course, without it I would not get the screen resize on guest system at all.

No, I didn't try previous versions of VB (I mean for this issue, because I use VB for some quite time, but on Vista for the first time and with 2.1).

comment:3 Changed 7 years ago by frank

Then this problem might be related to #2771.

comment:4 Changed 7 years ago by macias

It might. But note for me works everything with one exception -- when the window is maximized.

It this window would be resized to maximum (this is quite different than maximized) then it would work.

comment:5 Changed 7 years ago by bbreslauer

(This used to be in 3096, but it was a different bug) I'm having a very similar problem. I'm running 2.1.4 on a Debian etch host with Debian sid/experimental on the guest, with kde 4.2. Both host and guest are running kernel 2.6.26. When KDE loads in the guest with the vboxvideo driver, it performs perfectly well (the screen updates continuously). However, if I log out, then the screen no longer updates unless another window moves over it or I move the window off-screen temporarily, then bring it back on screen. In addition, I have two monitors; if I move it from the secondary monitor (in KDE, but Screen 0 in xorg.conf) even partially onto the primary monitor (in KDE, but Screen1 in xorg.conf), then a complete refresh occurs, but only that once. Keyboard and mouse still work, though I don't see the results unless I move the window off-screen and then back on. If I switch from the vboxvideo to vesa driver in X, then none of these peculiarities occur.

comment:6 Changed 7 years ago by michael

Is this still an issue?

comment:7 Changed 7 years ago by bbreslauer

I'm using 3.something now, so this isn't an issue for me anymore.

comment:8 Changed 7 years ago by macias

I didn't see this issue for quite a while to I assume it can be closed. If it re-appears I will notify you.

comment:9 Changed 7 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Thanks for the feedback!

comment:10 Changed 5 years ago by jamesensor

  • Status changed from closed to reopened
  • Resolution fixed deleted

Hi, I'm using ubuntu 10.10 64bit on a Acer aspire 5740g laptop and virtualbox installed version 4.1.6 r74713. This very exact same issue appeared too on my system. Hope it gets fixed :) meanwhile I'll go back to a previous VB package while it gets reviewed. Thank you.

comment:11 Changed 4 years ago by KlaasVaak

Same issue here.

  • Host: Windows 7 Home Premium 64 bit on Dell XPS L502X
  • Virtualbox: 4.1.8
  • Guest: Ubuntu 11.10 64bit
  • Guest additions: yes
Last edited 4 years ago by frank (previous) (diff)

comment:12 Changed 4 years ago by sffetlio

I have the same problem. Win 7 Pro 64 on HP Pavilion dv6. Vbox 4.1.8 and 4.1.10 with GA. With Ubuntu 11.10 64 guest.

comment:13 Changed 4 years ago by frank

  • Description modified (diff)

Please attach VBox.log files of such VM sessions. I assume that this only happens if you use Ubuntu with the 3D-accelerated desktop?

Changed 3 years ago by jrminky

comment:14 Changed 3 years ago by jrminky

For what it's worth, I see the opposite behavior with a Win7 Pro 64 guest running inside VBox v4.2.4 r81684 on a Fedora 14 (yeah, yeah, I know it's old) host OS. In my case, the guest desktop doesn't automatically refresh if I'm not actively doing something inside the guest (and even then, I might have to manually force areas to be refreshed...see below)

Easiest way to reproduce the problem is to simply switch to a different virtual desktop (make sure the new virtual desktop has one or more windows would overlap the VBox guest window) on the host machine and then switch back. The Windows guest will not refresh its desktop window.

Sometimes I can force a refresh by simply clicking somewhere inside the guest window. Other times, the refresh doesn't occur until I manually drag one of the Win7 guest's app windows (cmd.exe, for example) over the unrefreshed portion of the guest desktop.

Guest 2D and 3D acceleration were enabled; I do not see the problem if guest 3D acceleration is disabled. I haven't tried seamless or full-screen modes. nVidia proprietary display drivers have been installed on the host machine.

I'm attaching the relevant VBox.log...

comment:15 Changed 3 years ago by dellagustin

Hi All,

I was exeperiencing a similar problem using a Samsung laptop (RF511). I reached the conclusion that this is due to NVIDIA Optimus, probably a refresh issue, maybe it will be solved with a later host driver.

Meanwhile I solved the issue by setting the Virtuabox executable to use the NVidia card instead of selecting the card automatically. This can be set on the NVidia control panel for optimus. This enabled me to use the 3D acceleration and Full Screen properly.

Cheers, dellagustin.

comment:16 Changed 3 years ago by Joost de Vries

Thank you so much dellagustin,

I was having pernicious problems with virtualbox+linux not refreshing. Turns out that your trick worked. So I set VirtualboxSvc.exe to use the Nvidia processor instead of the standard 'integrated processor'.

So if you're having problems with linux graphics/display not refreshing with virtualbox on windows 7 this may have to do with the nvidia settings.

comment:17 Changed 3 years ago by misha

  • Component changed from GUI to 3D support

There seems to be different problems being described here: one that the 3D screen data does not refresh unless *guest* refreshes it, and another (the original one) is that the screen would not refresh until some action is done on *host*.
The first one should be solved in the next major release, and I should be able to give you a test build soon, once the code gets a bit more stabilized, and I *hope* that the situation with the second one should also be improved with it.

Changed 18 months ago by Colin McT

Screen not re-painting unless change happens in guest, in this case change is right clicking to open menu repaints a portion of the screen

comment:18 Changed 18 months ago by Colin McT

Is this issue being worked on? I am having the same issue (even as I type this...). I am running: Host Windows 8 enterprise Guest Ubuntu 14.04.1 LTS

3D Acceleration is enabled, when I disable it the refresh issue is no longer present but the vms' performance is so sluggish it's unusable.

Issue is most noticeable in chrome and sublime text for me, I have attached a screenshot of the issue that happened while viewing this page

Last edited 18 months ago by Colin McT (previous) (diff)

comment:19 Changed 10 months ago by JakeGD

I am still having this issue (exactly what is seen in the attachment given above). My host is Mac OS X Mavericks running VirtualBox 4.3.30 r101610. The guest OS is 64-bit Ubuntu 14.04 LTS running with 4GB RAM on an Intel Core i7-3720QM CPU @ 2.6GHz (dual) using Chromium graphics.

Can any update be given as to anticipated timeframe in which this could be addressed, or alternatively ways to correct for the issue in the guest OS or settings if one exists?

Last edited 10 months ago by JakeGD (previous) (diff)

comment:20 Changed 4 months ago by epc

I, too, am seeing this problem. Ubuntu (32-bit) is unusable without 3D acceleration, but then there are screen refresh issues, especially with Chrome. I am using version 5.0.10r 104061 of virtual box. I have 2 screens and am assigning 128MB of RAM to the displays (the max). I assign 2 processors to the VM and have VT-x/AMD-V, Nested Paging, PAE/NK, KVM Paravirtualization turned on. Remote capture and video capture are disabled. This would be nice to have fixed.

comment:21 Changed 4 weeks ago by VijayaKrishnaKasula

I am facing the same issue. No refresh happens in guest unless I switch to host and come back. Is there a fix for it. I am using Lubuntu guest in Windows 7 host.

comment:22 Changed 4 weeks ago by VijayaKrishnaKasula

I noticed the issue after I switched to VirtualBox-5.0.18-106667-Win upgrade and installed the guest additions. I tried upgrading to VirtualBox-5.0.20-106931-Win hoping to find a fix in latest version, but in vain. I went back to VirtualBox-5.0.10-104061-Win and uninstalled the latest guest additions and installed the guest additions of VirtualBox-5.0.10-104061-Win, then it works fine.

comment:23 Changed 2 weeks ago by BBBThunda

I'm having this issue on 5.0.18 r106667 Host: Win7 Guest: Debian 8 64-bit w/XFCE

Initially when I start up my VM, usually with the vbox window maximized and auto-resized via guest additions, it works fine for a period of time. Then after having it open for a while, "some event" happens that causes the guest screen to stop auto rendering as long as it's focused. In other words, I can still click/scroll with the mouse, or type commands into the terminal, for example, and they will work, but the screen will appear frozen until I click on some other window or the desktop on my host machine or press HOST, ALT+TAB, etc. to cause Virtualbox to lose focus.

Some usage details that may be helpful:

I code on this VM and rarely have more than my IDE and 3-5 terminal windows open at a time and it has 8GB RAM allocated, so I doubt it's a resource issue.

I'm not sure yet what "some event" is yet - doesn't seem to be caused by the guest's screensaver as I suspected, but it's a rotating screensaver so it could still be a specific screensaver.

Usually the window is maximized on my secondary display when the VM is started or shortly afterward and stays that way basically all the time. I only change it if the guest fails to auto-resize or if the mouse mapping is offset, which happen less than every day.

The secondary display is in portrait mode.

comment:24 Changed 2 weeks ago by aamikkelsen

I also facing the same issue. Using Lubuntu 16.04 and have installed the guest drivers. I notice that the bug disappears if I logout of the system.

Note: See TracTickets for help on using tickets.
ContactPrivacy policyTerms of Use