VirtualBox

Ticket #2771 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

VB guest window no longer resizes on virtual display mode change => Fixed in SVN

Reported by: dimitris Owned by:
Priority: major Component: guest additions
Version: VirtualBox 2.1.0 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description

Host is Debian sid, guest is CentOS 5.2 with 2.1.0 guest additions installed, both x386.

Steps:

  • Start the guest.
  • Boot sequence switches the virtual display to graphical mode.
  • VB window doesn't resize, instead it displays the CentOS graphical boot screen cropped to the size the VB window had originally.
  • Boot sequence now starts X, same cropping present.
  • Machine->Adjust Window Size has no effect.
  • Resizing the VB window manually through the host WM decorations also has no effect.
  • I can "force" the VB window to resize by selecting Machine->Close..., then canceling.

This is a regression from 2.0.6. Also, when I first booted the guest under 2.1.0, still running 2.0.6 guest additions, this problem was not present.

Just to be clear, this is not about auto-resizing, which isn't possible on this guest due to the X/RandR version it runs. This is about the VB guest window not resizing during the boot process, something that worked on different guests since 1.6.x.

Attachments

VBox.log Download (31.6 KB) - added by dimitris 5 years ago.
VBox.log of CentOS boot and Machine->Close... "workaround".

Change History

comment:1 Changed 5 years ago by frank

Please could you attach a VBox.log file of a session when the resizing fails?

Changed 5 years ago by dimitris

VBox.log of CentOS boot and Machine->Close... "workaround".

comment:2 Changed 5 years ago by dimitris

In the attached VBox.log, the Machine->Close... menu selection which "works around" this problem happened at 00:02:42.084.

comment:3 Changed 5 years ago by dimitris

Forgot to mention that before Machine->Close... I tried Machine->Adjust Window Size, but nothing changed in the VM window and no entries showed up in the log (tail -f).

comment:4 Changed 5 years ago by frank

  • Summary changed from VB guest window no longer resizes on virtual display mode change to VB guest window no longer resizes on virtual display mode change => Fixed in SVN

Thanks for this report. In the meantime we were able to reproduce this problem and we think we fixed it. This problem does not occur with every Linux guest, therefore this bug was not recognized during the final testing. And no, installing the old additions wouldn't help fixing that bug.

comment:5 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use